Z-Axis Extension not working


#1

i have installed the z- axis extension for making bigger projects, i started a larger print and it seemed to be working well until it stopped ascending and just kept printing on the same level, when i stopped and pulled the print off I measured it, the Z-axis stopped moving at 125mm, its like the controller doesn’t even acknowledge that its installed. i cant get anything to print over 125mm without messing up, Yes i have tried switching ports, and the 3D software is configured correctly.


#2

I don’t have the extension, but I think I found something in the forums.

Did you upgrade the firmware to 2.11 and tell the controller that the extension is installed?

According to the firmware upgrade notes:

Added support to Z-Axis Extension Module. When you attach the Z-Axis Extension Module to your printer, upgrade the firmware to [version 2.11]. Reconnect Snapmakerjs to the printer. Enter “M1025 M1” in the console and press “Enter”. When the software replies “ok”, your printer is upgraded successfully.
When you want to use the original linear module, enter “M1025 M0” in the console and press “Enter”. When the software replies “ok”, your printer can only print items as tall as 125 mm.
Also, you need to upgrade your software to the latest version and change the settings of the machine to generate G-codes for taller models.

The article has links to the new firmware and software.


#3

You have to perform the above command from the console to tell the firmware you have a longer slide on it. Otherwise it will just stop rising up…


#4

i have that installed seems to still not want to work, i may have to try re-downloading it.

edit: anything i do to the snapmaker i am doing through the provided flash-drive, i have a gaming computer that i edit everything on, and i have the snapmaker in a shop.


#5

I’m not sure that will work. How did you send the M1025 M1 command to the snapmaker?

You have to hook up a computer to the USB port on the snapmaker and you have to connect it thru snapmakerJS and then send commands from the console over USB cable to the snapmaker to change the code. Different than running a g-code program.

Check this… Boot up your snapmaker and then on the handheld controller and go to Setting -> About and report back what the build volume numbers are. If they are all 125mm then you have not updated the unit to the longer z-axis. If one of the numbers is not 125 then you have upgraded it and you need to tell snapmakerJS you have a larger volume.

If the above is correct then Go to SnapmakerJS and under setting (Lower left corner gears), go to machine settings and see what it’s saying the z height is in the software. If it’s still 125mm then that is the largest it will print as the program on your USB key you plug in will be incorrect as the software is limiting it’s height.

There is a custom setting in the machine settings that you can adjust the z height to a taller number. You should really take your computer in, hook up the USB and go thru the process.


#6

You are guilty of the same oversight as me…

https://forum.snapmaker.com/t/downloads-and-updates-for-firmware/1467/11

You use the snapmaker.js software. You connect a USB cable from your computer to your snapmaker, and start up snapmaker.js. Press the “open” button (I think its called open), which connects you directly to the snapmaker.

You will see a black window on the upper left that looks like a dos box. Type in the M1025 M1 command, and it should be done. While you are at it, you should probably do a M1005 – this will allow you to confirm what firmware revision you are on.


#7

Just a quick reminder to all: before typing “M1025 M1” in the console make sure that Snapmaker.js really sees your printer. Looks like it says “Connected to COMn” even if there’s something wrong with the connection.

I’ve spent a pair of hours trying to send the command and checking everything before I recalled that I connected the printer to the wrong computer where CH340 driver was not installed :slight_smile: