Z axis port completely not working

After a few weeks of having my machine and doing many 3D prints I encountered an issue with the Z axis not moving up/down. After doing some troubleshooting tests (switching the Z & X cables/ports on the controller) It was determined by support that the Z axis port had “gone bad” and they sent a new controller module. Great! It worked for a quite a few prints and then mid-print the Z axis failed to move up/down. Same tests pointed to same problem!!! Support said that I must have unplugged the cord with out turning machine off…it was mid-print so I know that wasn’t the problem. A couple other owners suggested a problem with excess grease in the limiter switches so I suggested that to support and they sent pictures of how to open the end of the linear modules to clear the excess. Did NOT help. I had to pay the shipping for the 2nd replacement controller which arrived today…still not working. Please help me troubleshoot.

When I switch cables/ports then the touchscreen allows me to move the Z axis with the X commands; so I know it’s not the cables?

Conclusion of your post:

Your Z-Axis doesn´t work, even not with a new controller, on the Z-axis port.
But they work on the x-axis port?


What happens if you plug the Y-axis to the Z-axis?
Try to switch the conversion module between y and z.
Try to unplug/replug axis by axis to see when the issue occurs.
My guessing is that the conversion modules have to be switched, but this makes not so much sense right now :wink:

I have the same problem. What is the best fix? if you found one.

1 Like

Same issue. Is there any resolution to this? Per support I have tried resetting, unplugging and reattaching etc. M1999 log still shows z axis not communicating.