Z axis bed leveling, Day Zero!


#21


#22

The switch location and loosening is very interesting, thanks Olivier. I wish I had a better handle on the design/construction of the stages and how the limit switch(es) relate to all this; what exactly does “unscrewing the switch a little bit” do? Not clear (tho I’ll look at this more closely and see if I fully understand it better on my machine). Since you didn’t literally remove the two switch mounting screws altogether, I take it the switch remains in nominally the same position in the stage, yes? Does loosening it just basically allow the stage to go ‘a little farther down’ compared to if the screws were tight?
Sean Li did send me the link to the ‘fix firmware’ in a 2nd email, but an admittedly very quick look at that early this morning didn’t appear to me to be making any difference in the bed-leveling Calibration Z-axis problem…I’ll have to look harder this evening, etc. BriHar, I did do a physical Z/X stage swap a few days ago (buried up above somewhere–!), and unfortunately it didn’t make any difference; the ‘new’ Z stage immediately acted exactly the same as the ‘old’ Z stage (and ditto the ‘new’ X stage, which seems to be behaving fine). Frustrating! --Charley


#23

Olivier, —wow. I’m not sure I’m totally following this, but, your note about loosening those two Phillips screws that, from what I can tell, basically causes the Z limit switch to “sag” down a mm or two, TOTALLY changes the Z stage behavior! I was immediately able to perform the full bed-leveling calibration process, and appear to be able to finally move on to, you know, USING the machine! Have other users been down this screwy (no pun intended) road of loosening that switch?? I don’t know about you, but I’m potentially inclined to simply the switch in this condition—I mean, why not? One could even “stabilize” it in this admittedly rather precarious condition, via some judiciously applied epoxy (I do a lot of that sort of thing in my real life; laser/photonics R&D…).
Anyhow, I’m frankly quite amazed at how this minor 1-2 mm “shift” of that limit switch, had such a dramatic impact on this stage behavior. I guess I’d still like to see Snapmaker “get this right” on my machine (eg, is there still a fix here, as Sean at Snapmaker has suggested, or, is it really simply some goofy hardware/tolerance issue related to the precise position of the limit switch?), but, I feel like I can actually proceed near term now. Thanks—


#24

Snapmaker sent me a link to firmware v2.8 this morning, that apparently is specifically addressing this Z axis/limit switch/can’t-get-close-enough-to-calibrate issue I’m having (and that others are having from what I can tell, too). I guess I’ll see if loading this firmware results in my being able to both bed-level calibrate, and tighten the Z-axis limit switch back up like it should be. If so, I’m truly finally good to go, I reckon! --Charley


#25

No, I don’t appear to be able to download and use the update.bin v2.8 file; my machine immediately blinks fast, only (i.e. no slow blink for 5 s), and in “About” I still see v2.4 on the display. The provided USB stick is FAT32 no problem and the .bin file is in the root directory, and seems to be working fine as far as I can tell.


#26

我昨天收到的机器,应该是同样的问题,用触摸板下降Z轴,动了几次就不只能上升不能下调了。每次Homing,都是越来越高一直到顶


#27

Hi bean, sorry, but I can’t read your reply due to my (lack of) non-English language skills. Can you reply in English if possible? Thanks.
Latest here; with my firmware v2.4 (won’t upgrade it seems) and my Z stage limit switch loose, I’m making some initial prints. Made a “XYZ cal cube” fairly successfully (a little warped/wonky at the base) and I’m now trying to print a part I designed in Solidworks some time ago. Having bed adhesion issues with it (PLA provided with machine)but will look into some of the tips provided in Troubleshooting video, etc. Progress…


#28

Hi Chale44incolo,

I received our purchased printer this week. And i am having the same problems.
The z-axis will only go up and not down when using the “home axis” function.

I have swapped the Y-axis with the Z-axis to see if it was a hardware problem.
This was not the case. So i leaned towards a software problem.

My printer came with a 2.4 version and downloaded the 2.7 from the website.
When using the usb-stick delivered with the printer i was not able to update the firmware.
When trying with a smaller size (4GB instead of the 16GB usb-stick) i was able to update the printer to 2.7

This however did not fix the Z-axis problem.

Than i came across this forum-topic. Loosen up the z-axis limit sensor did not make sense to me.
I tried anyway, but no luck for me. Than i pushed it a bit inwards while pressing the “homing axis” function.
Than i managed to get the z-axis down for the first time. This made me able to calibrate the machine.

But after power-cycle the printer, it had the same problems again.
What i think is going on, is that the sensor is very sensitive and due to the movement of the x-axis the z-axis sensor is triggered. Meaning it won’t go down.

I am not sure about this, but loosen up the sensor gives the sensor a bit of room to wiggle.
However, i still find it strange that when swapping axis, the problem only occurs on the z-axis.

I am looking forward to a solution, to fix this bug on a brand new printer.


#29

Hi R.,

As Bill Clinton once said, “I feel your pain…” Well, loosening up my machine’s Z-stage’s lower limit switch (maybe the only limit switch? Not sure it’s actually got one in the upper end of it, since you can get the thing to where it ‘clatters’ up at the top end, i.e., trying to go up higher but simply can’t mechanically) is how I’ve still got my machine set up, and it does indeed result in bed-leveling cal ok and basically everything else about the machine, ‘working right’…but it’s not satisfying to leave it like that, that’s for sure. I’ve confirmed really decent leveling/cal, and printed several basic little parts that all turned out pretty good (now I’m into the wide world of getting PLA to stick to the bed well, and all that). I sent Sean Li a follow-up a week or so ago, and noted how I sure don’t want to have to leave my brand-new machine in this ‘loosened-up Z switch’ condition and whether it’s time to start talking about sending this unit back, but I haven’t heard back from him on that so far.

I haven’t had any luck updating firmware, still stuck at ver2.4 I believe. I may try a different stick like you did. That is certainly interesting that your successfully upgrading to 2.7 (i.e., your touchpad actually says “ver2.7” on it in the “About” page, now, yes?) didn’t fix this Z problem, as (from what I can gather) its main purpose is to do that…thinking a bit more just now, I wonder if it’s just basically a subtle but show-stopping issue with the thin steel ‘lever’ at the top of the switch, simply needing to be ‘tweeked’ (bent) downward a mm or two—eh? (that is, with it back in ‘tightened screws’ condition, as it should be) I may look into that this weekend, now that I think of it.

Yep, I swapped two stages, too, and the bad behavior (pre ‘switch loosening’) was identical on the ‘new’ Z stage.

I’m not real sure, but I think I had to loosen up the switch a lot in my case (versus Olivier’s comment above, about loosening it ‘a little bit’), to get the behavior to result in proper Z behavior; i.e., the switch needed to sag downward a good 2-3 mm for my machine to suddenly behave correctly. I doubt the two phillips screws are very much engaged in the switch body at all, in my case…

Good luck with your issues there, I hope you’re able to make more progress and/or get some solid resolution with folks at SM. I’ll report anything potentially useful later this weekend, too. --Charley


#30

Short update; I successfully updated firmware to 2.7, using a different USB stick (tho maybe I was just goofing up with the SM-provided stick earlier, not totally sure). Since my Z limit switch is still loose (the machine is working so well with it loose, I’m a little hesitant to change anything about the switch…), I’m not sure if that firmware update affected the Z axis homing issue or not. Anyhow, printing up a storm now (I’m currently in “everything looks like a lens cap” mode here, ha) and enjoying it immensely. I’d note that I’ve already got a lathe and a mill, full home shop, etc, but am finding myself enjoying the whole mini-CAD/CAM experience re: Solidworks>SMjs at the kitchen table!


#31

Hi Charley,

Good to hear you have successfully updated your firmware.
Mine indeed now says 2.7 on the display.

For me this temporary solution is not working. Once i have powered down the printer, and i want to use the printer the next day, the printer is not homing as it should.

I am in contact with my supplier, and will give you an update when things have improved.


#32

Hey charley,

I also was advised to use the firmware 2.8 from the forum : Downloads and Updates for Firmware

This has fixed my z-axis homing problem. The only problem i now have is that the y-axis (heated bed) does not move to its zero point when starting a new printjob.

Temporary fix is to do a manual homing action. Than i am good to go for a new printjob.

Cheers.


#33

Thanks, Ruud. I’ll try firmware ver2.8 here in the next day or two, tighten my Z-limit switch back up, and see if all is well or not with respect to Z stage behavior. (I guess I can always reverse engines and loosen up the Z-switch again if I have to!). To date, I haven’t had any issues with Y-axis (or X-axis) stage behavior; I hope you resolve that, too. Charley


#34

Ruud, did your Y-axis problem arise upon updating firmware to 2.8, or, did you have that problem previously? Charley


#35

So just got my Snapmaker and had the same issues described above. I fumbled for a while but was able to get everything working. A few consolidated notes for those having these issues.

  • use the USB stick included (if you’re on a Mac, you can’t format Fat32, so DON’T reformat the stick!)
  • if you are at 2.4, upgrade to version 2.7 FIRST (you won’t be able to jump to 2.8)
  • then after a successful 2.7 upgrade (go to settings -> about to check your FW)
  • apply the 2.8 firmware, and verify in the about
  • go into settings -> calibrate, press RESET FIRST. This will re-find the limit switch and do a rough re-home
  • then calibrate as usual using the calibration card

#36

Karig, your clear and concise notes here are gold. I think you’re totally right about how one has to update to firmware 2.7 before one can proceed to 2.8; I didn’t do that knowingly In my case, but, nonetheless happened to update from 2.4 to 2.7 to 2.8 (just checked in “About” and there it is, 2.8!) while using my USB stick for other purposes (trying to load a print file via the stick…which didn’t seem to want to work…but in the course of that, I’d also ended up with the two update firmwares on the stick in succession and so they loaded successfully while I wasn’t even paying attention!). I just now tightened up my Z limit switch, did “Reset”, and voila, I’m finally able to do bed leveling 100% “properly” for the first time. Wow. I’m sure glad there are folks like you contributing here, as I have to say, “direct” help from SM itself has been pretty lacking. Though to their credit, they did pretty quickly craft up ver2.8 to address this specific issue—they’re just not much for telling you what to DO, you know? But anyhow, at long last I’m 100% happy and feel like I can confidently proceed on with my machine without a nagging sense that I got a “Friday car”, eh. Charley


#37

Hey Charley,

Before the firmware update to 2.7 and 2.8, i was not not able to print like i do now with 2.8.
I only noticed when i had installed 2.8 that the y-axis is having this issue with not homing with a new print job.
A simple work around is to do a manual homing after you turn on the printer.

I noticed that even with the manual homing, sometime the y-axis doesn’t want to move in the correct direction.
I have to do a 2nd homing action before it goes back to its 0 position.

BTW. I was able to use the delivered USB stick eventually when i reformatted with FAT32. But i have reset the cluster size to default before i clicked format.


#38

Sorry for the problem you ran into.
Please fill in the warranty request, and attach a video or several pictures of problem and describe the problem in details.
We will transfer several questions to you from our engineer later and instruct you to locate the problem.
Once the problem is located, we will provide a solution to you accordingly.
The more detailed your description is, the fewer questions we will have.


#39

Hi Steve,

Thank you for your question.
I have already supplied detailed videos and step by step procedures via my local supplier.

If there are any updates on that i will comment here as well.

Cheers.


#40

There is definitely some funkiness with 2.8. when I go to jog controls, it randomly moves axis around. I also had an issue where after canceling a print, it seems to be confused and when homing, the y axes kept creeping backwards. a power reset fixed that issue. Definitely some bugs in 2.8, but at least the printer is usable.