Auto-leveling is...wonky

So, we got our A350 3 days ago and after much twiddling, have made some progress, but are still struggling with adhesion and have not been able to get a successful calibration print yet.
Setting the myriad other issues aside, I think the z-axis level might be an issue, but at this point have no trust in the auto-leveling process anymore and was wondering how to fix it.
I have done the auto-leveling/calibration process a number of times, and about 1/3rd of the time it freaks out in the upper-right corner and goes down so far that it forces the nozzle into the print board to the point that there is now a hole in the board.
The first few times I auto-leveled, it went through all 9 points on its own (though it would often do that hyper-press in the upper left), after which I would manually adjust the z-axis as prescribed. The last few times it tells me I have to adjust the last point manually.
Also, is it supposed to end up in the center of the print grid, or off to the left by a few centimeters? Because it always ends up on the left.

If I were to try to manually calibrate the entire thing myself, what would be the best way to do that?

Yes its correct, you must calibrate the last point manualy, to set the proper z height.

You can set the autocalibration off with the touchpad under settings 3d printer.

Then you can choose how many points are beeing used to calibrate the bed.

Sorry stefix - didnt mean to reply to you.

Mouriana

Auto calibration, if everything is proper, is not terrible. Its not the best, but shouldnt be crashing.

Firstly:

the position of the last calibration point is not dead center, because the sensor on the 3dp module is also off center. no worries there.

it is normal for the last calibration point to be done manually, and sometimes will start relateively high up, i’ve had it further than 2 mm away before.

Just gota set that position manually by moving it down til you can space it properly.

once you have the calibration card under the nozzle with a bit of tension but can still slide it, bump it up another .05 before saving

We have seen a lot of people say their nozzle crashed on the bed, and 9/10 times there is an installation error with the linear modules not mounted to the base plate properly or the print bed being upside down (nuts should be facing down away from the print sheet). Got some pictures?

There is also a chance that the sensor is improperly adjusted and needs to be moved, but lets start with the installation then also lets talk about:

There is a firmware bug which can contribute to the nozzle hitting (from what ive heard anyhow, havent seen anyone have that happen since i got mine), which you should update if you have not already.

after we address all of the above, lets talk about getting started if you are still having problems, we can recommend a sample print and help with settings.

Thank you MooseJuice, and sorry so long to reply. We were getting frustrated and I had to step away before I broke something. :stuck_out_tongue:
Knowing that the last position is not dead center is good. I wasn’t sure about that, and it helps me have a little relief.
The last calibration point is usually about 8-10 mm too high. I’m not concerned about that so much–adjusting it is easy enough–but knowing to adjust it back up .05 is helpful, thank you!
It’s the back right corner where the nozzle was gouging into the build plate inconsistently that is the primary problem. We have been working to try to adjust the sensor. Is the adjustment screw supposed to go in while making the sensor wiggle around? It’s making me nervous.

I set the settings to the most minute (like, the 2 dozen calibration points instead of the default 9) and will be manually adjusting it when we finish adjusting the sensor. I could try the auto-leveling again, but at this point I just plain don’t trust it!

Other steps we’ve done:
-checked for firmware updates
-calibrated the extruder (it was pretty off)
-swore at it a lot
-tried gluestick (poorly)
-applied blue painter’s tape (much more carefully)
-lots and lots of isopropyl alcohol wipe-downs
-cried a little

I commend your ability to walk away from the frustration without smashing the machine, know that you are not the only person who has had to do so.

Feel free to manually level it, but if your nozzle is crashing it sounds like something is assembled wrong or the sensor needs adjusted.

I would presume for sensor adjustment you turn the screw counter clockwise to loosen then slide it up or down then clockwise to tighten it, but you should read about the proper sensor alignment on the snapmaker page before fiddling with that. i have never actually done it.

.05 is my personal favorite number, youll get a feel for that over time.

Getting material tostick to the plate is a healthy balance of heat, distance and flatness/calibration.

I am just much more concerned about the nozzle crashing on the bed.

can you please photograph the assembly of the machine, specifically a shot that would show the webbed aluminum plate that the heated bed sits on(from the side) and an overhead showing how the linear modules are attached to the main base

I have located this article for you:

How to adjust the probe/proximity sensor in the 3D printing module? – Snapmaker

I guess its possible something is just really out of whack on your machine but id like to think that its something we can address without needing support to send you parts for, but you can always email support@snapmaker.com (it can be a lengthy process).

you said “checked for firmware updates” - the original firmware on the snapmaker does not have a way to auto update, and you have to download the firmware update and move it over via the provided USB drive.

There is a forum post from support with the most current firmware available and should have instructions for doing so as well. after the first update, you would be able to update the firmware directly from the settings, the feature didnt work or exist in the original firmware.

Yes, I forgot to mention that we made sure the bed was installed correctly.
And yes, I downloaded the update manually and installed via USB.
And yes, those are the instructions I used. They are very poorly written, but between that and some other helpful forum posts, I’ve been able to suss it out. :slight_smile:

Part of the confusion is that, without any changes on our part, doing the auto-leveling calibration multiple times will give different results. For instance, the first time or two it would seem to calibrate okay, then the next 3 times it would fail to sense the back right corner and go down until it ‘hurt itself’ (i.e., gouged into the build plate). Power cycling helps SOMETIMES but not always (I’ve also had to power cycle when it gave me an ‘unknown error’ when trying to run a calibration print.

Honestly, I’m leery about reaching out to support as I have not seen anything nice said about them anywhere, but if this continues i will do so.

I should also note that I know that adhesion is a complex thing; that is one of the frustrating things about this process. Is it the cheap Snapmaker PLA? Is it the room temp? Bed temp? 1st layer speed? Extruder speed? Nozzle temp? Software or hardware issues? Our overall ignorance? Our ninja cats breaking into the room to jump on the bed when we run to the toilet? The alignment of the planets? The Force? Current lack of an enclosure? WE DON’T KNOW.

Here is a pic of the connection. As far as I know, this is correct.
Overhead view. Note the blue tape in a (failed) attempt to achieve adhesion.
More full view of the thing, just in case there was something I missed. Also, to show off how trashed my craft room is now because this sucker is HUGE (which I will like. Eventually. Once I get it working.)
Back view. Note that the print module is still in the very low position to finish adjusting the sensor. Will move it back once we get that done.

4 screw holes on the tool head, go in 4 holes on the mount

image

Pictures for reference
image

Your linear module is not right.

They are sticking out past the build plate. they should be sitting flush inside the grooves

3 Likes

i responded to brent accidently. you have an installation issue:

image

image

your linear modules are not in the grooves properly, they are offhanging the plate.

but yeah, the snapmaker pla that came in the box is also a major issue. additional spools purchased are ok but the one in the main box should be thrown away, it causes problems for EVERYONE in different ways.

if you need more info ill try to find you a diagram, but there are grooves that those modules fit into and you are overlapping them

seems brent also noticed the tool head is not mounted properly

the aluminum webbed plate is mounted in the correct orientation though.

see post above mine :smiley:

don’t feel bad we get a couple a week with the linear modules mounted wrong

3 Likes

I say we first get your machine assembled properly, then we can redo the calibrations and try again

try to print a calibration cube from thingiverse first to start with after doing the calibration as discussed

XYZ 20mm Calibration Cube by iDig3Dprinting - Thingiverse

From there you should see success, that is an easy print, and then we can start talking about the complexities of warpage and so forth.

OH! Thanks! Fudge, I can’t believe we didn’t notice that!

1 Like

Calibration prints were what we were trying to do, but now I know we need to move some stuff first. :slight_smile:

Y’all are the the best.

1 Like

Firmware is updated, extruder is calibrated, proximity sensor is calibrated, auto-calibration has been run successfully, print board has been prepped, and most importantly, WE PUT THE DANG LINEAR MODULES IN THE RIGHT PLACE.

Currently loaded up a calibration cube and it’s heating up to print.

This reminds me of that calculus test I took way back in the day when I did all of the derivatives and integration correctly, then messed up some flippin’ basic addition of integers in the middle of the problem. Lest anyone ever think I have brains. :stuck_out_tongue:

1 Like

You moved the 3dp print head too right? :smiley:

sounds like you’re gona have yourself a cube!

1 Like

Cubes are out. Loooong cubes are in Printing very skewed

2 Likes

Well if we can get the basic cube to work, we’re gonna print the cali-cat.
Because it has the angle, but it’s also cute. :grin:

Oh…yeah, we moved the 3dp print head.
We forgot to load the filament back in for a minute, though. :stuck_out_tongue: :stuck_out_tongue_winking_eye:

1 Like

Let us know if you need any more guidance :smiley:

have fun!

im about to test filament runout myself… hopefully it works.

edit: to my surprise, it worked flawlessly!

Unlike power failure recovery, the head returns to home position to be reloaded and resumed so it can know where it is and not smash things!

1 Like