Z axis bed leveling, Day Zero!


#1

Hi all, brand new owner here, sorry! So “Day Zero”, put the unit together a-ok and began the bed leveling process, “corner 1” per instructions. The Z axis won’t jog “Down” from the Home position by more than a few mm, and it simply stops responding to the pad button…grrr. Tried port 4 instead of 5, no dice. Also tried cycling (duh) and reseating the RJ connectors (ditto). I’m already stuck! Any thoughts would be hugely appreciated, thanks all—Charley in Lafayette CO USA


#2

Hi all, bit more here; I updated the firmware via the web and the USB stick, no change. I’m also finding that the Controls>Jog commands aren’t so happy either, in Z and I believe X, as well. Heck! Do you think I’ve got a defective controller unit out of the box…? Charley


#3

Sorry, and a bit more here (maybe something I note will cause one of you to provide the necessary “You doofus, what you need to do is…” feedback!). So the Calibration>”Down” jogs process tops out at sixteen steps at 0.5mm/step, i e, A maximum of 8 mm “Down”. So, I can never get to the 0.1 mm/“paper almost won’t slide out from between table and nozzle” calibration condition. I’ve come to realize that I can manually move Z down, ok, but I still can never get closer than a couple of mm from the necessary Z condition to obtain good calibration on Corner 1, or 2,3, or 4 for that matter. So, I’m still stuck and/or doing something dumb…?


#4

Have you confirmed everything is in the correct mounting holes? You don’t have the print head mounted too high on its plate? The mount plate should sit level with the top and bottom of the module.

It sounds like it could be physical rather than software, maybe take some pictures from front/side/rear and post them up.


#5

As @WokkaWokka says, you’d be amazed how often people don’t mount the components exactly as described in the instructions
Also, did you perform a reset?


#6

Hi Wokka and BriHar, thanks. Yes, I’ve definitely done the Calibration>Reset process multiple times; currently the Z axis stage is in a condition where it’s ‘whacking repeatedly’ up at the very top of its range, surely not right…one thing I’ve done (maybe big mistake?) is I’ve manually moved the Z stage downward by hand with the unit turned off; that at least got me within the ~ 2 mm of having the nozzle in contact with the bed plate that I describe above, but that seems to be as close as I can ever get it. I

get the impression I may have screwed up the stage’s knowledge of its home position/limit switches, or something…tho it did seem to wake up that way upon first ever turning the unit on yesterday. Another thing I’d note is that in Controls>Jog Mode> , it will not go “-Z” at all; and if I hit “+Z”, it does the ‘whacking’ thing again up at the top of the stage. Again, as if I’ve somehow messed up the ‘homing’ of it, or something?
I sure think I’ve got the print head screwed into the correct tapped holes in the X stage (top edge of head in plane with the top edge of the X stage bracket), but I tell you, I’m nearly tempted to move the head DOWN one set of bracket holes, as, in my currently goofy condition at least, I do believe I would at least be able to get ‘within range’ of the 8 mm Calibration jogging range, you know? (i.e., I can get within like 2 mm of being ‘in range’ now, and if I moved the head down one set of holes, I’d be within that 8 mm Cal range…seems like ‘cheating’, I realize, though–and perhaps a potentially dangerous thing to do…)
Finally, I guess I’m thinking I might do a bit of disassembly/reassembly and trade out the Z stage for one of the two others (which both seem to be acting just fine far as I can tell). Maybe I’d then see that ‘new’ Z stage behave correctly in terms of bed calibration…? Thanks again–Charley


#7

Well, I just tried swapping Z and X stages (with NO monkeying with the X axis stage bracket position ‘manually’), and long story short, seem to be in the same predicament; Controls>Jog Mode> “-Z” still won’t work; only “”+Z" jog will, until I’m stuck up at the top of the Z stage…not good. (X and Y stages will both jog “+” and “-”, no problem). I’m frankly starting to think I have an actual Controller hardware problem, though, certainly still possible I’m just doing something increasingly dumb here…? Charley
–Correction; I’m finding that the Z stage WILL in fact jog down two 10 mm increments if I jog it up to its top limit, but that’s it; additional button pushes on ‘-Z’ jog result in no downward motion…


#8

From your photo, the assembly seems to be correct.

You mentioned you updated the firmware - I’ll assume to the latest version 2.7.

Did you also update the Snapmakerjs to version 2.5.1? If not do so.

Connect the computer or laptop on which your Snapmakerjs is installed via the USB cable. And check that the settings, specifically the enclosure setting. As you have no enclosure this should be OFF.

Check the axes with the controls from the software.

Finally disconnect the computer and reboot the printer, and reset.
Does the calibration work now?


#9

Thanks; I’m back to the proverbial world-o-work this AM and so will check on these later this PM. I’ll check the firmware version that I downloaded; the Snapmakerjs version I downloaded from the site on Saturday I’m seeing on my laptop here is 2.5.1, interesting. I downloaded the 64-bit version as that’s what this machine can use, hmm, I’ll look into that, too. At any rate, I never connected up to the printer via laptop/SMjs software as yet, so I’ll do that and see if your suggestions below help get the Z axis “working right” (i.e., able to home correctly, I think, and actually take the Z axis down to the point that the nozzle can be fine-tuned in separation from the bed using the corners-calibration process, finally). Thanks again–Charley


#10

BriHar, I connected to the printer via USB last evening and managed to make some sense of the Snapmakerjs ver 2.5.1 software (I couldn’t find any ‘manual’ for that software anywhere–? Unclear what functions like ‘temporary zero’ing’ is in the Axes controls are, etc…). Using that softw, I was able to actually adjust the Z axis down to nominal contact of the nozzle with the bed; but invariably when I switch to touchpad bed-leveling Calibration, the Z axis immediately jumps up a couple of cm and I’m once again unable to use the 8 mm Z axis Calibration range adjustability to obtain calibration on each corner of the bed.

Sean Li at Snapmaker sent me this message last PM, “Our engineer analysed several cases like yours and they find that there is a bug with the manufacture defaults of the firmware.
Please download the updated firmware on the attachment and install the firmware according to the instruction video: https://www.youtube.com/watch?v=GCxzZwxJ_mU” I didn’t find an attachment in his email though, and I’ve asked him if he still needs to send me that. I’m unclear on whether this firmware would be different than the latest version provided at their site (Snapmaker-GD32Base-2.7), TBD. That firmware update (which I did on Saturday) didn’t solve this problem, at any rate. thx–Charley


#11

Hi we just recieve our snapmaker3D today and we have the same problem. The Z axe don’t go down…


#12

Hi @Olivier Welcome,

Which Firmware version do you have (see the about page on the touch screen)?

Does the Home function work properly? Have you Reset?


#13

It was firmware 2.4 and we update to 2.7 and it don’t change anything.
The Home make some movement but the Z axe goes only upward. It seems the endstopt gives a wrong signal.


#14

Did you make any tests with 2.4 before updating?


#15

Yes, and we had the same problem, that’s why we update the firmware. It’s for us a problem with the end stop switch…


#16

Just to be clear, when I refer to the Home function I don’t mean the Home tab at the top of the jog mode screen but rather the HOME AXES function from the Controls page which must be performed after starting the machine in order for it to establish where the limits are.


#17

Yes it’s understand when we do that it should find the end switch to calibrate the 0 point for each axes. But for the Z axe it goes only upward and not downward like the switch is always touch


#18

Then it might be possible there is indeed a mechanical problem - either a defective switch, or perhaps the cable (I seem to remember someone mentioning that the RJ connectors were not properly attached on a cable, albeit that was referring to one of the cables to the head or the bed).

At any rate, in order to help corroborate/localize this, try switching the Z and X modules, not just the ports, but physically dismantle and exchange one for the other.


#19

We unscrew a little bit the switch and now it works but I don’t think it should be a definitive solution


#20

If you could perhaps upload a photo highlighting the adjustment you made, maybe @parachvte would be able to provide a definitive solution. :relaxed: