Why does it scar?

Hello.

I have the SM 2.0. So far, it looks really good. It is crazy loud though… I wish SM would consider the noise in their design (by fat the biggest oversight in a near-flawless product).

I’m seeing a problem, however, on my prints. Whenever I print something flat, I always get scars on the surface. This is not new… It happened on SM1 using cura, S3D or snapmakerjs. It also happens on my prusa i3Mk3… it is the one problem I have not seemed to be able to overcome – but, it definitely looks the worst on my SM 2.0.

This particular project I’m working on has long faces on it, and is going to use a lot of media. It will be a very expensive print, and I’d really rather not have huge gashes going across the front, sides, or top.

I’ve been through the settings in Luban, but I cannot find anything that helps. Z-hop doesn’t seem to address it… in S3d, even checking the box to avoid crossing permiters isn’t a cure (it helps, but isn’t a cure). Anyone have any idea what I can do here? I’m hoping that there is something in Luban I’m missing…

Thanks.

-mg

It always did seem odd that SnapJS follows the outer walls for most travel, then cuts across the surface when traveling for layer change.

Cura has some options under the Travel section. Combing Mode: On, and Avoid Printed Parts When Traveling might be what you’re looking for. Or maybe Coming Mode: Not In Skin. At least some of those are hidden by default, so you might want to go through all the hidden setting for Travel and see if something looks good.

If you find a combo that works, please post back. Most of the time I don’t care, but there are times it would be worth the extra print duration.

ZHop helps with that - and interacts with other settings in Cura. I’m always using Cura now, so don’t remember if Luban supports that.

As I mentioned, Z-hop has never helped me with this. No matter how high I “hop” it, it still does what it wants. The “hop” only seems to last a brief moment, then the nozzle moves back to where it was. It doesn’t say lifted until the next time it extrudes. It seems to me it should lift, stay lifted, move over, move back down, then extrude. Instead what seems to happen is that it lifts, moves slightly, moves back down, then moves over (across the body of the print – leaving the line) then extrudes.

On some prints, it is a huge problem. On other prints, it is barely noticeable. Typically when I have a long, flat field with raised lettering or something like that on it, it scars. I can pretty much count on that.

I believe some settings in Cura (Luban and Snapmaker JS use Cura Engine 3.6) override z-hop, can’t remember which ones, I think possibly combing might be one?
(some of those settings that do this may not be visible in Luban)

MANY aren’t visible or just don’t exist. Cura is up to version 4.5.

1 Like

Yeah, 3.6 is significantly behind now, so many things were added in 4.0 and there has been a steady stream of additions in every version since. I wonder whether there were huge changes in the interface with Cura Engine between 3.X and 4.X and maybe that’s why it hasn’t been updated? Hopefully now that the Luban source is available we may be able to bring it up to the latest version of Cura Engine.

Hi, you need to select the option “Z hop When Retracted” in Snapmaker Luban. If not, the nozzle will cut the plate.

1 Like

@Edwin

Oh, nice! I’ll try that next time. I missed that one. The flow of Luban still feels clunky to me… but I know it is trying to accommodate the laser and cnc functions as well. It will take some time to mature… but I will definitely try that. Thank you!

-mg

1 Like

Ok… well, that definitely did not work. I just made a large print, and it scarred from corner to corner. Even with the “Z Hop When Retracted” box is checked. It seemed to work on a test print, but apparently things change when the top layer is recessed (which always seems to be the case for me). This print, was going to be a small drawer… I had to stop the print before it was finished, however, due to some other issues. But here you can see the scar, going from corner to corner… it is huge, and unsightly.

Hey @moonglum!

This is an issue, anyways.

The z-hop should hop for 1mm, did you see it in the right moment?- I am not sure if retraction hop is the same like hop if crossing the print.

I see in the config file of luban some other options, which are not displayed.
May you try another testprint after changing following setting (open the file with editor and save it to the same ending):

Installpath\Snapmaker Luban\resources\app\resources\CuraEngine\Config\fdmprinter.def

“retraction_hop_only_when_collides”: {
“label”: “Z Hop Only Over Printed Parts”,
“description”: “Only perform a Z Hop when moving over printed parts which cannot be avoided by horizontal motion by Avoid Printed Parts when Traveling.”,
“type”: “bool”,
"default_value": false,
“enabled”: “retraction_enable and retraction_hop_enabled and travel_avoid_other_parts”,
“settable_per_mesh”: false,
“settable_per_extruder”: true
}
Switch from:
“default_value”: false,
TO:
“default_value”: true,

Waiting for the reply as well and I will do the same issue later.

@xchrisd, That is interesting… I will have to look into that, if I choose to continue to use Luban, that is. There are other issues I’m having as well, but they are really not relevant to this thread. I’ll start another for those issues, when I get a moment to do so.

Thank you very much for this insight… it is definitely worthy of investigation.

-mg