Original rebooting on large prints

The problem looks similar to others posted where there seems to be something causing the controller to reset. However, I’ve replaced the power supply with a 24v 6 A supply, it’s on a UPS, and I think after watching video of it, and being able to find ways to reproduce it, I think I can confidently say it is not a supply power issue. This isn’t inside the enclosure, so it’s not the old door opening safety mechanism issue either.

The symptoms are this: print will be running fine, and anywhere from a few minutes to a few hours into the print the print head will stop moving, the blue flashing light on the controller will turn off (unclear if all of the fans also stop), the screen will stay in the sleep mode. A few seconds later there will be a click, the screen will flash the white boot screen momentarily, the blue light on the controller will start flashing again, and the screen will show the temperatures set to zero and the progress bar at zero. The power supply and UPS remain operating normally the whole time, and I believe it even happens if I leave fans off, so I don’t think it’s a power supply issue.

I’ve noticed it only seems to happen on models that are not just big, but that take up a lot of continuous space on the build plate, say around 1/3 of the surface area or more. I’ve done big multipart PIP articulated models that printed for 16 hours without issue. But put in a model that has a raft a couple inches square (like a 190% scaled up benchy at 114 mm x 58.9 mm x 91.2 mm) and I can get it to reset anywhere from a few minutes into the raft to a few hours into a print.

I have made some modifications to the original:

  1. Z-axis extension installed (doesn’t seem to be the issue)
  2. new Noctua fans installed on the controller and the print head
  3. New part cooler connected to the print head power with a pot to control fan speed manually.

At this point I’m wondering if it has to do with:

  1. Thermal control issue when trying to heat the bed with a large print on it (maybe it messes up the controller and it triggers a runaway protection?) - I haven’t been able to observe the temperatures because the screen will be in the ‘screensaver’ mode. I’d love to know if I could turn that off…
  2. thermal instability in the controller (something in the controller gets too hot and the controller reboots) or maybe another component
  3. Electrical issue in the controller (something not behaving and the controller rebooting to try to recover)

I’ve reached out asking if support has any ideas, but I figured I’d check here too. Anyone run into this? Or have ideas of what it might be?

I am a little worried about buying an even beefier power supply and seeing if that helps since this one is already like 50% higher power than what the machine came with, and I’m fairly certain the loads I added wouldn’t add that kind of draw), so I don’t expect it would make a difference.

Hi Benebarba, you can contact our support for possible solutions at support@snapmaker.com.

I tried through the contact form, but I’ll send an email direct and see where it goes! Thanks!

Figured I’d let folks know that after contacting support, they said it sounded like I needed a new controller. My machine was just still under warranty so they are sending me one.

I’ll update when I get that and get it installed.


received the new controller, installed it and updated the firmware. Tried a print, same issue. Rebooted partway through a raft on a large part that had problems with the old controller (but at different points in the print.

Going to try something smaller and try this same print again.

Hi Benebarba, does the problem still persist?

If your controlboard is new, i would suggest to check your cables and connectors.

What slicer do you use?
I remember there were gcode problems a long time ago (it was about commentaries in a new line instead of after semicolon), may you try slicing the model with a lot older version of luban to verify its not the gcode?

1 Like

Sorry it took so long to get back to this:

Yes, problem still exists. I’m going to have to figure out some more thorough diagnosis, because each individual component seems to be OK, based on the overall response.

Originally, I was using Cura 5.2.1 which was able to produce prints just fine until I went to large ones. I used Luban 4.4.1 (I think, most recent) and Eamon from support suggested I try 3.15.2.

Same behavior regardless of slicer.

Eamon also had me monitor temperatures, there was no sign of runaway - temps were +/-1-2 C of the setpoint right up to the moment it stopped.

Smaller print that worked fine on the old controller also worked fine on the new one. Larger print that failed on the old controller failed on the new one too. Re-sliced large models also failed (regardless of the slicer being used)

I’m afraid I’ve run out of patience with this, as it worked well for 8 months and now I can’t use it for anything reasonably large (including things that once printed fine) and will probably be looking to sell it off for parts and get a printer from a different brand unless support can work some sort of magic.

one thing I might do before I call it quits is to remove all of the fans I replaced, and see if it works. I doubt that’s the issue, since the size of print should be irrelevant to them, but it’ll truly be the last thing I can think of to check.

At this point, after being directed to try the laser print head, and having Luban 4.5 not even load correctly after installing, I’m calling it quits with this machine.

I’ll be opening a forum thread to try to see if anyone wants the parts so I can put that toward a more reliable machine.