vCarve Post Processor no longer working

I’ve used the vCarve post-processor successfully in the past for both standard cuts as well as 3D stuff. But I haven’t use the CNC module in a while and I just created a very simple set of circular cuts in vCarve 11.5 to make a collar for a post and when I run this on the Snapmaker A350 it simply moves off-center and starts drilling down.

Here’s what the design looks like in vCarve.

And here’s the .cnc output passed through the latest official vCarve post-processor from https://github.com/Snapmaker/snapmaker_cnc_post_process

Here’s the output file.
ParasolCollar_CNC.cnc (71.6 KB)

I tried doing this in Luban since it’s just a couple of circles, but it completely screwed up the dimensions. The outline cut I chose created a 48 mm hole which I don’t understand at all as 37.3 + 6 does not equal 48. And the cutout piece has a diameter of 35.6 mm. WTF?

It looks like there’s no way to choose an inner cut so I’ll need to design the cut to follow the path and manually subtract 1/2 the diameter of the bit that I’m using if I can’t get the post-processor working.

Any hints?