CNC Post Processor Ask for Testing

As CNC post processors are being frequently asked, David drafted post processor for Fusion 360 on Feb.

Now we drafted two more post processors for FreeCAD and ArtCAM, you can find them at our Github repo https://github.com/whimsycwd/snapmaker_cnc_post_process:

Have a try and leave your feedback here, or you can directly open PR and help us improve the post processors/documentation so that other people may benefit from it.

8 Likes

I am a long time user of Vectric Aspire. I am interested in your machines but only if there is a clean postprocesser for Vectric that works for the CNC. Very glad you have developed for FreeCAD and ArtCAM

I have read that GBRL metric post processor kinda works but in this forum there are issues.

To be honest using Luban is good for some but for others with more advanced needs we need a high level CAD tool like Aspire. Snapmaker seems to be providing very good hardware ayvery reasonable price points. Developing a modeling software probably should be beyond your scope.

Anyway sorry if I hijacked your posts but I feel many other could benefit from a robust post processor and machine flow not locked down to using Luban.

2 Likes

Having Snapmaker 2 A250 i relay need a post processor for ESTLCAM I have tried with F360 but it is a bit for complicated for my skills ESTLCAM is a easy to learn and a pries that suits most wallets.i hope you will look in to it soon
Regards
Carl Johan Feddersen

Hey, I just recently tried to use the FreeCAD post processor. Sadly I were not able to get it going. When I try to generate the gcode file, there I get an error message within FreeCAD and no file is generated. Is there anyone who got it working already and can provide some help?

What is this error message?

It is hard to read, as it is only partially displayed and only for a second or so. When I am back at my computer I will try to make a screen shot. Or do you now if there is a log file where such errors are being logged?

@zjief here is a screenshot of the error message.

Sorry that it took so long, but I didn’t find the time earlier.

Same exact issue happening with mine.
OS: Ubuntu Core 16
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 +53 (Git)
Build type: Unknown
Branch: 0.18.4
Hash: 980bf9060e28555fecd9e3462f68ca74007b70f8
Python version: 3.5.2
Qt version: 5.5.1
Coin version: 4.0.0a
OCC version: 7.4.0
Locale: English/UnitedStates (en_US)

Looks like the postprocessor is based on the already included processor linuxcnc. Have you tried to generate gcode with that aswell or only with the SN postprocessor?
I did CNC once and used linuxcnc