USB not recognised

Hi everyone,

I’m having a problem connecting my computer to my printer via USB. It had previously worked without problem but now my computer is simply not recognising it at all and it isn’t showing up as a port to connect in Luban.

I’ve installed the latest version of Luban and the CH340 drivers, restarted everything - no joy, and no more ideas. Does anyone have any other ideas of stuff I could try? Attached a picture of what shows up when I run devmgmt.msc and look for the ports.


Be sure you have proper connected your USB Mini B plug at the machine, there are rubber-dust-protectors which could be in the way.

Restart your machine and PC, if this doesn’t help, try another cable.
Hope this helps!

Doesn’t seem to have helped :weary: but thanks for the response. :+1:

THANK YOU! I’ve been dicking around for 2 days trying to work out why I couldn’t connect via the USB port. I had even resorted to install USB spy software. I’ve been using the full sized Type A port and hadn’t even spotted that there was a mini-B port on the controller. Fixed my issue instantly :slight_smile:

Though I did learn that I can power the screen and controller from the USB port and leave the printer powered off…not sure what use that is but at least I learnt something from the wasted 2 days.

Now I can get on with calibrating the extruder…really wish you could do this over wifi.

You have probably done this, but connect first then turn on the SM. I found it is tricky with what needs to be connected or not when different programs start. Play around w/ order of plugging in and turning on and see if there’s a way that does work. That’s what I had to do - I haven’t done it for a while so I don’t remember the final order I came up with to make it connect. Probably should have written it down…

Thanks for the response! I will try that as soon as I can get Luban to open. Just one thing after another this week. :roll_eyes:


Thank you for the response, I had tried it but clearly with not enough diligence and hearing that it worked for you made me try it again.

Have an awesome day :+1:

1 Like