USB Connection SM 2.0 A350

There are two USB ports on the Controller. One type A and one mini. Does it make any difference which one you plug into to offer computer connection to the SM?

The Mini is meant for Serial coms with the computer, USBA is to connect USB sticks to work off of them if no Computer is closeby or you cant have the Connection hickup and get your Print messed up that way. Onl yhappend twice to me over the houdret or so yours i had it printing so not that likely to happen. But Murphy will make sure it will happen when you want it the least.

Thanks for the response. I have been trying to connect to via the USB-A plug. I could not find a diagram of the controller ports in the manuals.

Yeah its isnt called out very well,

the usb A is just for the thumb drives for files or getting logs out of the machine

com is the mini usb

you may also need to get a driver from their web page and additional tinkering around too depending on how stubborn the computer is hehe

2 Likes

Yes I was set straight earlier on which port to use for connectivity. I have installed the package for the serial port driver from SM, but it does not seem to do anything. So now to contact them and see if they have anything further. If not, this machine is toast and not fit for sale as the SM Luban is not a useable product as I cannot work continuously to design anything, and Luban keeps no power or speed settings if shut down and then reopened.

have you done firmware update?

snapmaker and luban both have their issues, but the ones you are describing are atypical.

Firmware updated to 1.10.0 before anything else was tried.

Try going 1.9, which has a lot more stability

Consider looking into Cura, which luban is based on, for your 3d printing slicing needs… it has a lot more ability and power.

I have made a video for someone about this topic, which might be helpful for you

1 Like

I am new and having a similar problem. I did all the updates, even installed drivers. There is still no serial port available

Few questions arise that may be helpful to know, which operating platform are you using? Windows / Mac? and which OS? have you rebooted your computer?

I have no idea why my MacBook Pro suddenly decided to connect. I rebooted several times after installing the driver (CH34X_Driver_V1.4_Mac.zip). This is available on the SM website. If you’re on Windows you’ll just download the other version. Still I had no serial port. However, the next morning when I booted up the MBP the driver had been installed and worked. Be sure to connect to the USB mini receptacle. The Type A receptacle is for USB drives.

1 Like

Another thing i can suggest on windows is after downloading and installing drivers and rebooting, and connecting to the mini usb port as mentioned

you can look in device manager to look for the device and that will help you find the com port its on and if you dont see anything then you know maybe somethings wrong

also, i do a lot of little gadgets and so forth to program logic controllers and motors and such, and i can’t stress enough how often a USB cord is bad or going bad. to the point where you want to try a FEW not just another one.

do yourself a huge favor and destroy known bad cords.

ive fallen into that trap more times than i care to admit, wasting countless hours.

also, try different usb ports on your computer. sometimes that makes a difference too.

USB is nice, but for serial communication it can be rather finicky and this is not isolated to the snapmaker.

Thanks for the hints. As I noted earlier, the USB-Serial port suddenly appeared after about 6 reboots. Why? Who knows? The USB cable and the extension cable in use were not the problem in this event.

All is now working well.

1 Like

Just adding my 2 cents for others who may stumble across.

God speed

Got it! I have found several answers on older posts.

the operating system that i am using is windows 10. I purchased a brand new laptop to use with the snaapmaker