New Snapmaker Original... will not communicate

Hello All. New Snapmaker original arrived today. It was easy enough to assemble and I did this carefully over an hour’s duration. Everything fitted together well and all of the expected movements were possible via jog on the controller.

Bed levelling was a simple process and very easy to follow and understand. I tried to print a small file and the SM1 appeared to be unable to see the computer was connected via the USB lead that came with the printer. I tried to print from a file and the supplied USB stick. The
remote hand controller appeared to know that a file had been placed in the USB port (it said files) but pressing on the file button did nothing. Could the controller be defective in some way?

Another issue with the printing was putting the filament into the head. The button on the front of the head had no movement when pressed. More by luck than judgement, I managed to locate the filament and a little of it appeared at the end of the nozzle. Without being able to depress the button physically, it was difficult to remove the PLA filament but eventually a very strong tug did it.

I thought that I would try to use the laser cutting/engraving head and tried to follow steps on you tube that show a different software… I had no dropdown to select the serial port and given that I tried to download and install the driver for it twice, without success, the lack of a serial port dropdown in Luban does not surprise me. I am using Luban 3.5 in Mac Os 10.14.6 Mojave on a MacBook Pro mid 2014. It has a quad core 2.5GHz i7 with 16 GB DDR3 RAM with Nvidia GeForce GT750 with 2GB of RAM.

Using sudo su, I was able to use terminal to ls dev/tty/*. No serial ports displayed as present. Apple system report did not display “Vendor-Specific Device” after Bluetooth USB Host. I had tried installing your drivers twice with the same result. I could turn on the laser beam from the hand controller but nothing else. Files will not transfer via the USB stick. The hand controller does not do anything when the files button is pressed.

edit: Just opened my SNapmaker enclosure to assemble it and noticed that on the parts list there are two M4 Plastic Spacers that fit behind the door interlock switch. These were not present in the box when I opened it. How do I arrange for the missing parts to be sent to me?

I must be doing something wrong but I have no place to start because the Luban software does not look like the software in the instructional video presentations. Any help with these issues would be highly valued. Thank you all.

You were able to calibrate, jog, and change the filament, so the touch screen is working.

You mentioned that you’re using a Mac. I’ve heard of some issues with the USB stick if you don’t eject it properly. For some reason, my KINGSTON doesn’t show up on the Desktop anymore, and I have to eject via Disk Utility. Ejecting does take longer than I expect. If you pulled it out without ejecting properly, you might need to reformat to correct the corruption (or try inserting the USB in a windows computer – they’re better at detecting and repairing FAT errors). You could also try using a different USB drive.

Regarding software, Luban has replaced SnapmakerJS. You can still download SnapmakerJS if you want, but I would only use it for testing and educational purposes at this point. Luban should be very similar.

I have not tried to connect my v1 hardware to my mac via the USB cable, so I can’t help much with /dev/tty*. From what I’ve heard, you’re better off doing the CNC and Laser via the USB drive, due to slight communication delays causing slight timing issues. But if your USB drive isn’t working, that’s not really an option.

My filament change button is very stiff. Stiff enough that the first time I loaded it, I only depressed the button half way, and couldn’t load filament. But that doesn’t sound like your problem, since you were able to change the filament. I would be careful about tugging the filament out. You shouldn’t strip any gears, but if you do, the print head won’t be able to feed filament properly anymore.

Thanks Craig. The USB stick seemed fine to me. Formatted MS-DOS (FAT32) Erased, formatted and loaded files to it and from it without any issue. I downloaded SnapmakerJS for pig iron. It did show me that the port it was going to use was /dev/tty.Bluetooth-Incoming-Port. That is helpful because finding a serial connection via USB was proving hard for terminal, even though I was SU under sudo.

I had tried one other approach using Network Utility. That shows two USBserial interfaces that are both disconnected. USB2.0-Serial (usbserial-1410) and USB Serial (usbserial-1420). I have tried to find details on enabling these two ports but no luck yet.

Good point about using a USB stick file to fix possible timing issues. I had considered adding a Thunderbolt serial port but I am not yet convinced about its usefulness. The supplied usb lead is usb A and B so I think it is version 1. My Mac can be either USB 2 or 3 depending on the connector used.

The filament change button really does not move. I had thought that it would open a space in the head for the filament to be pushed through but it seems to be completely seized. I am not convinced that it is a working part of the print head. I could not depress the button at all. Thanks for the pointer about removing the filament. I had visions of it being stuck in a cooling nozzle, so I removed it as a matter of urgency.

I get the point about the touch screen working. Something is not working though. The created files are not viewable from the USB stick. Is there a test file that is known to work and that can be downloaded so the hardware can be assessed as working properly or not? Thanks for your help Craig.

Kind regards,

Had a long think about the problem and have concluded that the fault lies in the central controller with all the attached ports. The files are being acknowledged by the hand controller… it just cannot see them but it knows they are waiting to be selected. The hand controller can jog the head anywhere and the direction and distance increments look to be accurate. I have opened discussions with the vendor in the UK and I hope to have the problem resolved soon. The missing parts for the interlocked door catch on the enclosure have raised a technical ticket with the vendor. Hopefully they will just supply the missing parts so that I can complete the door lock. The enclosure is nice though.

The USB connection is simulating a serial connection, so the Bluetooth tty is unrelated.

I had some time to mess around, and connected the snapmaker via USB to my Mac. Before I started, I see /dev/tty.Bluetooth-Incoming-Port . After plugging it in, I see an additional /dev/tty.usbserial-1410 . I don’t think I installed anything on this machine, but I won’t swear to it (this is a replacement Macbook; restored from a Time Machine backup).

I started Luban before I connected it, and only saw /dev/tty.Bluetooth-Incoming-Port in the dropdown. After clicking the refresh button to the right of the drop down, I saw /dev/tty.usbserial-1410. These match the pattern /dev/tty*, not /dev/tty/* (note the extra / before the *). It started out grayed out, but after a few seconds it became selectable. Once I selected it, I clicked the “Open” button below the dropdown.

I don’t see /dev/tty.usbserial-1420 anywhere; not in terminal, Luban, nor Network Utility.

After switching to object view, loading a model, and generating GCode, I was a bit confused. It took me a few minutes to figure out that I had to click “Load G-Code to Workspace”, then click the YZX icon in the left nav. I then clicked the Play button in the center pane. Once I did that, I looked over, and saw the snapmaker starting to heat up the nozzle and the bed. The print

When the USB flash drive is connected to the controller, will the background color of the ‘Files’ from Grey to Blue? If it can, that means the controller recognize the USB.

After you click on the ‘Files’, if you cannot find the files stored in the USB, please make sure they are the g.code files.
You can show some videos or pictures to us.

1 Like

Overall i could say, there is no bluetooth connection possible at the snapmaker original.
Have you connected your mac with a USB A to USB B -Cable?
The USB A at the controller is just for the thumb drive.
I have no mac so, just figuring out.

Thank you all for your ideas. An engineer from the vendor got in touch today and sent me a file which was known to be good. It worked! The only thing that was different was I had bought a new USB stick. Everything was working as it should although the print did not stick to the bed and became a mess.

I am currently cutting a pattern in a piece of wood with the laser cutter. It is on a single pass and a depth of 0.1mm. The pattern is developing as I would expect so I am happy. Tomorrow, I will try my hand at a little CNC carving and then I can spend my quarantine time learning the machine and the software.

I really appreciate the forum folk for keeping me on the straight and narrow. Thank you all. If some kind soul will tell me how to upload an image to the forum, I will take a picture of the completed test piece. (It should really have said “Hello World” but that is a bit nerdy) :crazy_face:

The Snapmaker Original works best with a flash drive that is USB 2.0, 16g and in the FAT32 format. You can upload image by clicking the upload button. Or you can copy and paste like you would in Microsoft Word and it does the same thing. :grinning:

Thanks JKC20. I see it now. I am using the type of USB stick you mentioned and it is formatted to FAT32. I see the upload button now. That is helpful… thanks for your support. I will try it here so that people following this thread can see that my SM1 is working well.

1 Like