USB / Flash Drive: "Files" screen doesn't work

HI there,

I’ve researched the topic on this forum and elsewhere, but I just can’t get anything to show on the screen via a usb flash drive. I’ve tried different ones, different sizes, UBS 2, USB 3, even followed a tip found here to format them with a particular cluster size, to no avail.

I’m using FAT16/32 flash drives formatted with macOS Disk Utility. Inside right now there’s a gcode file, at the root with the “gcode” extension. The screen does seem to recognise there’s a drive inserted as it lights up blue, but that is as far as I can get. Tapping it does nothing and I never see any files showing up…

I don’t really know what to expect, as I have never seen or found online what I’m supposed to see or how to move from there on, although I’ve used a similar approach in other 3D printers.

Any tips or ideas would be greatly appreciated.


Sounds like you need to contact Do you have the thumb drive it came with?

I probably do have the original drive somewhere, but… is there anything special about it? What if I can’t find it? Can’t possibly believe that would lock me out of printing without the computer!

Thanks for your help!

I don’t think there is anything special about it but if it doesn’t work then that might be an indication there is something wrong with the SnapMaker or it’s USB port.

Could you please format the U-disk we provided and download a file into it.
The U-disk the controller supports is FAT32.

Please do as the attached video and check the file via the touchscreen.

If the touchscreen still does not show the file, please let me know.
And send a picture that shows the screen of the touchscreen on the file-reading page.

1 Like

I also have the same issue. I have tried al the supported file formats. I can read the USB on my computer but nothing shows up on the files on the touch screen. I have also tried a different USB with the same results.
When I plug the USB into the controller the touch screen will change from “No Files” to “Files”. the controller does recognize the USB but not the data. The blue light on the controller is flashing.

What files did you copy to the stick?
It has to be a gcode file.

I have tried every format in the “Export to file” button. I have also made sure that they have the gcode extension on them. I am now trying to reformat the USB stick as I have seen in other posts.

No luck there. Still not seeing any files.
I have also tried using my Mac book and still no luck.
Are there any updates for the printer? I have just bought mine.

I should also say the the “export code to file”

On my original flash drive there are two folders that show up when it’s in the SM.

On my mac the “lost” one is empty and the “system volume” is hidden.

(You are selecting the USB tab at the bottom, as opposed to the internal memory in the SM? Figured you are but had to ask)



What format is your flash drive in? It is recommended to use a 16g, usb 2.0, and fat32 flash drive for the Snapmaker Original.

I have tried the stick supplied, A New stick both as bought and reformatted for fat 32 both with Windows and Apple. The original stick had no files on it when looked at on both my computers.
The files I was using were created using the Snapmaker software. I have also tried to update the printer with no change

FWIW, my SM1 supplied USB stick stopped working permanently… after I had removed it from my computer without specifically ejecting it first. I tried many different utilities on the Mac and in UNIX to get the drive to wake up again but it never did get going again.

I have bought a few 64GiB Sandisk USB drives from Amazon and they were already FAT32 formatted. I have used them all without difficulty, even when I remove them from my computer without ejecting them from my Mac. They are plugged into the SM1 at will and the files dialogue on the touch screen then opens the folder icon as soon as it detects the stick. Removing the USB drives has no effect on their integrity. I have used 4 Sandisk sticks now for about 6 months and at £8.49 each, they are very cheap.

1 Like

I have just tried to save a file for the laser, the CNC and the gcode. Both the laser and the CNC files show in the snapmaker but not the gcode generated by the snapmaker software. This tells me that the snapmaker USB should be working correctly. Could there be a bug in the firmware? I have updated it to the latest from the web site.

my enclosure is not working - so i finally found out i need to update the software (the old firmware on the machine doesn’t allow updates via wifi :frowning:

getting back to the problem - it seems the 2 people above are trying to do the files using macOS (because i am the same). samsung 64gb , formatted the usb to fat 32, recognises the usb but nothing on it.

&&& going to use my sons computer which is windows - will report back if it works

update, machine is currently on a job (YAH) , even though i am using a mac and a mac to save the file to a usb (using fat 32) - i just bought a cheap usb that didn’t hold too much data (i think it was 2 gb) and it worked like a charm.

updates will be so much better doing them via the touch screen from now on :slight_smile:

off to the shop to buy some more bits, thanks

Hi @Nazar. I am on a Mac here too. The supplied Snapmaker USB stick died on me after I pulled it from the Mac without ejecting it. I bought several 64GB USB sticks from Amazon because they were very cheap @ 8.49 each. They were all formatted to FAT32 out of the box and they work just fine.

I guess I will have to try the SanDisk. I used my own USB stick successfully once, then as I was having connection issues via WiFi I decided to load directly only to see the LOST.DIR issue - and like others, once plugged back into my laptop (Windows) I can see the file that SM couldn’t. I then tried the SM supplied USB - same issue. I have yet to update the firmware (it would be nice if we were notified that updates were available! - side issue) and plan on doing that to see if it solves my sudden WiFi connection and USB issues. On the WiFi connection issue, I went to change the timeout to 30s, did so, but it won’t save it, it reverts right back to a 3s timeout. :frowning:

over the air firmware updates were not functional on the 1.8 firmware, which is why you couldn’t update or be notified of it, unfortunately.

it would seem like the usb drives they provided are not very good, which is unfortunate.

i hope you get things working