Firmware 2.11 Bug: Unable to view more than 5 files on USB stick

I believe I’ve updated my Snapmaker Original to the latest firmware, and while it’s working well enough, I’m having some pretty annoying filesystem problems with the thumbdrives I’m using to transfer files over from my PC to the printer itself.

The printer is too far away from the PC for any cable I currently have to reach that far, and while I will eventually buy a longer cable, that doesn’t solve the more severe problem I’m having that only the first five files in the root directory of the USB thumbdrive can be seen at a time.

And no, the “Next” and “Previous” buttons do not work.

At the moment, I’m having to delete everything but the few files I’m working with at any one time, which does make it easier to find the files I do want to use, but doesn’t allow me to have projects on a single drive that spans more than five files at once.

I’m using Ubuntu Linux to put files on the drive, and no I do not have a copy of Windows handy to see if that would work.

It is recommended to use a flash drive that is USB 2.0, in FAT32 format, and is 16g. If you still have issues with your flash drive, you can quick reformat it as a last resort.

USB 2.0, check.
FAT32, check.
16GB, also check.
Freshly formatted doesn’t matter, but I have tried that too.

I was severely tempted to try FAT16 to see if that was more reliable, but I’m not sure if it’s supported. Then again, it’s free and quick to try, and I don’t store the permanent versions of my engraving files on the drives, I store them on my PC, so I can try it without fear of losing data.

Did you try another USB drive? What is the file name of the gcode? Is it very long?

I’ve tried the drive that came with it, and others.

I am using (relatively) long filenames, though. For example:
“laser - mothersday2020 - bookmark -”

But even with six sequentially-numbered files, only five are shown (or four, I forget), and while the Next and Previous buttons are not grayed-out, they don’t actually do anything. When I have five files on the drive at a time, I actually have to tap a file twice to get it to recognize my selection. I don’t have this problem with four or less files.

I’ve seen this also. I use a Windows laptop, create the file, export it to the snapmaker original USB thumbdrive. If there are more than FOUR gcode files in the directory, created by snapmakerjs, the snapmaker original hangs when you enter into the “files” screen and either try to open a file or to check for additional files.

I can create subdirectories on the thumbdrive and places lots of files in the subdirectory - snapmaker never checks the subdirectory… it just can’t handle the extra files in the top level. I’m also using the 2.11 firmware version in the controller.

There was a bug in snapmaker js a long time ago. Try luban or not renaming it after+while saving the code with snapmakerjs.
Give it a try!

I’m using Luban already. Annoyingly, the file names generated by the software is almost as long as the names I’ve been giving the files myself!

Once the new batch of thumb drives arrives, I’ll try using far shorter filenames.

I also am using luban. This is a bug in the snapmaker original firmware that resides on the controller.

I should have done this earlier, but I’ve finally started to add extra folders in my workspace to categorize my files better. As a result, I’ve been able to rename files to much shorter lengths.

For example:
“mothersday -”

And I put all seven variations on the drive at the same time. This time around, all the files showed up in single lines (not having to wrap to multiple lines), the first six showed up readily, and the Next and Previous buttons actually worked, allowing me to see the seventh file on its own page. If I’d had more files, I’m sure it would have worked normally.

But this is still a workaround, and NOT A FIX. This is a bug in the firmware that needs to be fixed. Ideally, it should also get support for recognizing folders, so you can compartmentalize things without having to clear the drive out from previous runs. The replacement drives I have on order should make it easier to deal with multiple projects at the same time, but they’re not here yet.

Our support has looked into it but couldn’t reproduce the problem. Could you send us your exact files (same long names and file sizes) that cause the issue of not showing on the touchscreen and we will see if we can reproduce the problem? (725.5 KB)
Here’s the files. The SVG files are from copyright-free website, and the front is called Ecolier_Court, a very nice handwriting-like font Linux has freely available. The files fit perfectly in a 3x5 card, and are calibrated for the 200mW laser module, engraving quite nicely and cutting pretty cleanly.

Hi, I will download the files and get back to you with the results.

It shows all the files on our machine. Did you try to output the files with a different computer? Like on a different system.

I have a laptop and desktop computers, but both are running Ubuntu Linux 18.04, so I’m not convinced they’ll do anything differently.

Annoyingly, it’s working properly now. Back when it wasn’t working, I’d be putting one file on the drive at a time, due to wanting to engrave the file as I built new ones, so I don’t know how that would be different from other circumstances.

If it happens again, I’ll try to figure out what’s different.

Okay, I’d put the files on the drive all at once before ejecting it and it worked.

But now I just put two files on it before ejecting it again (short filenames this time around, but in addition to the other ones) and it had the same situation happen again!

So the problem appears to be the difference between the files all getting added at the same time versus put on one at a time, ejecting the drive in between.

I’m going to see if it happens with short files names too…

Hi, the problem lies with the way how the files are transferred from your laptop to the flash drive. Different computers transfer the files differently if the computers have different settings. There might be some compatibility issues related to the region or language with the files output from your laptop. Please try your other methods on the desktop to see if you can replicate the problems :+1:

That sounds suspiciously like you’re not actually verifying Linux support. Please be careful how you respond, because I spent a lot of money on this machine, and if you’re not ACTUALLY supporting Linux, you should say so straight up, instead of hiding behind all these weasel words you’re currently using. If you’re not sure you’re using weasel words, you should stop trying to help me, and instead get one of your ACTUAL software developers on here who knows how to communicate effectively.
(if you’re concerned about me having insulted you, be aware that you HAVE insulted me)

Now, I was able to get my hands on a Windows 7 Pro, 64-bit PC for long enough to replicate what I was doing. Namely, with the long filenames, copy one file onto the drive, eject it, unplug it and plug it back in, copy another file onto the drive, and so on and so forth.

I put eight files on the drive (the seven I posted earlier and an extra one that had a much shorter name, and that merely cut the outlines) and while it showed eight files, it didn’t actually show the right eight files.

Again, that was from a Windows 7 Pro, 64-bit install, and I’ve attached the pictures of what the display showed.

Note that the first filename (“cutting-outline -”) showed up as the first element on both pages. Tapping on the second page’s first item actually brought up the file “laser - mothersday2020 - bookmark -”. Like it was stuck on the file’s name.

Note also the blank line at the end of the first page. Tapping on that (several times, the first few were not recognized) eventually brought up the expected file “laser - mothersday2020 - bookmark -”, the name is just not showing up.

It looks like there’s a disconnect between the code for listing files’ names, and the code that actually chooses the file.

And I will repeat again, this list was generated on Windows version 7 Pro, so if you’re thinking that it’s just Linux that has a problem, think again.

Hi Carl, sorry for my oversight. I downloaded your files almost immediately after I saw your post a few days ago but couldn’t reproduce the problem. In the past there was one case where the user had a similar issue to yours and pretty much all the troubleshooting steps we provided failed. But strangely once he switched to a different computer, the problem was gone. I thought that was the case here (and it was not), hence my reply.

What’s more strange was that, we could reproduce your problem now… And all the things you described happened to us, blank file names and such. Our tech support is looking into this issue and he will respond to you here once he finds a solution.

Once again, I apologize for my previous reply.

1 Like

Hi @CarlFoxmarten Here is Edwin from Snapmaker Team.

According to our test, this issue was caused by the length of the filename. The touchscreen failed to read all the filenames in a short so that it only showed some of them. Meanwhile, when you go to another page, the first filename in the page 1 remains because of delay effect of reading files.

This is a bug of firmware 2.11, and we will fix it later. Currently, you can shorten the filename so that the files can be shown in the touchscreen.
Please refer to these two images.

1 Like