Screen turns off when USB stick plugged in

I’ve had my Snapmaker original for coming up to a year now and have used it heavily as a laser engraver and printer. However, I’ve always used it connected to the computer.

I’m now needing to run it independently so saved a gcode file to a USB stick, but any time I plug a USB stick into the port on the printer, the screen on the printer turns off and I can’t do anything.

Can anyone suggest what’s going on here?

you must plug in the USB first and then turn on the printer.

And where I find the gcode file if I do it to the USB - Drive?In my case the SM say File is empty.
Thank you

did you copy the .gcode file into the root directory of your thumb-drive?
The thumb drive has to be formatted to fat32 with clustersize of 8k.
Usb 3 Stick doesn´t work from stick to stick, from size to size…

This is the root of the USB Stick. Also empty on power off and on!

The USB sticks, File is stored as a .gcode Screen shows empty file ?
What should I do.
THank you

This Screen it comes instead of the gcode list. I do not recocnies when it comes but after power on the normal list shows all the stored files. In the last time there is no possibility to store files. If I am working from WLAN the communication breaks and the beginning print stops. It happend to times. Confusing in the moment.
What I can do?

You have a snapmaker original? - you posted in original forum.

Try few other stick and or check of this stick is formatted to Fat32.

At an older version of snapmaker js, there was a bug, you should not rename the file, because then it corrupts. Have you renamed it?

What is the size of the USB stick? I tried to use a 64GB USB stick on it but the machine was not able to read from the stick. Then I changed to the 16GB stick and it worked. And always use the FAT32 format.

Hello xchrisd.

Thank you for your quick answer. I want to help because the machine you create is the best i now in this price area. Yesterday there comes on transferier to a flickering on showing the transfer. After the machine finished transfer
there where no file in the list. The next try, i start from new. Slicing the file, transfer to the the working screen and then transfering to the snapmaker. It works printing, but not coming to the end and stops 10% before the end. Later I send the picture.

It seems, that there are problems with the WLAN. I am working with a homecontrol System. I install a WLAN power on/off switch. Today i will disconnect the Power Plug. Later i will report a fault that let run the right z-axes so quick up that the mechanic
not works and you only hear a big bruit. But on referencing it runs normal.

Thank you for your help. It is good to know that you helps me.


Christoph Sobotta

Holen Sie sich
Outlook für iOS

You must actualize your firmware.

1 Like

Please use USB 2.0, 16G with FAT32, Then try again.
If you use USB 3.0 on Snapmaker Original, the screen will turn off.
Snapmaker 2.0 supports USB 3.0.

Bombastino has a A250, i have edited the topic because of this before.

What slicer do you use, Snapmaker Luban? Here I attach a gcode and please try to use it via USB. 20mmTestCube.gcode (131.5 KB)
Please use the original USB flash disk. Then can you find the gcode file on the touchscreen?