Update now machine won’t work

So, I figured out why my 350 wouldn’t work, I had missed about 5 updates. I thought it was being updated, but it wasn’t going into the firmware. Anyway, I did each of the updates, and they were all completed. Well, I wanted to test it out after sweating thru 12 hours of frustration. It was working beautifully! For ten minutes then the Screen said updating. After that it wouldn’t come on. The touch screen comes on momentarily then the enclosure light blinks then nothing. Can someone please enlighten me as to what I can do now? Nothing works. I’m seriously ready to throw in the towel. It’s not a hobby when I’m constantly stressed out :cold_sweat:

I am not sure what your problem is.

What is the state of your machine now if you power it on?

If you touchscreen looks like normal, what version of firmware are you running?
Try to download the latest firmware here, unpack it to a thumb drive, plug it to the machine USB A-Port and start the file from the touchscreen.

That is really great information, however I have no idea how to implement that. Is it possible you can tell me in English :laughing: Is there information in the manual I’m overlooking that explains how to do this? And…will you explain how to check for the current software that is installed? How do I add “M413” for example to the “G” code? I did take your advice and updated each tool head, and that has worked so far. I’m less likely to smash it into bits little now so thank you! Thank you for your precious time, I really appreciate it :heart_eyes:

G-code is just a text file. So editing g-code is just opening the file in whatever basic text editor your computer has. (in mac it’s textedit)
Here’s some info might help:
https://all3dp.com/2/start-gcode-cura-ender-3/

All3dp.com has a bunch of good info and articles. Just search for g-code (or whatever else) and there is a lot of good explanations of stuff.

-S

1 Like

Hi. Sorry if I’m annoying, but I’ve been chained to this thing for the days. Any idea how to make the touchscreen connect when it goes blank after startup?

Make sure it’s plugged in all the way.
The connector may seem like it’s plugged in but make sure it goes in with a really solid click.
(do all plugging and unplugging with machine off).
Also might try reversing the connector. This seems to work for some people.

Be very careful not to reverse the connector to a toolhead!!! Even though it seems like there is a tab that will keep you from doing this, it doesn’t actually work. If you do reverse it you’ll instantly fry the head, and a very good chance the controller also.

Lastly, when making sure any of the connectors are seated it seems to work best to completely unplug, not just push them in.

-S

1 Like

Thank you​:blush: I finished my project through the computer because I still can’t get the touch screen to work I swear it’s possessed. I’ve turned it on and off several times and plugged, unplugged. It has a mind of its own maybe it’ll work tomorrow. Thank you for all your help :grin:
It comes on, the “s” shows, it goes away, the LED’s blink and it goes black. If it’s goons work, the “s” stays on through till it connects, but when it’s working it just disconnects. And won’t reconnect. It’s very strange

I’d start a support ticket with SM. Sounds like it could be a bad cable or connector - could be a controller problem.
Let them know as much info as you can to start with - what you’ve tried.
Photos too. It will speed things up.
As you’ve found out as long as you can connect to the computer you can do most stuff without the controller.

-S

It is better to go through it via email. It seems either the cable of the screen or the C port is defective.
You can request a ticket by sending an email to support@snapmaker.zendesk.com.

@ZERO00 It’s most likely due to the stress the connector (both the cable and port) have applied because the cable just isn’t long enough for the A350 enclosure resulting in too much stress to the connector and port being applied. Simple fix really… just throw in a usb-c extension cable possibly with a right-angle adjustable locking connector (for when you need to connect via serial, you can make the right angle connector a straight one, but they aren’t cheap because of usb-c having a pcb) into the enclosure kit.