Update Luban, can't update

Hi all, Have been trying to update Luban since the new update. I kept getting message that
“IWindows cannot access the specified device, path, or file. You may not have the approtiate permission to access the item”. So today I decided to try to uninstall the old version and install the new version (4.3.1) , well I got the same message and could not uninstall . So I decided to go back and open Snapmaker Luban on my desktop and now it will not even open and I get the same message. I have Dell touchscreen desktop running Windows 10. I have never had problems updating before. Don;t know what to do.

I updated after some issues with auto update, actually did a seperate install so have versions 4.3.0 and 4.3.1 on Imac
Both versions slow to open and the new version stops cnc at 8% of job.
so back using 4.3.0
I have set my SM2 to use only as CNC and Laser.
To much mucking around getting 3d prints sorted after using CNC.
So purchased a cheap 3d printer, manual levelling and basic but prints are magical and adhesion problems are a thing of the past, print times about the same.
I printed a range of the little test boat on SM@ using same filament same settings with different slicers, will that was probably a silly thing as the test are so different, proved in oneway that slicers do play a big part in finished item quality.
SM2 may get printing for larger parts one day.

I checked back today and see that there is another update 4.2.1 tried to install that and get the same massage.
I cannot open any version of Luban I can’t uninstall Luban and start over. I don’t know what to do. I searched the settings on my computer and see nothing that will help me unlock Luban. I did not set it up when I bought it to require Administrator permission so I don’t understand why I get the message " i may not have the required permission"
I can’t us the old version or the new version of Luban. HELP!

Success finally: After over a week of frustration by accident and a suggestion from a friend of mine I was finally able to update SM Luban. The problem all along was not the permissions window that kept popping up. It was my virus protection program. I have PC Matic and it blocks the firewall from installing or upgrading unknown software. There is a setting that when you open PC Matic that when you open it, click on **Protection Level that opens a window that has several choices to check. Check or click on “pause for one hour”. This opens the firewall for one hour and lets you install unknown software and updates. I then went into settings and uninstalled SM Luban and then clicked on the new version and installed a clean version of SM Luban and all is well, it works fine.
Thanks everyone for your efforts.
I wanted to let anyone that is having the same problem updating that this is another option to look at that may help.

Update: I tried to open SM later and got the same message again, so I contacted PC Matic and they replied with instructions on how to let SM update permanently and the instructions are rather long and I believe not enough room here to FWD it. If someone from SM Luban would email me I will be happy to FWD their email with the instructions.

I would like those instructions please.
I had same issue, glad to see your post, it really helped