Version 3.13.1 problem

I let the update go through today for the 3.13.1 and now I have no material or print settings available and the program will not slice. Do I need to do something else or what?

I’ve not had that problem - seems to work fine for me. Which version did you upgrade from?

I guess all the usual things would be worth doing - reinstall Luban, make sure existing Luban is closed during the upgrade install.

Please post up with how you get on so the mods/staffers can help.

Ed.

I tried reinstall as you suggested, but that didn’t help much.
I use the win-x64 since i have windows 7.

Now it works again. I uninstalled the update and installed the 3.12.3 version again.
Better to have a version that works than a new that doesn’t :slightly_smiling_face:

it is ridiculous to offer a new version as a stable one, if it is more faulty than the previous one 3.12
CNC has more error meesages than before., really disappointing. Laser and 3D printing not yet tested.
seems that nobody is testing before publishing… :frowning: :

See, I’ve not had any problems other than very small bugs. I am of course NOT denying that you have had the experiences that you recount, it’s just odd that different versions of Windoze or different platforms have such variable results…

One thing that does spring to mind is that some of Luban seems to be written in JavaScript. It might be worth checking which version of the Java Run Time Environment you have installed. That’s a bit of a shot in the dark, but might be worth investigating.

Anyway, I hope your problems are resolved soon. If you would like me to post up the relevant specs of my desktop PC and its software, I would be happy to do this so we can start to isolate differences that might be causing the issues you describe.

Ed.

JavaScript and Java are not related.

SnapMaker Luban is distributed as an Electron application, essentially a copy of Google Chrome with an embedded web page and JavaScript application.

It’s generally thought to be pretty forgiving on the quirks of an operating system.

Another user found a solution to the problem and it now works great for me again. He found that the uninstall process is leaving small files, so when the new install is happening it causes the above functions to not work. He put the fix on the Facebook group for Snapmaker owners.
I will share his instructions here…
From [Duane Fudge Fougere]
I experimented by uninstalling my copy of Luban 3.13 to find a bunch of folders and files that were left behind. So I put together a batch file that will get rid of these leftovers quickly and hopefully that will solve your problem. A batch file is just a Notepad file to execute commands.

As it’s generally a bad practice to run a file from a stranger, here are the commands as I’m sure there are plenty of people here that know basic DOS commands and can verify nothing is malicious::

rmdir /q /s C:\Users%username%\AppData\Roaming\snapmaker-luban\

rmdir /q /s C:\Users%username%\AppData\Local\snapmaker-luban-updater\

rmdir /q /s “C:/Users/%username%/AppData/Roaming/snapmaker-luban”

rmdir /q /s “C:/Users/%username%/AppData/Local/snapmaker-luban-updater”

del C:\Users%username%*luban*

3 Likes

Cool. Another school day, as they all are in some way! Thank you for the information. I would like to start to develop Luban for myself, but not being too hot on software further than doing Arduino stuff, there may be a few more school days yet!

Glad you got it working.

Ed.

Some problems like everyone else with 3.13.1 on my iMac that I never had before! I click the “add” button and get the message “successfully loaded” but no image appears! Tried several different stl files and same problem. I will try the uninstall/reinstall method and report if that works.

Uninstalled 3.13.1 then downloaded and installed again. Same problem persists: it says “loaded successfully” but no image.

Got rid of 3.13.1 and downloaded 3.12.3 and I’m back in business!

Hi there!
Since SMLuban 3.10.2 (Mac) I had the same problem: sometimes Luban did not display the materials panel, sometimes losing my custom print settings, sometimes showing them… despite several clean uninstalls, reinstallation, installing an older version, cleaning the computer … SMLuban is not working properly. Conflict between some hidden files?

I think, it´s not a matter of Windows or Windows Version, or JAVA

My System is Windows 64 home Version 20H2, latest JAVA , Acer Aspire i7-7500, 32 GB, Geforce 940MX, SSD 1 TB

Some examples CNC module of Luban,

Relief Modus for Grey scaled Image : s. attached screenshot, wrong Parameter, no Explanation why/what is wrong

Version 3.12 didn´t have this error message

If you Invert image , nothing happens, no toolpath is generated,

if you check Auto preview, then no toolpath generated , no Simulation

Maybe that it is my mistake, but if so, where is the documentation of the changes from 3.12. to 3.13, any what´s new section ?

If I click on Manuals /FAQ in the Headline for help , then I´m linked to Snapmaker Website with old FAQ , Nothing About LUBAN.

Perhaps LUBAN is ment as an adventure, in any case . it is a challenge

As I already said, 3D print and laser module not yet tested.

greetings

Gesendet von Mail für Windows 10

Luban 3.13 error.PNG

Most of these problems seem to be preference file or cache related.
If you completely uninstall Luban, including any hidden, or system files, it seems to go away.
They really should create an uninstaller that wipes everything.

-S

Hello everybody,
I have now completely reinstalled Luban 3.13.1 (mac) (all old files in library … deleted) and the problem persists!
Laser -> I create one or two circles, set the size to 10x10mm and switch in process …
See video! The coordinates are no longer correct.
If I reinstall 3.12.3 from scratch, the problem doesn’t exist.
Is there now a German forum? Then I could save the translator …
MfG ThM

Addendum: If I set “Snapmaker Original”, it works, but there is a problem with the “A350”!

May be you’re right, but then it is apparently a weakness and they cannot announce it as a stable version.

I think many customer highly appreciate the Snapmaker Philosophy of a hand-in- hand working package of soft- and hardware, especially for the newbie.

If the alternative is, to switch to high end Fusion 360 or something else, then it is more the hard way and this causes frustration for a lot of people.

BlueMail for Android herunterladen

When I tried updating to 3.13.1 via the download link in Luban, the download never completed and I’m left with ver 3.12.1. Which is fine bc that earlier version seems to work fine. Think I’ll wait to update till a “latest” stable revision available through GitHub.

I too am having a problem with 3.13.1.

When using version 3.11.0 opening the G-Code file in Luban Workspace resulted in the following visualisation of a CNC Carve.
70thLuban3-11-0

However since updating to 3.13.1 the exact same G-Code file results in the following visualisation:


It seems to be only showing the tool paths above the surface, and not the actual carving paths.
I am reluctant to try this to actually do aCNC carve in case it completely screws up my Snapmaker 2.0
Resorting back to 3.11.0 all works fine again. Have not tried this with a version 3.12.x yet either.
Any ideas?

1 Like

What does it look like in ncviewer or camotics? Does it look as you expect in those?
Then it’s probably best you report it as a bug on github in the luban repository (Issues · Snapmaker/Luban · GitHub)

Do attach the generated gcode and that it looks good in ncviewer or camotics and the older version. That should help them to reproduce and come up with a fix.

If you just use Luban to send it to the machine, the wrong preview shouldn’t be a problem. At that point the only thing Luban does is to just send it to the device (not making changes to the file). And if you don’t trust it anyway, just put it on a USB stick, and possibly run it 5cm above your stock material in the air to validate it does what you expect :wink: (And keep your finger on the power button)