Luban 3.9 unusable, went back to 3.8

I’m having tons of issues with 3.9 (Mac OS 10.15.6)
White screen and having to reload.
Weird glitches and freezes.
Not being able to see the size of an STL once imported for me is the biggest, and makes it completely non-functional.

I’ll stick with the bugs in 3.8 that at least I can work around.


I’m on 3.9 Windows 10. When I go online via wifi Luban during a print started from the touchscreen (SM 2.0) Luban appears to download the gcode being printed and display it in the workspace, but it always shows the first print I ever printed, which was a 3dBenchy.

I’m not sure this is a Luban problem, or SM2.0 problem. I also don’t know if this happened on 3.8, as I never did this specific set of actions before.

Anyways, my 2cents on 3.9…

The issue occured in Luban v3.8 as well, we’re fixing it on both Screen and Luban end.


I use Luban 3.10.2.

All that work to remove the 3D printing and connecting and calibrating the laser, and it has not worked since 3.8? :frowning:

1 Like

I’ve been using 3.10.2 since it came out.
Only used it for laser and it’s been fine for that. Still some issues with bringing in files and changing sizes that I can’t seem to figure out the pattern.
I have not done any 3D printing.
Tried to do a simple relief from a b&w image. It was a round image (file was square obviously) and it ended up creating a tool path that basically did parallel passes of the whole square. It didn’t just go to where it was actually doing carving. Which on a round object started to run into my clamps. I ended up using fusion to create my tool path.
I don’t recall having that problem with earlier versions, but I’m not positive I tried a round image.