Trouble printing with enclosure v1.1

Yesterday I received the new enclosure i bought. It comes with door control switches. The manual said the cable has to be plugged in port 4 on the controlller…pretty straightforward. I also upgraded the firmware to 2.11.
However when I try to print the printhead moves out in the far left quadrant of the bed and tries to start the print there instead of the center of the board. It also tries to move outside the printable area, which makes hoorible sounds. All in all the printer behaves erratically and printing is not possible.
If I unplug the cable fron the controller, everything is fine.
Am I missing something …is this by design?

1 Like

Have you got Snapmaker Original selected in Luban? The enclosure doesn’t have any effect on 3D printing, the door closure switch is intended to switch off the power to the laser.

Does it try to actually start printing there or does it sit and wait for a while?
It’s supposed to park there and come up to temp and then extrude some filament before it wipes it off on the corner as it moves to the center to print.
Double check all your cables for the linear modules are connected properly to the right ports. Also make sure that you’ve set Luban to whichever model SM you have. This post is in the original SM category, but this sounds like an SM2 problem.
-S

Luban is up to date and snapmaker original is selected. I have been printing with that thing for over a year…cables are all properly plugged.
It homes in, heats up all nice, cleans out the hotend and then when the printing starts, it goes as described. The same print with the cable unplugged runs error free. I just dont know whats up with that. Perhaps the cable is faulty

I have this exact same problem, except in my case the print head goes to the back right the minute the door is closed. Upgraded to latest firmware, settings in luban, everything. Seems like a bug, prints perfectly fine if I leave the door open the whole print, or unplug the door detection cable. I have adhesion issues, but that’s another story…

I had a similar problem, but with CNC. The job would get about halfway through the first path and then suddenly go 10-20mm up un the Y axis and then try to carve in mid-air, moving a little further up and up with each consecutive pass.
Unplugged the door switch from #4 and no more problems.
I’m running the newest Luban, but couldn’t get the SM to take the 2.11, unless it is already there, but I can’t find a way to check the firmware so I am not 100% on the firmware that is installed.

1 Like

“I can’t find a way to check the firmware” - I had trouble too. It turns out that you have to have the 3D print head connected, and then you get an extra settings or about button on the controller. That is where you get the firmware version.

I sure wish they made a complete manual for these machines. They are great, but the documentation is truly a nightmare.

As far as I know, the only requirement is that the machine is on with any tool head.

Tried it. Nope. Only the 3D print head gets you the extra info on the controller. Cheers!

I ´m having the same Problem printing from USB stick.
I ´m using enclosure v 1.2.
Every Thing works well until I close the doors.
Then the prinhead runns into the X Limit steppermotor runs a few seconds and then the print continues outside the bed the origin seems tobe changed after Closing the doors.
Can anyone give some hints to solve this problem exept disconnectin the door switches.

Hans50

I had the exact same problem and ended up unplugging the enclosure.

2 Likes

After installing enclosure 1.1 I experienced the same problem. After doing some experiments with console commands I found a workaround that works with my enclosure 1.1:

  • plug to your snapmaker using an USB cable
  • activate the connection
  • in the console window enter command “M1010”. This will report the current status of the door enclosure switch. My status was “off”, may be this is the default status when shipping snapmaker to the customer.
  • Using commands “M1010 S1” and “M1010 S0” you can now change the status by enabling or disabling the door enclosure.

After enabling door enclosure with “M1010 S1” the enclusure switch now works as expected when printing, regardless if the USB cable is plugged or not.

Maybe this is a firmware problem, I have reported my results already to the support team.
Because the door enclosure is not of interest in print mode, for me it seems there is no door enclosure setting command included in the gcode and therefore the initial status will never change until you change it manually via USB connection.

2 Likes

looks like this worked for me! thanks so much

Hello,Just to join this post as I had exactly the same problem.

Since day one I use the SM Original with the enclosure v1.1 and was running firmware Snapmaker-Base-2.9 without having any trouble.

Few days ago, I updated the firmware to Snapmaker-GD32Base-2.11 and from that moment I started to have the same behavior as described in the first post and the only way to solve it was to disconnect the enclosure cable as the macro commands did not work.

Firmware problem?