Touchscreen says 100% but print was only about 50% done

So I was printing, and all was going well. I let it run overnight because it was a long print. It was about 40% done when I went to bed. I got up to check and the screen said it was done, at 100%, but then I looked at the print and it was only about 50% done… The filament was fine. Anyone ever experience this?

Nevermind, I think I found out why. I attempted to restart the project and when it was starting no filament came out the nozzle like it normally does. So I stopped the run and checked the nozzle. Looks like something got clogged. Does this happen often? Is it bad filament? I JUST put in a new hot end kit, so the nozzle is mint. Running now, hopefully no more issues.

If plastic stops extruding its usually caused by a jam or the extruder gear stripping the filament. This can be caused by excessive retractions.

Can you share your retraction settings?

For me, I can say that I only once had a clogged nozzle - and I’ve perhaps done 75-100 prints max. during my “career”. The retraction problem I had a few times, i.e. that too many retractions in a short time grinded my filament to the point the gear did not engage any more. Honestly, retratction for me caused more problems that it solved. I hardly use it anymore - stringing might be annoying, but with a sharp knife it’s easily removed. The only thing in retraction that I use is extra prime amount, to avoid underextrusion after a long travel.

Since you said the nozzle wasn’t clogged (restart worked fine), something prevented the extruder from pushing filament out. The filament run out detector only notices when the filament breaks or ends. It doesn’t notice when the filament is intact but can’t extrude.

Are you using the stock filament holder? A lot of people have had problems with friction and binding on the filament using the default location. There are several filament holders and guides available on thingiverse that help that issue. At one point, snapmaker was recommending this one that sits above the print head. But you can get away with filament guides too.

This is what I found in Cura:

I haven’t modified these settings, fyi

Sorry, maybe I didn’t state it correctly. Just the restart itself did not fix it. When I restarted, I noticed the filament wasn’t extruding. So I went to the settings and did a manual load and gave the filament a little push and it started coming out. However, it was not a normal extrusion. It would curl up and make a little nest on the nozzle. I wiped it off and kept doing the manual load to push filament thru (I stopped pushing at this point). Eventually after a few manual loads the filament started coming out straight (normal).

THANK YOU for this spool holder. IT IS AWESOME and I will be making it… =)

1 Like

Like @hauke I’ve found actual clogs to be extremely rare.

Usually when filament isn’t extruding it’s caused by one of three things:
Too low nozzle temp.
Too low z-offset (doesn’t allow filament to exit nozzle)
Filament binding (either on roll itself, or tangled/dragging on something else)

When I’ve had filament get chewed by extruder gears, it’s usually related to those 3 also. Sometimes if wet or old or brittle I’ll have problems extruding also.


1 Like

That the filament only came out after you gave it a push is a strong indication of filament grinding, i.e. the filament was chewed away by the feeder gear. I’d strongly recommend to open the front flap of the printhead - you most likely will find a lot of filament chips and you should clean them out.

Looking on your Cura settings, these are the defaults, and I find them not very good. It basically says: If the print head travels with no extrusion more than 0.8 mm, do a retraction. Depending on the model you print that may happen very often. And it allows this to happen in quick succession up to 90 times - that’s a lot IMHO, at least with “aggressive”, ungeared feeders like the SM2 one. Also, there’s no extra prime amount, and that often causes underextrusion after a longer travel. If you want to use retraction (as I said: I don’t and accept the resulting stringing), I’d go for something like “Retraction Minimum Travel” set to 5 mm or even more, “Max. Retraction Count” 10 or even less, and add an extra prime amount of ~2 mm³, perhaps even 3.

If you’d follow my example, I’d leave the tickmark “Enable retraction”, but set “Retraction Distance” to 0 (i.e. no retraction), and set an extra prime amount against underextrusion after travel. That gives me decent results with a bit of stringing.

EDIT: A bit of recommended reading/watching:

EDIT EDIT: You wrote that the filament did not come out “nomal”, i.e. it curled intead of coming out straight. Don’t bother! As long as it comes out in a regular flow, all is well. It curls sometines, and if it starts to, it often does not stop. Never kept me from a good print.

Thats probably it then, your retraction settings are more appropriate for a bowden extruder setup rather than a direct drive setup like on the Snapmaker.

I would try retraction settings of 2mm at a speed of 30mm/s and also reduce your maximum retraction count to 40. You can calibrate for the most appropriate retraction settings for your filament, I recommnend teaching tech’s calibration guide

If that doesnt prevent the issue, its likely caused by binding or tension along your filament line. I would recommend printing a different spool holder to try and remedy this, something that uses bearings for extra smooth action and feeds the extruder from above.

Its unlikely to be due to you printing with too low a z offset as you said this extrusion failure occured 50% through a print. If your offset was causing the extrusion issue you would see it stop extruding within the first few layers.