Dual Extrusion - filament stuck in nozzel (not clogged)

So here I am, wanting to print something multicolor on my Dual Extrusion module.
Calibration worked, but after that, everything failed.
It stopped feeding filament after about 30 minutes in. I played with retraction, speed, temperature.
However, now, filament is stuck in one of my nozzles. I heated it up, i tried to push with a needle, everything. The nozzle is free now, but the tube between the gears and the nozzle is jamed with filament and I can’t get it out…

Any ideas on how to do that without screwing and taking guarantee/warranty risks?

Contacted snapmaker for warranty. Waiting for their reply now.

1 Like

I had a similar problem, it was broken filament inside the part from the extruder-gear to hotend.

I used needle nose pliers to work the piece loose and after disassembling the whole-hotend-changing-piece the rest of filament fell out.

Hope this helps.

1 Like

I’m having the same issue the filament is stuck in the hot end

I think we all are… I’m in the same boat.

There seems to be an issue with at least some dual extruders clogging. I’ve seen quite a few reports now that involve clogging and stuck filament, and it seems to almost always be the right one that has problems. It’s happened to me as well, thankfully I was able to clear it but there might be an underlying issue here. @Melitta_Snapmaker, is this something you are looking into? Thanks!



I had a really good run when I first got it… either all my filament is bad or it’s something with the direct drives.

Double extruder right black filament see picture nozzle clogged more and more often how can I fix this ??

There isn’t a fix yet. My DX is sitting on top of my enclosure right now till they get their stuff together.

I have the same priblem with the right extruder. Do you also get this error from Luban?

Luban 4.7.1
Default nozzles delivered with extruder.

My guessing is, the main problem comes from the inconsitent temperature regulation of the right extruder.
I played around a bit with pid and there is NO change on the right nozzle in temperature rising and falling ±7 degree.
Left extruder regulation is ok, the temp sits on point.

@Riskey, please forward to your devs, right nozzle has a very limited temperature regulation, pid values doesnt work for the right extruder.
I am printing only with the left nozzle right now and have nearly similar problems on the left side but not that often so this could come from my really old brittle filament, i will compare.

If you undo the set screw the filament tube and nozzle fall out. You can remove the filament from there.

Same thing happened to me.

1 Like

I’m finding the same problem. I think it’s a very poor design of the feeder gears. Sometimes they engage, sometimes they don’t. I’m trying to run a long print, and am on my 4th attempt. The last 3 attempts the right nozzle, which is PLA, stops extruding. Once it was jammed by heat. Once the gears were no longer engaging. Even though the clip of the gears is fully closed, you can still move the filament freely in and out of it.

Hi. I use Prusaslicer and have successfully completed over 14 hour printing session.
The result is not good because the prime tower was broken but did not cause any problems with extrusion.
Well dried PLA filament was used for both extruders, with a normal retraction of 1mm and a tool change retraction of 10mm.
Both nozzles are kept at 190 degrees Celsius during printing because dislike temperature changes.
You can refer to it if you like. Thx.

@iMats at the end, how did you solve the problem. I’m facing exactly your situation…

Just to make you aware of another discussion happening around the same issue: Dual Extrusion Head: Heat creep? More likely: Bad feeder! OR: bad heat break to heat sink connection --> use thermal grease! - #24 by mswietlicki

TL;DR: It seems that the right nozzle is somehow prone to heat creep, no solution identified yet.

I am having the same issue. I think there is a design flaw in the hotend. I have four of the .4mm hotends and two hardened .4mm hotends, and all of them have the same issue. I have a set of .4mm drill bits to clear nozzle blockages, and interestingly enough, the nozzles in all situations are not blocked. The blockage occurs further up the hotend assembly.

I am getting very little help from Snapmaker, unfortunately. There is no official word from them on the issue or what the correct procedure is to remove the stuck filament.

I have resorted to taking the hotend out of the printer. Letting it cool. Then, take it apart and drill out the stuck filament. This risks damage to the hotend, but unless Snapmaker addresses this, then there is nothing else that can be done.

Seriously annoyed.

I would also add that the calibration process built into the machine is broken. The right-hand nozzle temperatures are all over the place. It never gets hot enough for long enough to do a good print. Also, the routines assume 200 degrees. This assumption, in a lot of cases, is wrong. We all have our own filament and we should know what temperature to print these at. I have asked Snapmaker to publish the calibration routine STLs so we can adjust the settings in Luban, but so far they have not provided these or even acknowledged there is an issue.

I now have the two calibration print files from Snapmaker. Sharing them here.
CalibrationXY.zip (13.8 KB)