New 350 Dead on Arrival

So I put my new A350T printer together but when I turn on the power the little “S” logo shows up for a second or so. I hear a slight noise like perhaps a stepper motor is trying to move and then the screen goes blank and the sound changes in the power unit and nothing ales happens. Like it is dead or something. This happens each time the power is turned on.
Anyone have any clue what might be the problem?

Check that you have not inverted any of the cables. The connectors have a clip, but still can be connected backwards, usually burning someting.

Unplug and replug all your cables (with power off).
Triple check that they’re plugged in to the right places.
Make sure the hand controller is pushed all the way in (On mine it needed an extra click beyond what I thought at first)
If that doesn’t work email support.

You can also try and see if you can connect and control with usb and computer.



I think I have the same issue…

Just sent this to zendesk, but maybe y’all have any ideas that can fix it in the meantime?

I just assembled the snapmaker 2.0 A350 T, As well as the enclosure and air purifier. I followed the instructions precisely. When I turned on the snapmaker, at 1st there was no reaction from the touch screen at all. I made sure all the cables were plugged in appropriately and made sure they weren’t wiggling. During the installation I had noticed that the the plug in for the touchscreen seemed to be be a little less stable then the other connectors. After powering the power station back on and making sure the lights were breathing or pulsing normally I made sure the console was doing the same, and saw the touchscreen Flash on with the snapmaker logo. However, It went straight to a black screen after and gave no further reactions. I tried to turn off the power and turn it back on, without any changes. I then turned off the power, unplugged the touch screen, turned it 180゚, plugged it back in and turned the power back on… Still no change… I then installed luban 4.1.3 On my computer and connected the my computer via USB cable to the snapmaker. It appeared to work. The touchscreen still was not working. Is the luban software detected the snapmaker sir including the laser, air purifier, enclosure While connected via com 5. I was not able to connect with Wi-Fi. I was able to control the access with the snapmaker a loban software, however, the LEDs are still not turning on and neither does the fan. At this point, I am fairly certain that the touchscreen is simply malfunctioning and needs to be replaced be replaced. I am unsure about the LED’s as well as the fan. Can they only be controlled through the touch screen?

Please advice how to go from here.

If the enclosure is correctly connected, you should be able to control its fan and LEDs via Luban (possibly only when connected by wifi, possibly buggy in some versions) or directly by issuing gcodes as well as via the touchscreen.

So I returned the machine and got a replacement from Amazon. Now, I seem to understand from some cryptic messages from Snapmaker that some A350 machines that should be the latest AT models were shipped with some wrong parts like the new ones have two 8 mm and three 20 mm linear modules. X axis (20mm), Y axis (20mm), Z axis (8mm). The one I received now works perfectly and has these linear modules which are lazer engraved with this information and also the manual that came with it referred to this. The one I returned had a different manual and the linear modules had codes molded in them if I remember correctly. So apparently, some one made a mistake with a number of these units late last year and put old linear modules with a new controller of something like that and typically when the A350 is turned on the snapmaker logo appears briefly, you will hear a faint noise when the linear modules try to initialize then the display will go blank and it turns itself off. I thought this might explain some of the faults reported with new machines lately.

You description perfectly matches my problem. I made a video and send it to snapmaker, they told me my display has a malfunction.
I have to say, it worked for a few minutes and then when black immediately after the noise of the modules.
I’ll see what happens next, it works with the computer though. At least :confused:

You can try turning over the connector to the display. Sometimes that seems to fix it. Also make sure it’s plugged in all the way. I thought mine was plugged in but needed to go one more click to be fully seated.
Check where the cable enters the display. Some people have received ones with obvious problems where the colored wires are visible.


Thanks for your tip. To be honest, I think I nearly read every thread in this forum about this and tried everything. I’m an electrician and programmer, so I really try many stuff… I thought about checking the connector inside the cpu… but it’s three days old now. I wait for the next answer from the support. I don’t want to screw up my warranty.

I’m having the same issues.
Until now I always succeeded to temporarily fix it by unplugging and replugging the touch screen cable and rebooting the power. Sometimes it needs a few times and sometimes it helps to turn the connector 180 degrees.
Then it’ll typically work until I unplug and replug the USB stick, which disturbs the USB-c connection (e.g. because I slightly touch the cable).
So either it’s a bad connection in the touch screen cable, or it’s a bad connection in the controller usb-c port. I contacted support, hope to get a replacement soon…

The support told me to talk to the company I bought it, and said I should replace the screen.
I’ll see if it’s better after the replacement.

I’m just afraid it will take some weeks to get it :confused:

The controller is the same between AT and non-AT models, the screen too. The linear modules have to match though, either all old or all new. Don’t mix linear modules without 8mm/20mm engraving with those that have the engraving. The connectors are tricky though. I got a brand new F350 and thought it was DOA, nothing moved. Turned out that one of the cables was not plugged in properly. Same for controller and touch panel, if not plugged in properly before turning it on it may not work. Also, Luban, octoprint or similar connected via USB will show something even with the touch panel disconnected. I’m running a “FrankenSnap” with Octopi only, no touch panel, and it works.

Check if the touch screen connector keeps being seated well.
Mine was tilting downwards due to the weight of the cable.
I added a rubber band to hold it up:

With regard to the touch screen; I noticed during construction that the USB-C plug is kind of loose and it is easy to put strain on it. Over time this would likely cause the plug or socket to get bad connections. I also have the enclosure and made a stand for it out of scrap wood laying around my workshop and mounted the enclosure to it. I decided to route the cables (both USB and Touch Screen) below the top of the stand and enclosure by drilling a hole and putting in one of those plugs (common on desks) that will grip the cables and stop strain on them when removing the touch screen. I also mounted the touch screen stand outside the enclosure and plugged the hole in the enclosure for the touch screen. Furthermore I put a knob on the top acrylic sheet and did not screw it down so I can easily remove it. This seems to work for me and the cables have no strain on them. I think choosing a USB-C plug and socket for the touch screen was perhaps a poor choice but I would also have made the touch screen wireless since we already have WIFI capability and the touch screen runs Android like a cell phone.

I’m gonna finish the air tube for the extraction and afterwards I’ll look up the mounting for the cable. I guess I will find a good solution. Thank you for your tips!

How did you connect with them? I am trying to return mine but no one is answering

I used the links on the website, but the first unit was faulty and I purchased it through the Snapmaker store on Amazon and Amazon arranged for the replacement.

I got it all solved.
Support Team got me through my return and we figure it all out. I believe they had a holiday or were off because of the lockdown.


1 Like

I am having issues as well. I get to the leveling screen and get an error message. Snapmaker sent me new parts for my Z axis, but no joy. So far I am not impressed!

While likely unhelpful, I received two used machines, purchased as new from Amazon, one was defective out of the box and the second was from Amazon warehouse and was returned without trying. Poor business practices and 100 emails from snapmaker later… not joking.