STORE feedback here


#1

This is for reporting problems and suggestions for the SnapMaker Store

As reported by @Rainie on FaceBook, the store is in Beta Test.


You can now access it in the “Header” of the forum.
You need to scroll to the top to see the header.
The Store button on snapmaker.com also works.
You can also access the store directly at store.snapmaker.com

If the store is not working for you, try Chrome, It has worked on both a Mac and PC for me.

@Rainie also reports on Facebook:
“One more thing I should mention now is that the coupon system is not ready yet. If you want to purchase the 1.6W laser engraving module at 50% discount, please wait for a little while. We will send you the coupon code when the system is developed.”


#2

The Store appears to have problems in Firefox and Explorer (v11.0.56) at least for me on a PC running Windows 7. Under Explorer it doesn’t even want to bring up the store.
In FireFox it won’t let you log in. It flashes the screen as thought the login is going to come up but then it just goes back to the Step 1 of the check out process.


#3

Hi @Tone

I was looking at it today using Firefox ( ver 59.0.2 (64-bit) ) on a Windows 10 PC and it was fine.

The little business is growing up and it is great to participate in its growth.

Doug


#4

I suspect there is a big difference between Windows 7 and 10. :slight_smile:


#5

A very big difference.


#6

Can’t find the link on an iPhone Chrome browser in this forum header. Will follow the direct link.
Thank you


#7

I see it on Safari on an iPhone. It appears under a “menu” in the header.
Did you try refreshing the page? This header was only added yesterday.
You do have to be scrolled to the top to see the header.


#8

i just tried it on the latest Internet Explorer in Win 10 and cannot see it.


#9

Can not see the Store or the problem?


#10

My apologies, I should have said I cannot see the store at all. Just a blank screen. I refreshed the site a few times and no luck in seeing any part of the store, just a blank screen. In Firefox it is fine.

It is 2;30am here bed time for me I think


#11

Can you log in? That’s what doesn’t work for me in FireFox.


#12

The store doesn’t show up for me running Windows 10 and IE 11 at work.


#13

I can’t log in through Firefox either. It redirects back to store.snapmaker.com when I click “Sign In”. But the store displays correctly otherwise. FYI on a Mac (MacOS Sierra) running latest build of Firefox (59.0.2 (64-bit)).

The online store displays fine and you can log in on Safari and Chrome on the Mac.


#14

I can access the store and I can see the link in Safari but not in Chrome. In Chrome there is no header on the iPhone. I tried Desktop View as well.


#15

Hi @Tone

Like some of the other users who have tried, the Sign-in does not work. Trying to do so gives me a blank page then after a few seconds returns me to the Store page

Doug


#16

On Firefox it is not redirecting to sso.snapmaker.com/login correctly in order for your to login. Even when you login at sso.snapmaker.com/login, and then go to store.snapmaker.com, it does not remember that you were logged in.


#17

Thanks, I have reproduced this issue. Following.

update1:
I have found the problem. Firefox need to handle submit event differently. They implemented different default behavior. I need to go explicit about what I want. It will be fixed today.

update2:
It’s fixed. Could you help me double check it. Thanks in advanced. @kelvin8r


#18

Works fine in mobile Safari on my iPhone 8+.


#19

Works fine in Chrome on Android 8.1.

In addition, was able to test the following on Mac desktop and Android 8.1:

  • log in/out.
  • add/remove items to the cart.
  • go through checkout process (Steps 1-4).
  • did not complete entering credit card info (Step 5)

#20

@whimsycwd can confirm “Sign In” is fixed on Firefox. :+1:
Tested on:

  • Desktop - MacOS Sierra, Firefox 59.0.2 (64 bit)
  • Mobile - Android 8.1, Firefox 59.0.2