Snapmaker not seeing gCode files

Hi, we’ve just assembled our Snapmaker 2.0 A350 and we’re trying to print our first 3D item. We’ve loaded the test project, generated the code, loaded it into the workspace and sent it to SM. We see the file upload dialog on the SM touchscreen and a success message but when the Got it button is pressed nothing happens.

When starting up, it doesn’t recognise the A350 and makes us choose each time,
I’ve also exported a goddess to the usb but when this is plugged in, no exported files are found. When plugging the usb into the laptop, it says there is a problem with the usb that needs to be fixed.

I’ve wondered whether it is a problem with the 64bit version of Luban, the fact that files are case sensitive on android, formatting issues with the usb but I would expect one of these to work.

Any suggestions as to what we’re doing wrong?



1 Like

The screen used to let you execute a job after uploading, but now you are required to hit buttons to load the file then start. It just defaults back to the main screen. you can swipe the screen to Files then load the file there, or you can hit Start then choose the file from the main screen.

Luban frequently loses track of the machine, so thats not unusual.

it is unknown why they changed the firmware to require you to load the file and run it when it used to just let you run it from the acceptance screen, but its silly.

As for your usb problems, some people have had problems with their thumb drives. there are some threads on how to fix that i think if you search. theres a certain way to format it to give it the best chance to work, but ideally you will get the send over wifi down pat.

if you graduate to Cura, theres a plugin to send to the machine without using luban as well.

When Luban doesn’t recognise the machine size it seems to be because the machine itself has failed to identify the size of the linear modules - if you go into settings and click about machine you see the build volume is 0x0x0. I’ve found that next power up its usually OK again.

@albutch Until last night I would’ve said the same thing, then I saw in the repository that its actually both a Luban bug and firmware bug and will be fixed in the next update of Luban, and firmware of the machine.


Not sure if a solution was ever found to this, but we’re having the same issue.
Tried different USB’s, different files and different software (Cura and Luban).
We’ve also tried rolling back the firmware and the issue still persists.
Any solution or things to try would be greatly appreciated!

It would be a good idea to factory reset the machine, then we can go from there. Update to 1.12.2 after resetting, and update us with the results even if it fixed the issue. You’ll need to reset both the controller and touchscreen.

—To reset controller, connect to the machine directly via USB cable, connect to it in Luban (make sure the CH340 driver is installed) and in the console, enter command M502, this resets the controller, then enter M500, this saves it (may be unnecessary but just in case).

—To reset the touchscreen, follow the instructions in this link:

Hi there,
We happened upon a solution, but we’re not entirely sure how!
Everything was unplugged (including the 3D module), then the machine was turned on and off. Then everything was plugged back in with the same on and off and it seems to be behaving now. We’re not sure if there was a loose wire somewhere, but it seems to have fixed it!
Thank you for your response! :slight_smile:

1 Like

Glad you fixed it! It sounds like a firmware glitch instead of anything physical. When in doubt, unplug and plug back in, common method in the electronics and computer industry. Most of the time nobody knows why it works :rofl:

Yep! When the standard ‘on and off again’ fails, ‘get angry and take it apart’ works too! :joy:

1 Like

It’s a less dangerous method than percussive maintenance, anyway. :wink:

@ElloryJaye im sorry, I can’t help myself.