Not updating and cant connect via Luban

I’ve had a SM original for a number of years now and it’s always been great.
Due to an injury last year I’ve not been able to use it for several months and when I loaded the SM software it updated and told me to update my firmware on the SM itself.

The only official instructions I can find from SnapMaker on how to update the firmware on the original is their video tutorial in which it says to go to THE 3-IN-1 3D PRINTER - Snapmaker. That page doesn’t exist anymore so just loads a 404 page.

Anyway, I did manage to find and download Snapmaker-GD32Base-2.11 which I believe is the latest firmware for the original one. I tried copying the Update.Bin file to a USB, plugged it in and turned it on. The instructions say to watch for specific LED signs to show that the update is working but no matter what I do, it boots up with a fast flashing blue LED and it never changes. I’ve tried multiple USB sticks, all running FAT32, they are definitely plugged in correctly and you can tell by looking at the screen on the snapmaker that it is aware a USB stick is plugged in. In short, it never seems to update regardless of what I do.

I then tried plugging it into my computer via USB and whilst my computer can tell it’s been plugged in, as Windows gives the new-USB noise, Luban won’t find it at all. It gives me 3 port options and regardless of which I select, it won’t find or connect to the SnapMaker.

So my final test was to just export a file to a USB stick and try and engrave it. The file was to engrave a letter right in the middle then cut a frame around it. Instead, when I started it, it just started engraving something random in the corner of the workspace. So, nothing is working and I’ve no idea what to do here. Any suggestions?

I’m not sure about the usb not working, but for the engraving, it sounds like you didn’t have your home set correctly.

For this example, I’ll use a work origin in the center of the work.

In luban

  1. Set the “Work Origin” in the “Job Setup” to “Center”. When you click ok, you should see a red dot in the center.
  2. Put in your object and choose “Create Toolpath”, export to USB.

Then plug the USB into your machine, and turn it on.

On the machine

  1. Go to Controls > Jog mode.
  2. Jog the toolhead to the center of your material, the tool tip should be touching the material but not pressed into it.
  3. Hit back.
  4. Tap "Set Origin"
  5. Tap back again.
  6. Go to Files, select your exported file
  7. Choose Start.

Hah, the engraving thing actually was a stupid error. I definitely had the home set correctly, but the CSV I imported had a 6.3mm blank boarder around the edge so was completely mis-sizing my file. Sorted that now and am able to engrave via saving a file to USB stick, but computer control and firmware updates are still not working.

For the record, I’ve used this SM with this computer many times in the past so it should all in theory be set up ready to go, not sure what the problem could be.

Thanks for your help anyway

Kinda the same boat as you…only not. lol I haven’t used my for years (original kickstarter model) due to extreme laziness but updated to Luban and connects with USB no problem but I never did a firmware update. Get the same quick flashing blue light. Not sure how to check what I have on the printer. Either way can’t print anything. Error code says M190 S70: Wait for bed temperature (1in e=32) Error: printer halted. kill() called! others < Heating failed.

Same code after unplugging the heat bed too. Getting new parts shipped. hopefully that fixes it??

1 Like