Snapmaker J1 Linear Advance results stopping prints

German:
Hallo, da ich hauptsächlich mit TPU drucke, habe ich mich heute mit der Einstellung des Linear Advance Werts beschäftigt und nun einen Wert von k=0.4 eingestellt.
Das Problem dabei ist, dass der Drucker nun des Öfteren einfach jegliche Bewegung und Extrusion stoppt. Meistens fährt er nach ein paar Sekunden weiter, manchmal passiert danach auch gar nichts mehr.
Nach dem Starten des Druckes, die Druckereinstellung im Performance Tab von normal auf “fast” zu stellen hat leider auch keine Auswirkung erzielt. (zwecks Stealthchop)
Deaktiviere ich Linear Advance bzw setze den Wert auf 0.0 ist alles ok.
Ein Video ist unten verlinkt.

English: Hello, I am mostly printing with TPU and so I testet some linear advance values and settlet for k=0.4.
Since I set that Value the printer randomly stops mid print for a few seconds and sometimes don’t even recover.
I tried to set the printer to “performance” in the printersetting on the touchscreen because I read about some Problems with the TMC Drivers in Stealthchop Mode and Linear Advance but that sadly didnt help.
If I deactivate Linear Advance eg setting the value to 0.0 everything works fine.

Do you have any solution or information about that problem?

  • Latest Firmware Versions
  • Tried with mutiple slicers and Models

Video of the stuttering: https://youtu.be/knmoFHfZzUM

As it’s written on the marlin page, high values of linear advance could cause machines movement stop or stuttering.

Would be interesting if you really need this high value.

My A350 works with a setting of 0.04, I guess.
But hey, 2.0 User here, no J1 yet.

@xchrisd Thanks for the reply.
I did the default line pattern test and the corner test a few times and a factor of 1.2 was perfect but I didnt want to go too high so I settled for the first acceptable value wich is 0.4.

With other Filaments the value is much lower but sadly not with tpu.

I see the possibility to compensate with Linear advance but isn’t it under extrusion?

Maybe compensate by pushing infill overlap and flow?

May share pictures?

@xchrisd
Here is a Video I made of the stuttering.
https://youtu.be/knmoFHfZzUM

I will post some pictures of the Linear Advance test in about 1 hour :wink:

Interesting, thanks for sharing.

Maybe this is something the devs could look about.
I would suggest to contact support, maybe there is something wrong in the firmware?
I think the controller should be strong enough to calculate this just in time.

Where do you print from?
Remote Wireless or cabled or directly on the machine interface alias touchscreen?

Yeah, I will contact the support.
I printed over the upload function of cura and other the usb stick with no difference.

0,4 is too high. My J1 with stock hotend uses 0.07 for PLA what is already higher than my klipper printer but still ok.
Not sure you even need PA for TPU because i print TPU with a flow of 3mm^3/s for example.

Right now I am printing the Linear Advance Tower and the print also stops a lot of times.

@Stelzer

Hey,
remember that we are talking about tpu 90A which is easily compressable.
The Snapmaker ist my only Marlin Printer but on my other Klipper printers the Pressure Advance value is also very high (0,25 - 0,5) with a perfect finish.

My flow ist set a maximum of 3,2mm³