Lines and gaps between print layers

Hi everyone!

I hope someone can help me out, I keep getting these gaps between print layers around print’s I’ve been doing. Since I got the snapmaker I’m yet to get a print that doesn’t have this even occasionally.


Multiple different filaments have been used. I’ve checked the gear and the nozzle.
I’ve changed temperatures from 190° - 220° in increments of 5°. I’ve checked that the filament isn’t getting tangled and seems to be feeding in fine.

I’ve changed print speeds and resolution to lower resolution and higher resolution. I just can’t figure it out.

Not only does it detract from the looks of the object the strength is severely weakened. Some of the prints tear apart like I’m tearing paper at these points.

Can anyone help me?

Did you calibrate your extruder and linear advance?


1 Like

Hi, Thanks for the info.

I’ve followed this information but I get an S-value of like 2200 (2143.55 to be exact)? This is because it only used like 8mm of filament. So I guess this means the gear is slipping.

Now writing this I felt it was strange so I did the G1 E100 F300 step again and more filament was used. Did it again and less was used. It seemed to use a different amount each time.

I’ve completely cleared out the extruder head to the best of my ability but I can’t get anything more out of it.

Looking on the snapmaker website there isn’t an option to purchase the extruder gear replacement?

As for the linear advance, is the k-value the same as the k-factor?

I would suggest to contact snapmaker support. To me this looks like a production error.
@Edwin

I hope not but possible, I did have issues with the CNC module and it needed to be replaced. The motor wouldn’t turn on at all after 30 minutes of use.

Back to the 3D printer head when using the G1 E100 F300 code after cleaning the gear and extruder head once again. It is still doing different amounts each time with no settings changed, at one point it even went backwards and spat the filament out of the top of the module.

You have to enter relative mode before, I think it’s M83

I do enter relative mode each time. I follow the instructions you posted each time.

You have to enter relative mode once, then you could extrude more than once.
I start my machine and will have a look, just a moment.

EDIT: @MyrddynEmrys Maybe your filament is a bit slippy?
Try it with less speed like G1 E100 F100 and see if this helps.

I have no idea why your extruder extrudes different amount of material every time, i could do this repeatable with the same amount.

  • preheat the toolhead to your print temperature,- maybe print temp.-tower first
  • M83
  • G1 E100 F100

Hope this helps!

1 Like

From your images I would say that you have excessive retraction settings. If you are using the Snapmaker default setting in luban it is far too much. Try setting retraction distance to 1-2mm and retraction speed to 20-35mm/s.

Your problems in getting consistent extrusion would suggest to me that either your nozzle is partially blocked or your extruder gear is gummed up with plastic shavings. Open up the door on the front of the module and use compressed gass or a tooth brush to remove any plastic that has built up on the gear. After this try feeding filament through the print module (when heated to a reasonable temp for the plastic you are using, I would suggest going high at 240C) by hand. If there is difficulty in doing this you might have a partial blockage. If so, try swapping your hot end for the spare and see if that solves the problem.

If it does, there are plenty of guides online on how you can unblock the other hot end you removed.

2 Likes