Snapmaker CNC homing issue


I have always had issues with the CNC module, which made me never actually use it and find alternative methods to achieve my goal. This time though, I really need to do engrave something over and over again, hence CNC’ing is the most suitable option.

I never asked for help, because the misbehaviour was so random. It always was related with the machine not seeming to know/understand where the position of its axis were. I just tried to connecting my computer with it, so I have more control over it. And the first thing that I notice which strikes me as odd, is that when I press the homing button in CNCjs the drill doesn’t end up at the same time every time. There is a slight difference in the Z-height.

It doesn’t help neither that there is no homing option on the touch screen when connecting the CNC module…

I think it is relevant to mention that I never experienced problems with the axis when I was using it for 3D printing.

That’s decidedly odd. Out of curiosity, when you say that that the Z-height is different, is this from a visual observation or do the actual numbers on the screen change?

One of the big problems with the Snapmaker design for CNC work is that there is a fair bit of vertical slop which gets worse the further you are from the center (on the front/back axis). Also are you homing to the center or the corner of your work piece? If it’s a visual check and you home to the corner (closer to the edge) this may be the issue.

When the motor moves the plate there’s going to be a variation in the height at the ends (think of weight transfer when you accelerate or decelerate) which is exacerbated by the use of the CNC bit which is actually driving through the material where 3D prints encounter no resistance which keeps the variance to a minimum.

There are some solutions that may help by adding a set of linear rails to force the bed to remain perfectly level at all times. Some useful threads and links: