Scaling SVG for laser cutting

Has the been any word from the staff on a software fix for this?

I’m trying to line up multiple complex cuts/engravings, and I’d rather not have to complicate my workflow or use other tools. Importing and svg at the designed size would be a huge help.

You can track the status of SVG scaling here:

It looks like not much progress has been made yet.

If you are experiencing a different issue then a new issue would need to be created in Github, as that’s the only one I see related to size. I recall seeing another topic on this forum related to a dxf import problem, but I don’t see a ticket related to that.

The Github issue creator noted that 3.8.0 worked, maybe try reverting to that version.


I just commented on this issue as I see the same issue with FreeCAD 0.19 and SVG as well as DXF. Would it be better to create a separate issue on this one in GitHub? Please let me know and I can do that as well.
Thanks, Chris

Hello, this is my first time on forum and not sure if I am posting in the right place for my problem. This is the closest I have found on the topic.
When I import an SVG to luban for laser print it is always in a small box. When I expand it to enlarge I can never make it large enough as the box has a lot of space between the emage and the edge of the box. I cannot figure out how to make an image larger ie. 10" x 10"
I tried making it larger in Inkscape but that did not work.

Under ‘document properties’ you can ‘resize page to content’.
This will get rid of any excess space around your artwork.


Thank you. I tried it and it worked.

Dale Mitchell

Sort of. I"m doing the same thing, SVG file from Inkscape, defined in mm (actually imported as DXF from NanoCad and then modified a little in Inkscape, so I know I have absolute dimensions right, since this is for a circuit board). My intent is to black paint a circuit board as my mask, laser off the paint, and then etch. [Yes, I could just mill it, but I don’t want to mill in the room my A250 is in.]

I do reset the size of the document in Inkscape to the size of the contents, with zero padding. I have 2 layers, and actually save off each layer as a separate SVG so in Luban I can mark one to be just vector - leave fill unchecked, and one vector with fill checked.

They come in the wrong size, annoying but I think I can scale it and get almost right. But then there’s weird difference still between the EDIT and PROCESS views, where there’s a slight offset which matches the slight selection box ‘halo’ which still remains.

Edit view, note I place my axis (0,0) mark right AT (0,0):

Process view:

When I export to workspace, the process view appears correct, meaning my exact zero is interior to my actual part to be lasered.

This is bothersome.