Printjob 'Complete' while it's not

Hey guys,

Every so often, like one in five of large prints, at any percentage during a print my A350 stops printing. It behaves like the print is completed. It shows completed at the bottom; but it has still some part of the model to print. It moves the print head to the top left corner and starts cooling down.

As an example:

On the screen it shows complete on the bottom but has11+ hours left on estimated time and indicates that it is only 69% completed.
I cannot find any way to resume the print, there is still power and filament loaded.

These numbers vary when it happens and when I restart the print from scratch it might print fully.
It happened on different print jobs, mainly the larger jobs, mostly 24+ hour jobs.

Initially I thought it might be some g-code, but when restarted it might print totally fine (or not).

anybody an idea why this is happening? Or how I could troubleshoot this or find the cause so I can check upfront.
It’s a bit frustrating when you have a long print running and this happens.

just happened with a 2hour print. 96% status complete, but model not completely printed. Any advice would be wildly appreciated.

Share the gcode with us, please.

Which slicer do you use?
Which settings?
How did you print (thumbdrive, wlan-connection, usb-connection, touchscreen)?
Which firmware do you run?
Have you an connected enclosure?

Never heard from such an issue so far.

1 Like

Hi @xchrisd, thanks for the reply.

Currently using Cura 4.5.0, also had this issue with Cura 4.6.1 (and additional issues with stringing).
I’m transferring files using the original usb-drive, selecting the file using the usb menu on the touch screen.
Firmware version is blank in the ‘about printer’ screen.
touchscreen version v1.7.0.0
No enclosure attached.

I have Wlan configured, but not using it currently.

Link to G-code file

Have you tried with the latest firmware from the forum?
It is now at 1.10, i guess.
There is a bug that the print is not completing at 99%, but I never had this bug yet, so I suggest you to update.

1 Like

I have the same model running currently after just moving one of the objects and reslicing, no other settings changed. I’ll post the result.
After that I’ll do the firmware update and reprint the first and second file to see if the behavior changes.
Thanks for the feedback.

1 Like

I had a look at your gcode file.
There are many holes, why?- Independently to your other issue, this is not normal, i guess.

Maybe this could be solved with 1 or 2 less walls.
Why don´t you drive the tool-head to home position at the end?
Line: 131786
G28 X0 Y0
this should be:
G28 X Y ;(to home X and Y axis)
G28 ;(to home all axis)

Have you got an enclosure connected?

I had an issue several times, when loading filament or something, i wiggled at the printhead-connector, this caused a system failure.- The light turns off, the controller stopped but the touchscreen was still active.- This sounds a bit like your problem.- Check the connection, please :wink:

1 Like

Hi, I’ll Check that connector and make sure it’s connected properly.

Concerning the gaps; I didn’t notice them and apparently are not an issue. they are not noticable on the model.

So the second print worked like a charm and completed for the full 100%, also restarted the initial g-code file on an Ender3 and this also printed the full 100%. Safe to assume it’s not a g-code issue I guess.

Also thinking back on some of the previous fails. After the print marked complete, but before switching the printer off and on again, I noticed that the usb drive indicated 0KB/0KB and no files on it. I checked this also with other failed prints with the same issue but this was not always the case. But this would also point to some connector issues.

As you indicate it might have something to do with connectors. Still I would expect the print not to be marked as complete. I Actually do not know what check is performed to make the snapmaker mark the print as complete.
I was thinking, and this is just speculation, an end-of-file, which may be caused by faulty usb connection, might trigger this. But again this is speculation, I do not have any insight in this matter.

Thanks again for the feedback, I’ll update this topic as I progress in troubleshooting and making changes.


I think with the latest firmware, the touchscreen downloads the files from the USB-stick, this may help.

1 Like

Is the percentage counter at the start of the print indicating this? Because it’s already doing this.
Still need to update the firmware. Going to upgrade to 1.9.0 because i got the feedback that 1.10.0 might have some issues?

Is it possible to backup the firmware that’s on the machine right now? Since I don’t have a version I cannot revert to that exact version for troubleshooting.

You can easily go back, older firmwares are in the forum.
I would suggest to go to the latest, I had no issues with 1.10 yet.

Edit: it might be helpful to save your M503 values to you PC!


Hi G3ck0, you can easily go back to a previous firmware version if you wish, but please update to the latest firmware version first to see if the problem is resolved. And yes the touchscreen stores file information in the latest firmware :smiley:

1 Like

Ok, so I ran 5 other small jobs. 2 out of five had this issue.

Clicked the Complete button and changed to usb drive, result 0KB/0KB both occasions. So also might start some tests withother usb drive (probably going to use the one from SM1)

Updating firmware version to 1.10 and re-calibrating.
I’ll get back with some test results for the failed prints with new firmware once I had some time to test.

Updated Firmware to version 1.10
First issue I ran into was the auto-bed leveling pushing the hotend into the printplate.
How should I correct this?

As a sidenote; also went back to version 1.9 and had the same issue.

Auto bed leveling was working fine before. Do I need to input all the G29 coordinates as they changed? I assume the auto bed leveling would take care of that? or am I wrong?

Feel free to move to a separate topic if required.

@JKC20, So how do I revert to the initial firmware? Since I currently cannot simply get the bedlevel correct with these firmware versions and risk damaging the bed I would like to revert so I can do some prints and deliver the goods. Afterwards I can thinker a bit more with this new firmware.

Same as new firmware, take which you want

I think your USB Stick is inconsistent.


@xchrisd, thanks for the followup!

So now i restored the version, values on the about screen differ from the ootb values but OK.
Anyway,auto leveling still pushes the nozzle into the bed.
Any suggestion on how to fix this and get auto leveling functioning again?
Also seems like the Z distance for the home position changes when I change the firmware version, might this be a cause?

Maybe these are silly questions but it’s the first time I need to dive into these command codes. Up till now both my SM1 and SM2 did what was expected of them. (minus the usb issues :wink: )

Anyway thanks again for the provided help.

There is a thread about how to adjust the leveling sensor.
I would suggest you to actuate the sensor once while traveling to the bed (middle of the Z-axis), then it will travel slower.
Hope this helps.
Above fw 1.9 there is the enclosure update included, I guess.