Printing TPU with A250 (or any SM 2.0)

Thanks for the tips. I will try a looser calibration. One comment though about the slippage: I don’t think my problem is the TPU slipping. When I open the filament hatch, I can see the filament is buckled between the gear and the hole entering the hot end. This implies to me that it didn’t slip, it just couldn’t take the pressure the filament driver was trying to deliver. I can see how slowing down would help and so would a looser first layer as both should reduce the required flow and thus pressure in the filament driver.

TPU is always going to be problematic with the current feed path design. Its the first thing i looked at when I opened the 3D printer head flap. The filament path is not constrained enough for flex filaments and combined with a flat tooth gear rather than a hobbed extruded gear its always gonna have problems like the filament wandering and jamming up inside.

Contrast that with a dual drive BMG type arrangement with dual hobbed gears and you can print TPU at 30-40mm/s without issue. I will look at at least replacing the drive gear with a hobbed gear which should be doable and that might improve things a bit

1 Like

First 2 pics are a dual drive gear BMG clone. 2nd pics are the snapmaker extruder gear. See the difference. Unfortunatle snapmaker uses a proprietary very slim drive gear… so not an easy swap

1 Like

Might be able to 3d print a small plastic piece that could be glued to the filament guide to close the gap and stop filament wandering… This might do it


So yup after putting is an optimised insert into the print head to constrain wandering flex filament + a slightly stronger spring. happily printitng TPU at 40mm/sec with retraction. TPU is bioflex which is 27Shore D hardness or around 75A as most other filaments are measured in.

This is the modification:

2 test cubes printed all at once mode so lots of retractions, using CURA 4.2 at 40mm/sec . Am sure flow setting could be tuned a bit. Outer wall printed at 30mm/s
inner wall printed at 40mm/sec hence it a little rough


@chazr33gtr, any chance you want to share that stl?

@stevilg sure no probs… here it is… as one solid piece… and in two halves for easier printingsnapmaker_flex_feed_adapter_2_halves.STL (40.5 KB) snapmaker_flex_feed_adapter_one_piece.STL (38.4 KB)


Nicely done! I had some ninjaflex that failed to print previously that I will try again once I have this part inserted. Did you glue this in place or just let the door hold it in place?

I didnt glue it just let it be held in place by the door. I guess you could glue in place with a bit of cyanoacrylate (super glue). If the print doesnt come out clean then you may need to gently file or dremmel the part


It seems like one of the problems is that when you load it loads too quickly. It ends up jamming and looping up inside the housing before I can even try to print. Is there a way to slow down or control loading through command prompts in Luban?
I tried printing the adapters in pla and petg but didn’t have much success. Maybe I need to dial in my settings a little more. I’ve had no problems with larger items but I just ended up with stringing and bad overhangs on these smaller parts. Or I need to try slicing them in Cura.


Finally successful with TPU!

Thank you so much for the adapter idea chazr33gtr!

I kept having problems getting the adapters to print and when I did they were so fragile I ended up breaking them. Then it occurred to me that it is a CNC machine. I created a new version of the adapter in Fusion and then milled it out of a block of teflon I happened to have (my grandfather worked in aerospace as a material and process engineer). Had to do a little whittling and filing to take care of some areas my bit was too big too reach.
No more backup loops!
Printing at 18mm/s to start. Now I’ll have to start playing around and see how fast I can push it. I printed with a brim for the cube. Trying a skirt now. Needed the first half of the loop to be flowing properly.
The best thing about the adapter is not having to take anything apart to add it. Easy to remove (not sure I’ll need to) for other filaments.


Share the file for cnc please!

1 Like

Here you go. Fusion 360 files had to be zipped.

Milled profile first. Block I had was 15mm so I just used utility knife to separate from base. Then rotated piece 90 deg to cut the hole/slot using a wooden vise to hold it. Made slot slightly undersized so I didn’t have to be perfect centering it and could enlarge by hand. When you run boundary it shows you pretty well if you’re lined up correctly.
Flattened top and bottom tabs and squared up inside angle with a file.
Door should close with some pressure. I couldn’t install it on the machine. Had to lay head on it’s back to keep it from sliding out.
-S (374.3 KB) SM2_adapter hole_single pass.cnc (2.8 KB) SM2_TPU adapter single pass 3_175mm.cnc (1.3 MB) Snapmaker 2 TPU adapter.stl (51.0 KB)


Finally started working with TPU today and glad i checked back here first for the adapter! I printed that first (thanks @chazr33gtr !!) before swapping to TPU, then just tried higher temp and slower output (to lower the pressure) and that didn’t quite seem to do it. It still output SOME filament, but it wasn’t consistent enough. Without being able to watch the inside of the box, I suspect that the filament would get bunched, slip off, release, and slide back on. But with the adapter, no problem!

I did make an addition to it so I could print the single piece. I hate doing multiple pieces when I don’t have to if I can just add on a support or something that I can remove later. I also hate the generated supports and try to add my own. Attached is a breakaway tab so you can print the single piece easier that you can bend or cut off fairly easy (it just has 1-2 layers of attachment to the model, which should be plenty to keep the surface area up to the base plate).

Since I use Simplify3D, i also tend to print with Single Extrusion enabled and allow for single extruded walls (which is what it did for the side tab and the single small vertical).

snapmaker_flex_feed_adapter_one_piece_w_breakaway.stl (29.9 KB)

Currently printing an ear saver (slated to print a bunch of these for local game store with their logo, and a bunch more for cousin’s group of teachers!). printing at 220 (high end of filament temp) @ 20mm/s all the way around (per the video, but i would bet now with the adapter it could go higher).

UPDATE: Yup, turned out pretty great actually.

For those using Simplify3D, here is my TPU profile (i only used 50% infill for this model, but there was barely any infill anyway, so nearly 100%).

Snapmaker 2.0 - Med - TPU.fff (11.9 KB)

I still need some work on the model itself, but mostly the wording since that was pretty tiny to begin with. That doesn’t really have anything to do with the TPU you as it printed like any other once I got the adapter in there.


Hadn’t thought of doing it that way. That would’ve solved the problems I was having printing the single piece. Always more than one way to do something. It’s always fun to see other’s solutions.

It’s so nice to be able to print flexible filament. Opens up so many more things to print.
I dropped the controller for my A350 a couple times and was worried about breaking it. Designed a simple bumper case to help protect it.



Hi all, I’m trying to print TPU with my A250 for 1st time.
As this thread mentioned about, the max speed should set in 20mm/s. (or lower)

Just wondering, which speed should I set in Luban ?

all of them except the travel speeds :slight_smile:

1 Like

With adapter this is what worked for me (with Filamentone Pro Select TPU):

Haven’t had a chance to try how much I can speed things up. Only printed smaller items so far that weren’t going to take that long anyway.


I got very weird print result with TPU…
Here’s my 3D object, clearly, text and plate ware there : (And merged in 1 module)
Plate was 2 mm height, and text was 1mm.

Also in Luban :

Setting was followed with @sdj544 's hint, but the result …

My A250 shows print progress was 100% complete, but there is no text…
and there is no failed filament when print finished, so it seems not just print fail. (Both are just 2mm height)
How is it happening ?

It may caused by Luban’s slicing … maybe a bug ?

I just re-create whole stamp to 140 x 90 mm, so that I can make text larger.
When Luban slice finished, I swap Outer Wall on/off in preview, here’s result :
Outer Wall ON

Outer Wall OFF, some text are totally disappeared, no Inner Wall and Skin