Printing TPU with A250 (or any SM 2.0)


I just tried to print TPU with the Snapmaker 2.0 A250. Sadly after about 10 minutes it seems that the nozzle gets clogged and it the filament gets stick inside the head. Are there any suggestions how it could get better?
I have set the settings for the print same as for PLA with high quality, but increased the nozzle temperature to 230°C and lowered the bed temperature to 60°C.
As Filament I use the “extrudr Filament TPU black 1.75mm A98 750g”.

Kind regards


Turn the retraction off or lower it, instead printing TPU is like hell :wink:

1 Like

I’ve heard that you have to print with very slow speeds. Because it is soft if the print head is trying to push it thru too fast it will grind a notch in it and stop flowing. The nozzle isn’t actually getting plugged, it’s not being able to drive it thru. I have some TPU but haven’t used it yet.

I’ve been printing with TPU on my A350 for the last couple of weeks and have been very happy with my current workflow. the three things that I have found that made the difference between making good prints and making string.
Temperature was huge, the difference between 210 and 220 were huge.
Max speed of 20 with no retractions
When I calibrated level, I found I either had to take my PLA calibration height and raise the Z axis by .05mm, or calibrate for TPU, instead of using 1 sheet of cheap copier paper, I use 2 sheets of cheap copier paper.


That’s one way to compensate for the fact the filament probably doesn’t move through the print head quite the same. You should probably use a different filament flow calibration (I forget the M number).

Thanks for your response.
After some more fails, it worked well with these settings:

Nozzle temperature: 230°C
Max speed: 15mm/s
Bed temperature: 60°C
Layer hight: 0.1mm
Layer hight (1st layer): 0.16mm
Retraction: off


sorry, ment 0.16mm, I’ve corrected it

I am trying flexible (in my case its M3D’s Tough 3D) in my A250 and its jamming. I am concerned that no print settings will fix it because I can get it to do it before I even print. If I heat up the nozzle (tried a few temps) and then “load” the first time and then “load” again just to draw out more filament then open the head up, I can see that the filament is starting to coil (see image).

1 Like

M3D Tough is closer to PETG than it is to TPU. There should be no issue printing it on the SM2.

Is your cold section fan running as soon as you start to heat the nozzle? What temps are you using?

@DroneOn yes, the intake (I assume you meant suction) fan runs as soon as I heat it. I’ve tried temps from 230 to 255 with better success at the top of that range, but always get coiling inside.

@stevilg I’ll try some Tough tomorrow if I have time and report back.

Decided to give Kodak flex 98 a try. It too eventually coils inside the head and stops printing. For flex98 printing at 235, no retraction, 20 mm/s.

Trying to print TPU here as well on my A350. 1.75mm filament from Matterhackers.

Tried nozzle temp of 235 and it extrudes well during loading, but not so much during the print. I mirrored the settings in the thread here

Can someone post their FULL settings that they use to include the print quality area?!

Pic attached for what it looks like.IMG_2865|375x500

1 Like

This picture says to me, your bed is not well leveled, you just took a picture of the first layer,- right?
look at it a few layers later if it goes better then.

1 Like

Thats what I thought too, but I just printed PETG with no issues with auto-leveling.

The picture was taken after an hour of printing, so figure 6-7 levels. It started on the top part, then just stopped extruding.

have u turned retraction off and printed slow speed ~20mm/s?
See you a curl inside at the gear of the extruder?

Yeah, retraction is turned off and it’s at 20mm/s.

I hadn’t looked for a curl in the gear. Can you run it with that part open? Or are you saying to look when it’s stopped?

you have to look at it when it stands, if it is open, it feeds not more

I have to say the one thing that had a huge impact on me was infill. Using snapmaker luban, infill seems to be auto-calculated to something too fast for my attempts using flexible. Once I switched over to Cura and slowed the infill to match my base print speed, i had a lot better luck.

What settings did you specifically use to slow down the infil rate to?