No issues printing TPU before but having problems now

I haven’t had issues printing with the Sainsmart TPU (Hardness 95a) in the past but recently I have issues where the filament is bunching up in the extruder.

I’ve dried the filament over night in my esun drier, leveleled multiple times and disabled the retraction settings, but I still keep having the issue.

The filament is not pushed against the extruder gear by the idler pully. It just ends up bunching up and not extruding.

Any idea what I can do?

It could be a change in the filament over time even if it is dry.
Maybe it’s a clog and need to clean your nozzle. Haven’t needed to do it but I’ve heard it recommended that any time before using tpu you do a cold pull on previous filament to make sure nothing else in there. Some even suggest using a separate hot end/nozzle.
Maybe there’s been some build-up over time.
Possibly there’s been just enough gear wear or the distances have loosened up over time so wheel isn’t pushing it against gear as it should. (although it sounds like it’s pushing it fine).
Are you using adapter?
Otherwise I would check that you’re using the normal tpu rules.
No (or almost no) retraction. All speeds except for travel the same, 15-20mm/m.
Could try heating up nozzle 5º and/or raise your z height .05.

Thanks for the response!

I forgot to mention the following:

  • Brand new spool of TPU. When I first ran into extrusion issues I dried it for ~10hrs @ 55°C.
  • Brand new nozzle (when I had extrusion issues I changed nozzles)

I’m not using an adapter, nor have I used one in the past. Which adapter would I need?

I increased my nozzle temperature but haven’t tried raising my Z height but I can give it a shot.

Same brand, color etc.?
Even if it is, could just be a little more flexible.

Most people find they need to use and adapter with SM for tpu:


Yep. All the same.

Thanks for the link! I’m printing off the adapter. Hopefully that helps!

Still no luck using the adapter.

The filament still bunches up in the extruder.

I wonder if it is indeed the hardness of this particular batch.

With the adapter it really shouldn’t be able to bunch up. It should block the path where it can escape. If anything it should just grind the filament.
What happens if you try to feed by hand?

Is this the original 3d head? (not the 2.5 version)

@WilliamBosacker found he had to apply scotch tape to the path to lessen pressure on filament. Hasn’t been my experience but everybody’s machine seems to be a little different.


It is the original head, and that actually prompted me to look at that. I’ve replaced it with the spare that came with the unit and its operating beautifully now.

It would seem that there was a build up of gunk in the hotend that wouldn’t resist PLA or any other hard filament, but was just too much to push against with the TPU.

I’ll advise, but it’s printing like it did before I had any issues, and it seemed like it was an incremental problem which caused me to think wear and tear rather than anything else.

1 Like

Could be the ptfe tube insert has deformed just enough to cause problems with the more flexible filament. They degrade over time. Especially if you’ve done any printing in the higher ranges, 250 or above.


That might be the case.

The printer has been running flawlessly with the new hotend. I haven’t gone up over 220°C so I don’t think that was the case.

At any rate I ordered a replacement hotend (will probably order another one) as well as some cleaning filament.

Hopefully the cleaning filament goes a long way, but the hot end replacement isn’t a costly fix.

Thanks for your assistance!

I ordered a bunch of hot-ends and put different nozzles (stainless, hardened, lesser/greater diameter, etc) on each. I figured you have to pop the hot end out anyways to replace the nozzle, and it gives me a stockpile of hot ends in case of emergency.