Printing just stoped

I had similar problems.
Sometimes the touchscreen did not start after power loss, I actually lost all gcodes on the touchscreen and had also this printer response warning saying reconnect and shutting down the app of the touchscreen saying not reacting.
Sometimes it helps to unplug and replug the touchscreen from the controller, to activate and start it again. This is a huge bug.

1 Like

What slicer did you use? I think Simplify3D makes it possible to restart at individual layers because it zero’s the E out in between each layer.

1 Like

My touchscreen has done the same thing as noted above with the app force closing.

Ive been using Luban most recently 3.4.2, but i’m looking at other slicers. I hear alot about Simplify 3D but havent had the chance to try yet. I took the failure as an opportunity to calibrate my extruder and im zeroing in on fully leveling the bed tonight before I try another large print. Always more stuff to learn and tinker with in this hobby.

Thanks all, happy printing.

2 Likes

I use Prusa Slicer and have been happy with it. Try it before you spend the money on S3D.

5 Likes

Which version of firmware you are using? First thing, please update the latest firmware via this link:SM2 firmware.

Please export the log file and send it to Snapmaker Team. Please contact support@snapmaker.com

I’m using FW version 1.7.1.1 so already the latest. I’ve grabbed the log and ill reach out to support tonight.

I am working on this and will offer the solution later. Thank you for your files. Can you send me some pictures of this issue?

I actually have video of the issue, these two videos are from after triggering the resume on power failure, and a second attempt at triggering the resume on power failure.


Beyond that I just had the same print stop, but this time job was sent over terminal via Octoprint. Looking at the Octoprint logs the terminal connection is just dropped. The print died a few layers earlier this time but the print head stopped in nearly the same spot. It occurs to me I should look at the Snapmaker logs as well, as even though the job was not run from local storage the moves are likely captured by the internal logging.

I will post these tomorrow as it is late and I am over the Snapmaker for tonight.

Thank you for your information and videos. In the email, I told you that we noticed something abnormal and still working on it. I will forward these two videos to our engineers. Sorry for the inconvenience.

2 Likes

Hi, getting the same issue here although with the laser tool head.

I’ve downloaded the new firmware but there’s no way to progress past the Warning screen, and plugging in through USB the machine says it’s not ready…

Here is Edwin.

The controller is defective. But the reason is not clear since you just swapped a toolhead.

Just wondering, can you roll back the firmware update to resolve the problem?
I am sure you may have already tried this, and curious what resulted.
I was going to update to the latest, but now I am concerned to update.
Thank you

PJ

That issue exists because of a faulty controller. If your machine functions perfectly, it is recommended to update to the latest firmware. If you have some exisiting issues with your machine, please contact our support immediately.

i did a firmwareupdate and printed today, the whole day.
The print stops at 99% and it seems the print is finished so far.

I encountered a very similar issue twice today. I just updated the firmware to Snapmaker2_V1.10.0 - the only update I’ve done since receiving the unit in December (I also recently updated Luban to 3.8.0).

As soon as I updated, two prints stopped at 99% and the controller thinks it lost power. The printer sits idle for hours until I intervene (with heat on, bed - not sure if the nozzle is also hot). Im not able to stop the print since it seems to be stuck in a loop or routine that doesn’t end, so I have to shut off the power.

When I power-cycle it goes through a recovery routine and then completes the print (no actual printing, just a re-homing and then it moves to the last position, completes, and moves back). This happened twice today after slicing an .stl with Luban and sending via Wifi (I used the new function to specify IP instead of using discovery since it has been flaky).

@JKC20, @Edwin do you think this is the same issue as xchrisd describes?

-RC

3 out of 5 prints stuck at 99%, how to solve that without cycling the machine (turn off and on)?

@RobotChicken

This is a bug of V1.10 and we have fixed it in the new firmware and will release it this week.

Best regards

2 Likes

My machine just started doing this… i rebooted it to get it unstuck and it did it on the next print too…

left a burn mark on my 6 hour print. then i went to print my new swatch for a new color and did it again.

Bout to start a longer print now and going out, i hope i make it back before it finishes so it doesnt ruin the print again…

Of course i have the latest firmware and luban, unless a new version came out in December 2020…

Furthermore, i use s3d to slice, luban to send over wifi, then run the file thru the snapmaker screen itself…

The swatch that just froze i printed 3 others yesterday and it didnt happen.

now i have to bounce back and forth between my lab and my computer to start a new print again

any ideas???

Check your end gcode and delete all comments, this was my problem. S3d swapped the comments to the next line and stops the controller.

That was it all right, looks like for some reason s3d cut the comment line in half to a 2nd line out of nowhere.

THANK YOU!

1 Like