Printer stopping during print

Fortunately it early in the print.
I’ve tried using SnapmakerJS, Cura, And Snapmaker Luban; at slow, medium, and fast speeds. I’ve rotated and flipped the piece on the bed. I’ve redrawn the piece. I’ve tried it with both the flash drive and hooked to my computer.
The printhead just stops moving and stays where it stops. The screen temps are at 0 and the current print field is blank. The door detection is off. I’ve re-flashed with 2.11 firmware.
I’m currently printing another file to see if it stops as well.
Where can I upload the STL and g-code file for someone to take a look at it?
Thanks.
John

UPDATE: Same issue with another file that I printed without issue 2 days ago.
After approximately 2 hours the print stops. The blue light is still blinking.
Next I will try with the screen disconnected while running the g-code from my laptop.

ADDITIONAL INFO: Another owner mentioned in a similar thread that the machine would not move in the negative direction on the X and Y axis. I have this same issue. The head will move with the + buttons on the screen but not the - buttons.
I am not loosing power as I am running this unit through a 500 watt UPS with a fresh battery. I have my alarm clock hooked to it as well and it has maintained the correct time so I know there has not been an interruption of power.

Hey, you could upload your stl and gcode to the forum or we transfer and share the file with us.

If you could only go in the + direction you have to home your machine first.

I will upload the files this evening when I get home from work.
I tried with a different file. Same issue. Print stopped after about 6 hours. I had the Snapmaker screen disconnected running the machine from my computer with Snapmaker Luban. I was in the room when it stopped. All the lines of code looked normal. But the last line of the code window was ECHO: V97 769 bytes downloaded. What does that mean?
I have a screen capture that I will upload as well.

I also tried using the laser with 2 different files. Laser stopped about a half hour into the job. the head stopped moving and the laser turned off after a couple of seconds.

Here’s some screenshots and the file.
This is not the only file I am having issues printing. There are a few files that I printed last week that are now failing to complete. I’ve printed a couple of smaller (< 3 hrs.) files but can’t print larger files.
I’m beginning to think that the issue lies with the motherboard. Is it possible to order a new one?

freeze3 Freeze
cover.stl (259.5 KB)
cover_33349040.zip (2.0 MB)

Hi, if the laser stops as well, it is not the gcode issue. How long have you kept the machine?
It seems that there is something wrong with the controller. You mentioned 500watt UPS. Can you try the original UPS?
You can email support@snapmaker.com
Thank you

I’ve had the machine since February.
UPS is uninterruptible power supply.
Is it possible to order a new controller board?

He has just plugged in his original power unit to a device which is battery or grid powered.
In German its called USV.

You can email support@snapmaker.com to purchase the new controller board.

@Tracy That didn’t fix it. I’m getting so disheartened with this machine. I was so excited when it arrived only to have to go through this.
The only things left are the print head, 1 of the axis, a cable, or the power supply. Not sure I want to keep throwing money at this thing. So far I’ve bought the 1600mW laser that can’t get through a complete engraving; and a new controller that didn’t fix the print stopping issue. Gonna try hooking it to a pair of truck batteries tonight to see if it’s a power feed issue.

What does “V97 stored settings retrieved” mean when it stops? Seems like it should be a fault code or something.

Crickets on that question…
I hooked my machine to a pair of 12 volt batteries (with charger attached) that I have in the truck shop I work at. I was able to finish 3 long prints with no issues. Voltage was at 25.2v with a 2.7a draw. So I ordered a Meanwell 24v/6.5a power supply from Amazon for $18. I’ll be testing the laser tonight at home with the new PS. If it works I’ll edit the first post with the fix.

As far as I know, the original power supply is 24V 5A.
Share the result of the new PS.

Hi there,
I have a Snapmaker original.
I ran into the exact same issues. After trying Snapmaker Luban this this problem started. The printer stopped printing. Temperature reading go to "0"degrees. The movement of the X, Y and Z axis are reduced to only X+, Y+ and Z+ else is not possible. The display freezes. After switching off the printer and switching it on again the printer functions ok again. First time the printer stopped at 70% finnished (4 hrs) 2nd time it came to 31% and 3th time it stopped at 20% I think in the charger/transformer or the controller. Help please.

The new power supply fixed the issue. I used an amp clamp and a kill-o-watts plug to test the draw of the Snapmaker. It would regularly hit the 120w that the original PS was stated to be capable of. It wasn’t capable of supplying 120w though. At higher wattage draws there was a voltage droop of about 1 volt. Here’s a link to the PS I got. I could hear the difference just starting up the machine. No more failed prints in 3 spools of PETG filament.