Need help: A150 strange behaviour while printing

it was couple of months that for some reasons I wasn’t able to use m y A150… today I just upgrade the firmware to the last one and also tried with both Luban last version and the v4.3.2 but my Snapmaker seems not working ok:
while printing, the head moves laterally away from the piece… it pauses for about 1 second (the filament comes out) and then resumes. The result is that my print is not good.
Never ever happened to me! I’m trying to print an already printed stl but as I told generating the gcode with the last version of Luban or with the old v4.3.2 doesn’t fix the issue.

Am I wrong? Am I miss some new feature?

The first thing to try would be downgrading the firmware, since you started seeing problems immediately after you upgraded it.

Thanks for the response, I’ve already tried to downgrade the firmware but the issue is still there.

Here there is the video of what I’m speaking about and the stl and gcode files:

Magura Reach Adj.gcode (256.1 KB)
Magura Reach Adj.stl (175.4 KB)

the problem is the slicer settings - check /search for a parameter like “Minimum Layer Time”.
There are pauses inserted in your gcod file - check/search for G4.
See a quick found example in your gcod :
;Small layer, adding delay … G4


G0 F4200 X79.357 Y80.391
;Small layer, adding delay
G1 F1500 E146.9275
G0 F4200 X79.357 Y80.391 Z9.28
G0 X96.458 Y69.993
G4 P7610

Thank you for your reply!
Yes, it seems it is “Minimum Layer Time”:

In my opinion it could be useful but in my case when the toolhead is waiting ,the filament is running out and that cause the issue when it resume printing because the filament dangles…

I hope the Snapmaker Team, will solve that issue or at least I need to understand if am I wrong on some settings.

Is there a way to disable this feature in Luban?