Print Head stuck in printed piece after complete printing

This is my second time encounter this issue. After the print job hits 100%, the print head will be stuck into the print itself, causing an error asking to re-connect.

If I click re-connect, it will fail
If I click No - It will goes back to the 100% screen and hangs there. I must reboot the entire unit.

After re-boot, I will have to go the navigate and try to home the head. Lucky for me both times, the print head will pull the printed piece out of the bed, after I heat up the nozzle and remove the printed piece.

HW Info : A250, Luban 3.3.3, Windows 10, PLA (All standard settings)

This happend to me too once (not consistent since on another try with the same file everything worked fine). It didn’t execute the end script.
Please update to the actual Snapmaker Luban version (3.4.2) and check if you have the newest firmware (don’t forget to recalibrate after an eventual firmware upgrade).

1 Like

This issue was supposedly fixed in one of the firmware updates. I personally no longer see this issue after updating to FW 1.7.0 but there is a more recent FW 1.7.1 I believe.

1 Like

I just had this problem. Running 1.10.1 firmware. Stopped at around 63%. Any idea what causes it?

Did the touchscreen report “Machine is not responding, would you like to reconnect” and reconnection attempts fail?

If not that’s a different issue, start a new thread and post your gcode.

If that is what you had happen, post your gcode.

Turns out it has something to do with the USB. Found another post where they mentioned that corrupt USB drives can cause it to fault and stop printing. So I formatted the USB drive and tried again. Everything seems to be working now.

An index out of bounds error was the culprit and it did not fail gracefully.

1 Like