Printer restarts after selecting gcode for printing

Ok I’m new to this stuff and I just unpacked and set up the original Snapmaker my wife got me for my birthday. I used the Snapmaker Luban software to load a 3D model I found and generated the gcode. I put the gcode on the supplied flash drive and selected the file from the touchscreen panel to print.

At first it started moving like it was going to work, then shut itself down and turned itself back on. The printer sat there like it was just started with no further motion.

I upgrade the firmware and still no joy.

Any sign of what could be happening here?



i have not heard of this issue before, could be an issue with the usb, have you tried sending the G-code to it via wifi. also before you try to print anything to big or important i recommend calibrating the E steps see the post below for details

Extruder Calibration a must

Thanks Atom,

I have the original Snapmaker 3D printer, so wifi is not an option for me. I did connect it to my PC via USB and was able to send the gcode to the printer using Snapmaker Luban 3.9.0 but alas no joy. It does the same thing as pulling the file from the flash drive: starts to home and then shuts down followed by a restart.

I have an email into support, but have not heard anything yet.

Your reference to the Extruder Calibration being a must, does this work with the Original?



Update: I connected the Snapmaker Original to my PC via USB. Using the console, I entered commands one by one to see where the failure occurs. I entered “M104 S205” which I believe sets the extruder nozzle temp to 205C. I watched the temp rise up passed 205 to 255 before it came back down. The temperature would swing back and forth until it reached around 203 to 219. But the unit did not restart.

I then gave it command “M140 S70” which I believe sets the bed temperature. I watched as it would rise up toward 70C but as soon as the nozzle temp fell the printer did a restart.

My suspicions were that the power supply was not able to keep up with the demands of heating the nozzle and bed simultaneously. Next I had my wife watch the green indicator light on the power supply while I entered the same commands again. The printer again restarted when both the nozzle and bed were heating up, and she said the green light blinked off and then back on. So I know the power supply is resetting.

Now the question is this: Is the power supply defective, or is the printer drawing more power than it should be in simultaneously heating the nozzle and the pad? Those wild temperature swings I saw on the nozzle have me concerned. I did not see the same behavior on the bed.

Any advice is appreciated. I have also submitted a support ticket on this.


yes calibration as described in that thread is something that is good for all 3d printers regardless of make or model. and as for the power supply, its good that you have found the problem. unfortunately i have a SM2 so i cant check to see if this is a common issue or if it is limited to your device. hopefully SM will respond to you soon, but i wouldn’t hold my breath :slight_smile:

good luck

@Dale_Chamberlain: A hot end temperature swing of 203-219C is excessive. You should probably start by calibrating the hotend PID values. (Reprap Wiki has a pretty good writeup of the process. Don’t forget the M500 command to save the new values to eeprom.

That said, the problem may not be the PID settings. A number of folks have identified an issue with the thermistor not being properly retained in the hotend. You might check out this forum thread: Constantly replacing hot-ends

1 Like

Hey, @Dale_Chamberlain welcome :wink:

I guess your printer did a heat runaway protection or you can´t start because the heat is not there for 10s before start.- Check if your thermistor is assembled well and is in the heatblock hole.

You could look at this by opening the console and looking at the running commands.

I would suggest you to add some thermal paste to the thermistor (like used for cpu cooler), there is a similar problem for some sm2.0 users.
I had the same issue at my original, my workaround was to preheat the nozzle manually and delete the gcode line to wait for the nozzle

M109 S200

Hope this helps!
PS: If you can´t go further with this hints, please make a video about your machine restarting while print, upload your gcode and show us your console, so we could see it here.

1 Like

Ok I tried the command " M303 E0 S200 C8" and the printer shuts down immediately followed by a power on. I tried it again without the E0 and got this: “PID Autotune failed! Temperature too high”

I opened up the side of the print module and took a couple of pictures of the red and white connections to the extruder. Is the thermistor connected by the red wires?

I have also uploaded a couple of videos that show what is happening when I try to print. As you can see it is a shutdown within seconds of starting and the power light on the power supply goes out and comes back on.

I have also put the gcode into the Dropbox folder:

I’m not sure what to look for around the thermistor.

Thanks for your help.


@Dale_Chamberlain, i would suggest you to write to people with adding a @xchrisd, then i see your post in my emails.

I guess your power supply is defective, because the green source indication lamp gets dark for a short time and comes back again , this is not a normal issue.

I suggest you to buy a new powersupply and print again :wink:
@Thick8 had a similar issue:

Thanks @xchrisd
I was highly suspicious of the power supply being underrated. But also concerned about the extreme temperature fluctuations of the extruder. It certainly won’t hurt to have another power supply around especially since they aren’t expensive.

I’ll try that as soon as I can get one.


I missed, the white cables are the thermistor :wink:

So should there be thermal paste where the white wires are?

Yes, at the end of the white wires is the thermistor, assemble a bit thermal paste to the hole and put the thermistor back into it.

You should make sure to use an electrive insulating thermal paste that has a temp rating at 300 or above… some cheap thermal paste will be electrically conductive and can short the thermistor. And lower temp pastes will dry out and break down leaving them ineffective.

1 Like

@xchrisd @Atom I’ve looked at the video instructions on Snapmaker’s website about replacing the thermistor and they do not mention using any thermal paste. Using it won’t void the warranty will it?


I could nothing say to this debate, do you wish to call support and wait more than a week?
Have you ever assembled thermal paste? - yes? - then do it.
You could clean it if it doesn’t work or swap the hotend to a spare part. No problem, so far, i guess.

@xchrisd I have used thermal on CPU chips but thats a different application. I just wanted to be sure this is recommended for the Snapmaker Original and not the 2.0.


I sold my original, but if I have temperature changes from what you described, I would try it. If it get worse I would assemble a spare part.
Hope you understand what I mean, there is nothing you brick, there are spare parts if needed. So no problem.

@xchrisd no problem. This is my first time with 3D printing. I understand thermal paste when using it with heatsinks but I was trying to understand its application with a thermistor. If I understand correctly, it would help distribute the heat more uniformly and hopefully not cause the wild oscillation I see now.