Random Z-banding

Hello people of Snapmaker forum. It’s finally time for me to use this forum, because I am at my wits end with the issues that my A350 is having. I have attempted everything I know how to do in order to fix the issue.

I’ve switched a y axis Linear Module with the X axis LM, as well as replacing the other y axis LM with a brand new one. I’ve attempted manual calibration. A full reset and fresh installation of firmware. Printing vibrational dampeners with TPU. Taking the printer off of the table to see if it was causing minor vibrations. Tightening the X axis carriage and the 3DP module. Nothing has worked so far. Support has given me some of these ideas, so I’ve already dealt with them, with no success.

I’m about to learn how to and go through the process of calibrating my e steps to see if that solves the issue, does this look like something that would be caused by uncalibrated e steps? Am I correct to assume that I can send codes to the machine when connected to it over wifi? I can’t seem to get the printer connected to my laptop via usb.

Recent work to my printer includes a replacement hotend being installed, and a shuffling of linear modules between the x and y axis. Perhaps it could be the new hotend? Since a shuffling of the LM on my printer doesn’t have any effect on the print quality, I’m assuming the issue has little to do with the linear modules?

There is one small issue I’m getting with the Y axis though. There are times where the bed will move a large distance in one direcrion and I’ll hear a small snap coming from one of the linear modules beneath the bed. Support has told me this is due to mismatching speeds of the Y axes LM. How can you sell a product that has that much of a discrepancy in the speed between two of the same exact things?? Is this grounds for a replacement part?

This is my first post to Snapmaker forums, I greatly appreciate any help you all can provide!! If there is any other information that I can provide, let me know and I’d be happy to.

They will ask you to switch the X and Y module, or find matching modules. But otherwise yes, it’s grounds for replacement, but they will push back hard. @MooseJuice, what were the magic words you uttered? Lots of kicking / screaming? Support’s document has a troubleshooting procedure to diagnose, then directs you to contact support, not the most useful: What should I do if there is a 'clunk' sound during the Y-axes moving? – Snapmaker

They don’t manufacture the parts, they purchase subassemblies from a subcontracted vendor. It’s an unfortunate situation where their vendor has poor QA/QC and Snapmaker is unable or unwilling to hold them accountable.

I saw your post on Linui’s thread, and I don’t understand how that reverting esteps fixed the issue, aside from assuming there are many many things wrong simultaneously and now 2 wrongs have lined up perfectly to make it work right.

esteps is the most fundamental property of the machine - when the controller commands the extruder to move linearly 10mm (for example) then 10mm of filament is moved. If that does not match perfectly then everything else that assumes that to be true will be wrong.

The next thing is the flow multiplier, a factor you choose that the slicing software (like Luban, Cura) uses to convert a volumetric filament requirement (1 cubic mm, for example) into a linear amount of filament to be run through the toolhead. It’s not always 100% what the theoretical calc would be because of shrinkage, etc. Typically PLA is between .9 and 1.0, and different filaments will have different values. The way to check that is with a single walled extrusion, see here: https://teachingtechyt.github.io/calibration.html#flow

The variations you’re seeing can be thought of as small variations in over / under extrusion from layer to layer, so solving this is difficult as it effectively requires eliminating all variation to an acceptable tolerance. I would make sure the extruder extrudes smoothly and is not grinding the filament (slipping), there’s no partial clogs in the nozzle (do a cold pull: https://all3dp.com/2/3d-printer-clogged-nozzle-how-to-perform-a-cold-atomic-pull/). Make sure it’s not speed related, maybe try a print at 1/2 speed and see if it gets better. If it is at least different maybe experiment to find the optimal speed. I’d gander around 40-50mm/s (2400-3000mm/min).

It could possibly be thermally related, and Luban doesn’t really have much fine grained control over how filament is laid down. If you use Cura you can vary the minimum layer time, which ensures you aren’t laying hot filament down immediately over hot filament that was just laid down, which could result in a small amount of sagging on a single layer, like you’re seeing. Simplify3D (and maybe Cura but I don’t know) gives you control on finer details, like does each layer traverse the same path meaning each laid down filament has at least several seconds to cool, or does it use an optimized path for each layer that is faster, but can result in hot filament being laid down immediately over the previous layer which can cause surface issues sometimes. The minimum layer time in my opinion should be 5 seconds to give adequate cooling time, sometimes I use 10s for very small parts.

Note, you don’t have to print the whole thing - if you notice the problem exists or not in the first 5mm of each test, then you can stop it early to speed up the change-test-repeat cycle.

I’m sure the module is tight to the toolhead. Is there up/down wiggle in the linear module? If so, it needs to be opened up and tightened internally, there’s a support document on this: What should I do when the carriage/slider of the linear module is loose? – Snapmaker.

Brent, thank you for your response. I’m still relatively new to all of this, as this is my first major 3d printing issue I’ve run into, so your response helps me out a lot. I’ll definitely get support to give me a linear module that matches the others’ speed, I’m guessing threatening a chargeback to my card would be most effective(It worked before), but I fear that enough time has passed for me to use that option. Any other means or tips to get support to comply with giving replacement parts would be appreciated from anybody!

I’ll update as soon as I figure out the e step calibration, which will most likely be tomorrow, I’m really hoping it’s an issue with that. I’m completely out of ideas after this forum post. It’s good to know that there are knowledgeable people on here such as you who can at least identify and tell me what my problem can be categorized as. Gives me a bit of hope with this. I’ll give an update after I do a cold pull as well, I’ve never done that either.

I have heard various noises occasionally coming from my machine. Support seems to think its both/either the y axes not being matched in speed, or the 3DP module having an issue retracting filament during the print. I have checked the 3DP module and attached linear modules for any movement up/down/sideways, and have found it all to be in a stable position.

I have attempted a calibration cube at a full 25% print speed, and it produced the same issue, with a slightly different pattern, so I can say that slowing down the print does not help unfortunately. I have also tried drastically changing the infill and printing profile used to print the cubes, to no avail.

The only slicer that I’m familiar with is Luban, and I haven’t looked into cura or any of the other popular slicers, maybe that ill have to change if my issues still persist.


Here’s the image showimg my slowed cube

I’d recommend biting the bullet and diving in to Cura. When Luban works it works well. When it doesn’t work it doesn’t give you the fine grained control you need to troubleshoot issues like this. Doing simple tests will be a good way to get started, now seems as good of a time as any for that to me.

Snapmaker posted Cura profiles, but their start and end gcode is dodgy, here’s some better code you can replace it with: Snapmaker PLA test results - #4 by WilliamBosacker

image

  1. Before addressing the horizontal lines you need to address the vertical variation - it’s more fundamental and less likely to have you spinning knobs in software endlessly with no change.

Calibration will get you through that. It’s poorly calibrated now.

  1. That bit at the bottom is called elephant’s foot, it’s also characteristic of overextrusion, but happens just at the start. It can be minimized but probably never eliminated. Once the machine is extruding the correct amount it can be fine tuned by your Z height calibration, which is incredibly sensitive. The first layer is by far the most important.

I walked through my calibration order here: Snapmaker 2.0 Initial Calibration Settings / Experiences

1 Like

Hey, I agree with Brent about the calibration.
Additionally to calibration of e-steps I would suggest to print a temp tower.

Got a ping from this other thread and it reminded me about filament quality - this in part could also be explained with poor quality filament.

I’d recommend ditching Snapmaker brand PLA and trying another brand.

Regarding the magic words to get parts replacement from brent earlier on in the thread (sorry i have been semi comatose from back pain issues) - simply persistence unfortunately… They would after awhile stop replying and I would just bring it back up again and continue to show them my issues.

Funny enough right now we are mid troubleshooting my controller as a potential source of problem, and they had me load the firmware that moves the 3dp module to add-on 1 port -which did not work right at all. the nozzle would heat and the fan would work, but it would not extrude. They have not responded to me since i confirmed the gear was not spinning and reverting to the regular firmware and regular port was ok. This essentially means that my add-on port is bad, and they are currently trying to let it slip away so they dont have to replace it because of that (which frankly, i dont think id try to make them do so, but technically they should incase something needs that port down the road…

They stated they doubt my controller is the source of my issues, and honestly ibelieve that to be true despite other peoples experiences. I think the firmware is funky and needs something addressed that doesnt get encountered when only using luban, likely some normal ass value someplace that luban doesnt let you use, and I surmise it relates to line width. (intentional or not, I cannot say, but i suspect they knew this was a thing and have luban built around it). So print my part at 2x the time with a lesser quality is the answer I guess.

My knowledge on these brushless stepper motors is admittedly limited, but it may simply be some slight movement that the motors are unable to accommodate consistently causing the issue. Hence everyone’s “multiple of 4” commentary.

For my replacement part journeys Ive had, I think the fact that I purchased spare parts to have on hand helped my case, but they tried to use that against me too at one point saying I don’t need any more because i bought spares.

Eventually they decided to give them to me anyhow.

One of the best things I can suggest to have a good experience with 3d printing on the snapmaker is buy “good” filament - matterhackers or prusament.

1 Like

Alright! Got Cura finally working on my linux system, and I’m not entirely opposed to getting to know this software. It does seem extremely customizable compared to Luban, although I’m definitely going to be keeping Luban on my system for now. I did an e step calibration, and it seemed to make the issue a bit better! The random over and under extrusion only happens on the x face of the calibration cubes now. I’m assuming my only issue now is that of mismatching y axis LM speeds, but I could be wrong. Thanks for your help Brent, I’m finally Starting to get my print quality back. I still seem to be getting quite a bit of elephants foot I believe, and some strange offsets in multiple layers at a time, but it’s starting to get better.

I’ll be looking into a temp tower before long, as I’m just getting familiar with Cura. I wasn’t able to do variables of anything like tenp layer height or otherwise with Luban, so that’s all very new to me. Thanks!

Oh yeah I only used the included roll of SM filament, and have been going back and forth between whatever is the cheapest at the time on amazon. I’ve tried a variety of filaments included Jayo, Sunlu, Overture, Hatchbox and a couple others. Might be about time to settle on a favorite…

Thanks for the reply MooseJuice, after calibrating my printer using some new processes I’ve learned the print quality is better but I am still getting occasional clicks from underneath my bed. Going to keep pushing to get a linear module that Matches my others’ speed to a tee. If I’m paying $1500 for a machine, I’m going to get a LM that was manufactured correctly without any defects. Sad to see such dissent from the customer base and the company, especially on the forums. Hopefully rhwy improve with time. I wonder if perhaps the new revised linear modules will rid us of these persistent issues with the LMs. Only time will tell I suppose…

i would hope so but im afraid of the cost on them :expressionless: do i wana drop another 500 bucks on this machine to replace the modules?

ps: check out matterhackers build series filament, is higher quality and cheaper than most amazon but only sold on their web page

1 Like