Octoprint on Snapmaker 2.0

Hi,

Is anyone able to use octoprint on Snapmaker 2.0? If so, what settings did you use for the connection?

I can’t seem to connect to the printer. I’ve even change the cable.

I’m using it with Serial port set to AUTO and baud rate 115200. It is great - would be even better if Snapmaker would throw some resources at it and write plugins to support the laser, CNC, filament runout detection, power loss restart, etc.

Yep same as JCKnox, Auto serial port and 115200 for baud rate and hit Connect.
Do you have a printer profile set up for it?
Have you had OctoPrint running for another printer? Are you running on a Pi or another computer?

It would be even better if they developed the built in wifi that we paid for so it worked as well as octoprint does.

1 Like

It would be even better if they developed the built in wifi that we paid for so it worked as well as octoprint does.

It’s completely capable of doing everything that you use octoprint to do. Just needs to be programmed. They’ve been promising to open source everything. Re-affirmed that along with rotary announcement. Maybe when they do that some people will be able to get it to reach it’s full promise.
-S

Hi,

I have a raspberry Pi with octoprint installed on it.

I’m still getting an error when I try to connect to the raspberry.

1 Like

@sdj544 I agree, its capable but not currently implemented. My main point is that I would rather the SM team work on the built in wifi over adding octoprint integration.

The only time I had the problem you are describing, my USB cable was not fully plugged in to the printer. Also, make sure you are plugged into the mini USB connector in the SM, not the USB connection used for the thumb drive.

To troubleshoot, open a terminal to your raspberry pi, disconnect the USB cable to the printer, then reconnect and run dmesg in the terminal The last few lines should show you if the pi is detecting the printer and what port it is using. In my case, it is ttyUSB0. If dmesg isn’t reporting any serial connections, you need to verify that your cable is good. If it is, then try connecting directly to the printer with a PC to verify that the USB port on the SM is good.

If these steps don’t get you anywhere, maybe try asking at https://community.octoprint.org. They will know more about Octoprint problems than this forum.

1 Like

Thank you for the feedback.

The mini USB is connected to the controller and the USB in the raspberry Pi. I’ve even changed the cable and the results are the same. The cable works when I connect it to my pc via luban.

I will test it via terminal and see what happens

Someone mentioned in a another thread, if you touch the touchscreen, before connecting with octopi, it won’t connect. Maybe that helps?
I got it working with my A350, and seems solid.
Be sure you don’t have the GPX plugin(like if you used your Octopi with an old FlashForge or MakerBot printer and tried to just move it over to the Snapmaker 2.0). I found GPX gets in the way, so I disabled it in the Plugins manager.