OctoPi for the Snapmaker?


#1

Hi All - I’m fairly new to this forum. I received my Snapmaker about a month ago and so far have loved using it. I was looking into a way to monitor prints remotely and came across OctoPi. I love the fact that you can launch prints and with a web cam watch the progress and even stop the printer should something happen and the print isn’t going well.

Has anyone been able to get OctoPi working with their Snapmaker? I set up OctoPi on a Raspberry Pi I had laying around and have launch some prints with it but have come across a number of issues with the Snapmaker not responding and then not able to reconnect to OctoPi with an error that says not able to Detect Baud Rates.

Hoping someone here has used OctoPi and has some tips on how to properly set it up.

Thank you.


Octopi software
#2

New to OctoPi. In fact, I had just setup OctoPi last night and successfully did a test print. I do not have a webcam attached to my Pi yet, so I’m limited to sending print jobs and monitoring the print remotely via the dashboard or Cura.

I followed these directions provided and it worked after initial OctoPi setup through the dashboard.

@fio316a This is how OctoPi is setup for me if you want to compare to your setup:

  • Pi is powered by a dedicated power adapter.
  • Pi is connected to the USB-B port on the Snapmaker (white port on the controller).
  • No printer profiles setup on OctoPi.
  • Slicing is done on the desktop using Cura.
  • Prints are sent to Snapmaker using Cura using the “Connect to Octoprint” option.

There are a few other members who has more experience on OctoPi. @nmohnot @trampi3 care to chime in?


SnapLinks -- Wiki
#3

kelvin8r is spot on with his reply. Well done! :sunglasses:


#4

Thanks for the replies. I will try using Cura and print with OctoPrint feature. I wonder if my issue, stems from setting up a printer profile in Octoprint for the Snapmaker. I do all my slicing on the desktop version of Cura but then would upload the gcode to Octoprint and open and print from there. After a while I’m getting issues where the Snapmaker stops responding to the Octoprint server. I actually end up buying shorter USB-B cables to see if that helps.


#5

I’ve typically not had any issues with SnapMaker not responding to the server with one exception.
If I use the touch screen to perform some actions like jg mode, change filament etc, and forget to go back to home. In such cases I go back to the home menu on snapmaker touchscree and then disconnect reconnect the printer.
Side note: I tried manual “extrude” from octprint server but that didn’t seem to work. I did not spend any time debugging, or even attempting a second time. Will try the controls later (fan on/off, jog axes, extrude etc)


#6

I think my controller is shot, I haven’t been able to print for about a week now as the Z axis isn’t raising up and the prints are just getting ripped apart by the extruder due to this. Once I stop the print, I can’t jog the Z axis at all but X and Y work. This is without even using Octoprint and simply using the flash drive. I can shut off the unit, leave it off for a while and the Z will jog again, but prints continue to fail. Once I get a response from support and hopefully a new controller, I will be able to check if Octoprint is working better.


#7

@fio316a sorry to hear about your controller. That definitely puts a damper on any further exploration with Octoprint. Keep us posted and hope you can continue very soon.


#8

I found 115000 baud rate to work. I don’t like leaving it on auto detect, so I found settings that work. Only issue I had was the print head crashed into the part at the very end of the print melting a big hole in the thin test cube I printed. Looked at the gcode and I don’t see why. It’s similar to other prints I’ve done without octopi.


#9

So tech support said my controller’s port 5 is defective and that I should use port 4. So that’s what I’m doing and Iam able to print again. However, IMO, that’s not a good resolution but I’ll have to take it up with them. As for Octoprint, I’m able to connect with auto detect perfectly fine and the printer has been staying connected but I haven’t printed from it since changing to port 4. Though I did notice, if I disconnect from OctoPi using the disconnect button, I can’t reconnect to the printer and get the baud rate detection error. I then have to power off the printer and leave it off for about a minute and power it back on. Once I do this, I can reconnect.


#10

I have just set my printer up with OctoPI. Really simple setup.

I made myself a case for it all - even with the camera in an illuminated tower so I can see what’s going on even when I’ve turned the lights off. I can even monitor this on my phone. So cool!



image


#11

I hooked up the Snapmaker to a smart plug so I can turn off the printer remotely after I’m done printing monitoring and printing. This is a workaround until a sleep function is built into the Snapmaker firmare.

However, if a sleep function would be built into a future firmware, how would the printer wake-up from sleep via OctoPi?


#12

When something goes into a sleep mode it basically is shutting down all non-important systems. The USB interface is an important system. As such OctoPi would not even know the SnapMaker is asleep. As soon as the OctoPi issues an actual command that requires the SnapMaker to wake up, it would.


#13

I set up OctoPi last night and was able to control the axis movements and heaters manually from OctoPi.
This morning I am trying my first test print sending G-Code directly from Slic3r. It is working flawlessly so far.


#14

Don’t forget to stop by and thank Gina!


#15

Today I had my first failed print while watching my octopi printing. Really useful to be able to monitor it and stop it remotely if it goes wrong. If I hadn’t done that I would have been in for a mess when I got home!


#16

I have setup my octoprint to also do the slicing using Cura 15.04 and it works well.


#17

So this is the issue I end up having. So when my Snapmaker turns on initially, the OctoPi connects with no problem. After a little bit, I end up getting an error saying that it’s disconnected due to too many time outs.

Comm%20Error

Then when I try to reconnect, I get the following error:

Baud%20Error

Here is my printer’s setting in OctoPi:

3-9-2018%201-10-03%20PM

3-9-2018%201-10-52%20PM

So this is the same issue I encountered long ago. I end up ordering a new USB cable and a shorter one as I read somewhere that the length could be an issue. I’ve tried to connect using the following and this does not help at all.

3-9-2018%201-08-07%20PM

Has anyone encountered this? Is there something I’m doing wrong?


#18

It seems like the Snapmaker controller has trouble talking to OctoPrint through the USB port and to the touch screen at the same time. I am now running a fairly lengthy test print through OctoPrint with the SnapMaker touch screen disconnected. No comm trouble so far! :pray:


#19

Thanks!! Let me know the outcome. Wouldn’t be ideal if I can’t use both the screen and Octopi but I rather have OctoPi running so I can monitor builds when I’m away from home or even in another room of the house.


#20

@fio316a while a print with OctoPi is active, the touch screen on the Snapmaker will be disabled. However it will still display the build plate and hotend temperatures. However if there is no active print, I believe you have access to other functions like changing filament and calibrating the print bed.