Newbie Problems with Laser Engraving

Okay, so I got my Artisan a few weeks ago and I have successfully 3D printed various objects. However, I followed the instructions to the tee for setting up and using the laser cutter but I am experiencing several problems: firstly, after loading the background on wifi (doesn’t load via serial port annoyingly) and ensuring the image is properly calibrated - when I try to ‘start the job on Luban’ it gets anywhere between 1% and 50% loaded then freezes. Next problem, when I run the boundary the toolhead goes anywhere except where it should go! I’ve tried sending the job via serial port and USB stick but the same issues arise. I must have reset, calibrated and recalibrated the machine a dozen times and got through countless sheets of paper but after several hours of trying I am getting nowhere. Has anyone else experienced the same problem and if so is there a solution? Thanks in advance for any guidance on this.

Hope this helps:

Thanks but I tried all this already (many times with differing results). I have since figured out how to just use a USB stick and process the job without the camera feature. Thanks again for your help.