Completely dead:(

So our 350A is only 2 days old (after 2 month wait), we successfully printed a few small test prints with no problems. Then I started another print that was to take 3 hours. About 20 minutes in the machine just stopped, black screen, no movement, no sound from print head and no pulsing light on controller. Only the main box was on with the fan running. Tried restarting, checked cables, even tried to connect to my laptop via usb… nothing…:frowning: afraid it will be another 2 weeks to get a response and another month or 2 for replacement parts​:weary::man_facepalming:… not a good start.

That sounds not good.

Please describe a bit more detailed.
For example like this:

Loaded luban generated gcode over wifi, printed from the touchscreen…

Now your machine does not turn on?
Power supply works, no light elsewhere?
Is the power plug from the power supply to the machine correctly assembled?
Could you check the cable with a Ohm-Meter, to see if the cable is broken?

This was about the 12th print we had made since assembly just 2 days prior. 1 was the benchmark piston engine print in place. And the rest were Among Us characters and the one that it failed on was a cybertruck. All done via Luban on a laptop sent to the machine over WiFi. All worked perfect except for one minor goof where a tall part separated from the heat bed.
I had loaded 1 part of the cybertruck chassis, the same way. Nozzle temp 205, PLA, bed up to 75 temp. It was working fine. I walked into the other room after making sure it has started fine. About 20 minutes in I didn’t hear the arms moving anymore, just the steady fan from the power supply. Came in to find it just sitting there, dead screen, dead printer, no light on controller, only the power adapter had power. The head was still in place on the bed so it didn’t have a chance to retract. I used an outlet tester to check for power, it beeped on the line from the wall to the adapter but not the line from the adapter to the controller.( not sure if that’s a valid test) but there was clearly no power at the controller. Tried unplugging for a bit, tried connecting directly to the controller with the laptop… nothing… Had to manually lift the z axis to get the print head off the print. Filed a warranty request already… was planning on doing some of my own designs on it this weekend😩

I am sorry for you, unfortunately cable meassuring is the only thing you could do at the moment:

I checked with ohm meter, there is power going through the cable to the controller, but zippo power from or life in the controller…

Anyone deal with Snapmaker with warranty or replacement parts? How long and painful is this going to be???

This is the thread you are looking for:

Normally support needs a few days to respond, I guess in case of warranty it gets a bit faster.
But you have to be fast, Chinese new year is coming and then all is closed for one month in China.

very slow and basic response from snap maker so far :confused: Don’t know how else to pester them, used Facebook , messenger, forum, support, warranty claim… ugh…

I don’t think you will be happy !!!
I ordered a spare part (nozzel) in the European store - tells me 3 to 5 working days untill shipment.
After 1 month there is no shipping information or tracking number.

The mails I send were answered within 3 to 7 days - information is — NOTHING !

I think there is no European store - only a website and the people at Snapmaker are absolutly overwelming. The people try to help but I think they are only a hand full.
They are not able to give a service for customers as we are used from bigger companies!

But if you can wait they are kulant.
My display was broken and they send me - without any question - a new one - ok. it last 6 weeks.