Machine won't connect to wifi

Wow. Severely disappointed in the Snapmaker 2.0. Yesterday I set it up for laser module but it failed on Camera Capture. But that’s another issue that I sent email to support about.

Today, the machine won’t join my wifi. Yesterday it did, today it won’t. I’ve rebooted several times. Using the touchscreen I choose my network and enter the password and nothing happens. The screen just goes back to the network choice page.

Any advice on how to get this thing to work consistently?

Days gone and no reply to my support request. No reply to this forum request for help. My snapmaker sits unusable.

Great job with customer support, Snapmaker. Do you not have anyone monitoring your support email or this forum?

I had to setup my network once on the touchscreen.
I am no network or wifi specialist so, may try to open your network and check if you could connect, again?

I had the same problem, clicked the three gears (settings), then config and finally “reset all user settings” (the red button) and the wifi screens came back and I could connect.

I’m sorry to hear that your Wi-Fi connection is not working.
In my case, after I made the following settings, I no longer have problems connecting.

Register the MAC address of the Snapmaker 2.0 machine to the router.
Specify a fixed IP address as the MAC address unique number in DNS.
Register the MAC address and static IP address in the Wi-FI repeater.

I’m sorry if this is not the information you want.

1 Like

I have the same issue and I have done the same thing as you mention here (static IP). There’s another option, the controller runs plain android underneath, so you can actually plug in most USB ethernet adapters into the USB-A port and then connect it with a wire to your network.

Unfortunately, luban will not autodetect, but most routers will list what’s connected so pull up that screen, take a look. Plug in the USB adapter and see what was added. Then use the + button in Luban to specify the IP address and off you go. Works great and is 100% reliable.

It seems that the wifi announce feature get stuck for something. What I mean is that my printer will not show up, but if I reprovision my wifi (using UniFi AC Pro around my house) it will sometimes get out of this state.

Mind you, my SM2.0 is connected and has even done firmware upgrades, it just won’t announce itself or accept incoming connections from Luban, which is super frustrating. SM support even replaced the controller itself and yet I have the same issue.

Update, if you KNOW the IP address of you machine, WiFi or Wired, you can simply connect with the + sign in Luban

I updated to the new firmware for my A350 and noticed after update I was no longer connected via wifi, finally got round to it today and had trouble connecting to 5ghz, and finally connected to 2ghz don’t know if its related. Don’t even know if it can connect to the 5ghz but it shows up.

During initial setup, I was able to connect to a password-protected wifi network, but on subsequent use I was not. Connecting to an unprotected network works just fine.

There are two problems with the wifi connect screen on the controller:

  1. selecting a network requires you to re-enter its password every time

  2. there is no way to “forget” or prevent automatic connection to a network

Not sure whether there should be an intermediate screen for each network (make default, option to re-enter password, connect automatically) or a small menu that pops up when you press-and-hold the entry for a network. Touchscreen interfaces are not my thing; I don’t know what the best-practices are.

Today I had a similar problem. Without changing anything in configuration my snapmaker A350 didn’t recognized my Wifi any more. The SID even didn’t show up under Wifi settings.
I was able to fix it by changing Wifi setting for channel width from “Auto (20MHz or 40MHz)” to “20MHz only” on my Wifi router. Then Wifi showed up again and worked.

i just went back a menu and then forward again and it worked. Not sure why but it worked.

Pretty sure it can’t connect to 5GHz. I could only reliably connect to 2.4GHz and to luban by using a static IP.