Luban Wi-Fi connectivity issues - solved

So, I just got my first J1S, I am not new to printing, but I am going to assume that whoever reads this, like me has had issues connecting Luban wirelessly from my slicing computer to the printer.

The following steps are what I did to fix this:

Estimated fix time: 5 Minutes
Works as of 8th August 2023

  1. power on your printer, in the settings find the Wi-Fi IP address - mine was

  2. Open Luban, try adding a new printer from the workspace window using the + icon - it probably won’t work… again…

  3. Open “Windows Defender Firewall” under the “System and Security” section of the “Control Pannel” menu.

  4. click the " Allow apps to communicate through the Windows Defender Firewall" - This opens a new window.

  5. in the new pop-up window:

5a) first scroll down the list see if you can find “Snapmaker Luban” - if present make sure private/ public network is checked as needed - - - Note: It’s probably not there… but if it is, go back to step 2.

5b) if “Snapmaker Luban” is not listed click on “change settings” then click on “Allow another app…” which opens a smaller pop-up window again.

  1. click on “Browse…”

So, my copy of Luban was not located under the default “Program Files (X86)” but rather the regular “Program Files.” If you just reinstalled the program take note of where it went, if not, you are going to have to do a search inside of your “Windows (C:)” to find it.

  1. once you find it, select the “Snapmaker Luban” application and continue on. That small second window should automatically close taking you back to the “Allow apps to communicate through the Windows Defender Firewall” - check to see if you can find Luban and select the appropriate level of firewall access as in step 5a.

  2. congratulations you should now be able to go back to step 2, wirelessly connect and follow the remaining onscreen Luban/ printer instructions.

Hope this helps