Wifi link from computer to Snapmaker

WIFI link from computer to Snapmaker has stopped working. Tried refreshing WIFI password in Snapmaker but Luban says “Failed to connect. Invalid authentication.”

Tried 100 times.


Have you looked at your router configs as it’s possible the network has been reset or the router is blocking your login.

Internet service where I live is poor at best and often intermittent. I just had to connect with an usb cable. I ended up using a 15 year old laptop. It has enough memory, to free up my computer.

Only other issue was that I hade to turn off the sleep/hibernate mode on the computer. It has to stay awake throughout the entire print.

I’m having the issue with “Failed to Connect- Invalid Authentication” as well. It started happening after I updated to the latest version of Luban about 2 weeks ago. I have successfully connected to the Snapmaker A350 printer via wifi from another computer but can’t from the one I need to.

The printer is always found and is displayed in the Connection dropdrown (correct IP address etc.). Just gives the error when I try to connect.

I’ve also reset the wifi on the printer and uninstalled and re-installed Luban which didn’t fix it.

Any ideas?

Exactly the same problem with the same symptoms and same info when attempting to send the file. Also re-done the wifi connection. The problem is obviously in the latest version Luban!
A solution please!!

I have done all of those things, resetting the IP, etc but no results. Problem only started from Luban 4.3.1 and still occurring with 4.3.2 (you’d think they would have solved that in the .2 version?)

Very frustrating as I have to send by USB and cant run the printer from Luban on screen. Those clever people must be able to fix it? Is it possible to go back to earlier version of Luban?

Cheers Roger

Snapmaker Support just suggested to update the firmware on the printer.
I’ll try this (probably on the weekend) and see if it works.

I reinstalled an earler version of Luban 4.3.0 and the wifi link works perfectly. The problem is obviously in the 4.3.1 /4.3.2 versions.

Hope Luban can sort it out.


I reinstalled an earlier version of Luban 4.3.0 and the wifi link works perfectly. The problem is obviously in the 4.3.1 /4.3.2 versions.

Hope Luban can sort it out.



I have the exact same problem. I was silly enough to update to 4.3.2 and now my wifi will not authenticate to the machine. At a loss - can Luban get this fixed?

Where did you find/install back to 4.3.0?

Here you go:

Thanks! Reverted back and the WiFi connection now works again.

What’s your firmware version?

Hey, try the latest firmware and the latest Luban. The failure might be the compatibility issue of older firmware and newer Luban.

Maybe that might solve the Authentication issue, but the latest version of the SM firmware has WiFi issues… dropping connection. I just sit and watch the Settings>WiFi screen and see the WiFi connection come a go. Sometimes the SM doesn’t show any available WiFi stations. But then shows ten and reconnects. Then will randomly disconnect. Never had this issue with V1.12 firmware.