Laser modele doesn't transfer with Wi-Fi

Hi There,

When I use the ‘Send to Device via Wi-Fi’ button, the Snapmaker A350 doesn’t receive the file transfer.
It does work with the 3D print function. Luban 3.12.3 is connected with the machine but shows an orange clock symbol and keeps showing the ‘Sending File’ pop up. Meanwhile the Snapmaker screen does not show a filetransfer request.

Also the USB function doesn’t show the G-code file when I put the file onto it. Should I make a special folder in the USB or something else I’m doing wrong?

Where are you creating the file?
For laser they need to end in .nc
The laser head needs to be hooked up to SM or it won’t accept them wirelessly.


I’m creating the file in Luban and the USB contains an .nc file. It still shows no files in USB mode.

With hooked up you mean that it is connected to the main block, right? I checked the cables, plugged them in and out, restarted the SM and it says it’s connected. But still no file transfer screen when I send it to the device by Wi-Fi.

It also works fine with commands like ‘Run boundary’ and ‘Go to Work origin’. Also the Camera capture works normally.

Are you using the SM provided flash drive?
Have you had success seeing any files on it (3d, laser, cnc) on SM?

What version of Luban and firmware are you using?

Yes! With the provided SM USB it works perfectly, thanks!

I’m using:


When using the camera capture, the photo aligns at the beginning of the X and Y axis. So the left corner of the photo, wich I want to print aligns doesn’t in the middle.

I then used that snapshot as a reference for the photo to be lasered. I am starting to think that when I do this the picture is out of reach of the bed and therefore cannot accept or understand the file transfer. I can’t test it now but I will let you know when my SM is ready lasering.

The camera capture does some weird stuff in preview (and in general)
It shows as being in a different place than you would think compared to cnc or 3d but it still ends up in the middle.
I personally found it wasn’t worth the time or effort. Easier and faster ways to position things.


Indeed, it does. In my view the camera or the camera function in the software is not (yet) reliable and needs some bug fixes.

Wi-Fi transfer worked just fine when I centered the image and worked within the reach of the bed.
Thanks for the help!