Laser - How to stop Luban from filling in interior holes with bitmaps

I was trying to create a business card. If I use Vector, the preview looks great and gives me the flexibility I need to laser the material. BUT, Luban is filling in interior holes in letters like “D” and “e”. Am I doing something wrong? I believe this worked correctly several versions ago.

I am importing a hires PNG. I have tried converting to SVG, but the graphics are not recognized by Luban, only the letters…and the font is wrong.



Thank you.

The only way I found was to put a small line so the hold wasn’t an actual hole. Ie. connect the hole to the outside.

Have you found a solution?

1 Like

I have been using black and while mode with some success. I have just found that vector seems to give slightly crisper text.

Your idea sounds like a good option to try. Thank you. I will make the line as small as possible without luban ignoring it.

Inkscape (freeware vector drawing software) has a feature that can ‘trace bitmaps’ and convert them to vectors - strokes, paths, etc. You have to play with it and fonts might not reproduce perfectly if you zoom way in, but it does a generally good enough job and you have lots of cleanup options thereafter. Or you can remove the text to capture the drawing, replace the text yourself and pick a font.
But in a vector program you must convert the text from a text object to a path object, basically in the language of SVG it needs to be a series of line equations not “these letters in this size at this location and orientation”. Then you can vector cut them.
Using the font creation directly in Luban for me results in both inner and outer outlines of the font being cut, even selecting vector and “on the path”.
(I’ll confess to not being a graphic artist and still getting somewhat lost between ‘path’ and ‘stroke’ terms…)

1 Like

Thanks for your input. I’m new to all of this but having fun learning. I downloaded SVG files but when I put it in Lunban to set it all up and get a G-code I run into issues. Not major but frustrating. For example; when you get to “Preview type” the Toolpath looks great. Click on “Simulation” and you now can see an edge line that cant be seen otherwise…That secret squirrel line is picked up and carved :frowning: , I don’t know how to stop that. Can anyone help?

I’m not sure what you’re asking.
In Inkscape you do want to go to Document settings, and pick (paraphrasing, not looking at it right now) “resize document to fit (selection or content)” and apply that before final SVG save. This makes sure that there’s not a larger than the actual vector graphics rectangle that forces the position of what you’re trying to cut or engrave, and might also get interpreted as a cut line.
Otherwise share a file and maybe someone can make a suggestion?

Thank you for even answering. I took a screen shot of an example to better explain my issue (Hope that helps, lol)

I’m still new to all this and even understanding the software but I’m a quick study so any thoughts, opinions, explanation are VERY WELCOME Please and Thank You :slight_smile:
BTW, This is on a Round not a Square project piece

Would you be willing to share the SVG? I’ll take a look in Inkscape see if I can see any source for that…

Sure But How do I attach it here?

Looking at your file list, one is an SVG and one is a JPG. I wonder if Luban is simply taking the edges of the PNG and making lines of them. You can import it into Inkscape, right click > trace bitmap and it’ll make an svg of your JPG.
A bit more involved tutorial on this can be found here:

It would be a good idea to click the little eye on the toolpath list to disable one or the other and see which path is actually making the lines.

OOOH I see, Well how about that! Thank you so much. I appreciate you taking the time to assist. I will try it out . Thank you so very much. :smiley:

Attach files the same way you uploaded the image. I got the .cnc you tried to send me directly but need to see the .svg and .jpg in your Object List in your picture.