How do I import this test file for laser

I’m trying to import a test https://www.thingiverse.com/thing:2243854/files
The file I’m importing is a vector. The problem I’m running into is when I import the file everything is there like it should be. However, when I preview, it removes all the text and almost everything. I’m posting an example of what I’m seeing. On the left is the image before preview, the middle is after the preview. The one on the right is the cut file, and I think that file seems to be OK.

Anyways, any tips will be welcome.

1 Like

as I understand that not all svg’s formats are the same. I would send a message to support@snapmaker.com about the problem.

Open the file with a vector graphics program like inkscape and transform the text into a vector path.
Search the internet for how to do this.

Then the Snapmaker software will recognize it. Try diferent svg-formats on the export from Inkscape until everything is ok.

I don’t know if Snapmakerjs/Luban can handle the scaled infill in vector mode.

But for the gray scale test I suggest to convert the svg into a png file.
This is even easier.

1 Like

Great advice… I love learning from experienced users.

Have a great day

Doug

Hey, maybe you do it with Laserweb like it is shown in the description:
(The Software is free)

To use this in LaserWeb, I do this:

  • Open mtc-engrave.svg in Inkscape and enter the details of your test print (material, speed…)
  • Export mtc-engrave to PNG format (File / Export as PNG).
    Make sure to select page as export area and use the same DPI as in LaserWeb!
  • Open LaserWeb
  • Import mtc-cut.svg for the cutting lines
  • Import mtc-engrave.png for the raster engraving
  • Change the settings in LaserWeb according to your test
  • Fire! :slight_smile:
2 Likes

I didn’t know that. Anyways, I sent them a message.

For that I can just easily make a png of that area, and go from there. In fact, I have a better idea with that since I can take a image of something small, do multiple of them on the same run. Each at different speeds.

When dealing with grayscale to get better images. Do you change the dwell time or the work speed? I’m finding I have to do 3 or 4 runs to get a good picture. Here is an example of what I’m working on. https://photos.app.goo.gl/7Kk6rPaGsRC7jwGa8
Increased the dwell from 5 to I think 9 for the one on the top, and I decreased that to 6.5 for the bottom. The one at the bottom that is 2 passes, but the one on the top is 1 pass. I increased the dwell time because I found even with changing the work speed from about 1000 to 250 it didn’t help much at all. And it took 3 runs with a dwell time of 5 to get something you can at least understand what it is. Like 1 run you couldn’t really tell anything happened outside of darker parts. Oh and this is with the power level at 85%. I’ve tried 100%, but after the first layer is burnt. It seems to burn really quick under it. I’m using this btw https://www.amazon.com/Unfinished-Wood-Pieces-Decoration-Supplies/dp/B07C4YFB7Q/ref=sr_1_4?keywords=diy+wood&qid=1582142583&sr=8-4 I think they are cork, but I’m not 100% sure.

1 Like

hahahaha, welcome to the “black art” of lasering , trial and error your settings will teach you a lot. NOTE: you will have to change the settings if you change the material being lasered. Sometime even the same material requires changes. I have experienced wood of the same type requires changes; due to its grain and moisture content.

Keep having fun

Doug

The lost parts are mostly text.

tags are not supported in Luban currently.
Convert all texts to paths can solve the problem as a workaround.

1 Like

Hi,
have tried to use Inkscape,
all .svg versions and the .png,
but no result…
The .svgz was calculating more than 10 minutes then it should do the g-code,
afterwards i quitted… Only 71kB, so should be quick.
The others show nothing or only tiny squares and circles…

Do you want to send me your file to let me have a look at it?

Hi,
would be great if you give it a try.
Can i add it here,
or via a “normal” mail?
Regards,
Wolfgang

Hey,
I have big troubles with .svg cutting templates in Luban. Luban does not find the vector’s correct etc… So I read you use LaserWeb. What configurations I have to do that I can use Laserweb? What Setting are neccasary in LaserWeb to cut on Snapmaker A350?
Thanks in advance…
Chris…

Hey @chris0803, i don´t use laserweb, sry.- It was just to load/engrave/cut the testfile from the thread creator.- i usually use snapmakerjs to engrave and cut things.- i have snapmaker original so i am not sure luban is fully compatible yet.

may u attach the file which you want to cut?
which ending is your file?
May you test following file to load?
Following is .png


Following is .svg
Kreuz_SVG

1 Like

Hi,
have as well troubles with Luban…
Cannot load any file.
Have now tried your png, but after loading in workspace, nothing happens…
The svg is not donwloadable for me, think its only the “space” for it.
May i attach a file from me, and you try it?
Tried with inkscape, but cannot load it as well.
The svg makes nothing, the dxf ( cannot upload here ) starts but has no ending…
Regards,
Wolfgang!
SM test4
PS: cant see my upload in the web, but have it here on my box…
Have here the file with name and the upload code, but not working…

share your file with dropbox, googledrive or other hoster, i can´t see it as well.
I think you could save my picture using, rightclick save picture.

Here is the link to the cross.svg:
http://ul.to/qeo5ei3e

1 Like

Hi,
hope that works…


The svg seems to be empty, the dxf i can open in irvanview, but its not what i have saved…
Cannot bring them back into inkscape…
But that makes no sense…

Sorry, i am only a silly user, but that sucks…
Why is it so complicated to transfer files???

What i tried:

Have no idee why its not working…
Originaly it should be possible to load it up as jpg into Luban, or?
My version is 11 days old, so up to date.
Same to inkscape…

1 Like

Hey, i simply loaded your Picture which you posted above and loaded it to luban using “vector”
After that i take the checkbox “fill” and viola, it looks great.


Maybe you describe more detailed whats your problem is, pls.

Hope this helps!

2 Likes

Hi,
if i load it, and fill it in,
i get some circles and lines,
have no screen shot software on this device,
will try to photo it…

so,
after some tries i got this, but laying 70 degree counter clockwise and looking shitty…
What means via vector?
Was using S&W as preset.
And dont understand why i gave it a size in inkspace, and now its much bigger…


And dont know how this will look lasered…